]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- rel 2
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # without boost-python2 support
8 %bcond_without  python3         # without boost-python3 support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.58.0
15 Release:        2
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  b8839650e61e9c1c0a89f371dd475546
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 Patch2:         %{name}-clean-gcc-flags.patch
23 # FC Patches:
24 # https://svn.boost.org/trac/boost/ticket/5637
25 Patch203:       %{name}-1.54.0-mpl-print.patch
26 # https://svn.boost.org/trac/boost/ticket/8870
27 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
28 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
29 # https://svn.boost.org/trac/boost/ticket/8878
30 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
31 # https://svn.boost.org/trac/boost/ticket/8881
32 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
33 # https://svn.boost.org/trac/boost/ticket/8888
34 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
35 URL:            http://www.boost.org/
36 BuildRequires:  bzip2-devel
37 BuildRequires:  expat-devel
38 BuildRequires:  libicu-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  perl-base
41 %{?with_python:BuildRequires:   python-devel >= 2.2}
42 %{?with_python3:BuildRequires:  python3-devel}
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  zlib-devel
45 BuildConflicts: gcc = 5:3.3.1
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
49
50 %description
51 The Boost web site provides free peer-reviewed portable C++ source
52 libraries. The emphasis is on libraries which work well with the C++
53 Standard Library. One goal is to establish "existing practice" and
54 provide reference implementations so that the Boost libraries are
55 suitable for eventual standardization. Some of the libraries have
56 already been proposed for inclusion in the C++ Standards Committee's
57 upcoming C++ Standard Library Technical Report.
58
59 %description -l pl.UTF-8
60 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
61 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
62 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
63 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
64 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
65 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
66 Raporcie Technicznym Biblioteki Standardowej C++.
67
68 %package devel
69 Summary:        Boost C++ development headers
70 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       %{name}-chrono = %{version}-%{release}
74 Requires:       %{name}-context = %{version}-%{release}
75 Requires:       %{name}-date_time = %{version}-%{release}
76 Requires:       %{name}-filesystem = %{version}-%{release}
77 Requires:       %{name}-graph = %{version}-%{release}
78 Requires:       %{name}-locale = %{version}-%{release}
79 Requires:       %{name}-log = %{version}-%{release}
80 Requires:       %{name}-program_options = %{version}-%{release}
81 Requires:       %{name}-regex = %{version}-%{release}
82 Requires:       %{name}-signals = %{version}-%{release}
83 Requires:       %{name}-system = %{version}-%{release}
84 Requires:       %{name}-test = %{version}-%{release}
85 Requires:       %{name}-thread = %{version}-%{release}
86 Requires:       %{name}-timer = %{version}-%{release}
87 Requires:       %{name}-wave = %{version}-%{release}
88 Requires:       libstdc++-devel
89 Obsoletes:      boost-any-devel
90 Obsoletes:      boost-array-devel
91 Obsoletes:      boost-asio
92 Obsoletes:      boost-bind-devel
93 Obsoletes:      boost-call_traits-devel
94 Obsoletes:      boost-compatibility-devel
95 Obsoletes:      boost-compose-devel
96 Obsoletes:      boost-compressed_pair-devel
97 Obsoletes:      boost-concept_check-devel
98 Obsoletes:      boost-conversion-devel
99 Obsoletes:      boost-crc-devel
100 Obsoletes:      boost-date_time-devel
101 Obsoletes:      boost-filesystem-devel
102 Obsoletes:      boost-graph-devel
103 Obsoletes:      boost-mem_fn-devel
104 Obsoletes:      boost-mpl-devel
105 Obsoletes:      boost-preprocessor-devel
106 Obsoletes:      boost-program_options-devel
107 Obsoletes:      boost-ref-devel
108 Obsoletes:      boost-regex-devel
109 Obsoletes:      boost-signals-devel
110 Obsoletes:      boost-spirit-devel
111 Obsoletes:      boost-statechart-devel
112 Obsoletes:      boost-static_assert-devel
113 Obsoletes:      boost-test-devel
114 Obsoletes:      boost-thread-devel
115 Obsoletes:      boost-tr1-devel
116 Obsoletes:      boost-type_traits-devel
117 Obsoletes:      boost-typeof-devel
118 Obsoletes:      boost-uBLAS-devel
119 Obsoletes:      boost-utility-devel
120 Obsoletes:      boost-wave-devel
121 Obsoletes:      boost-xpressive-devel
122
123 %description devel
124 Header files for the Boost C++ libraries.
125
126 %description devel -l pl.UTF-8
127 Pliki nagłówkowe bibliotek C++ Boost.
128
129 %package static
130 Summary:        Static version of base Boost C++ libraries
131 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134 Obsoletes:      boost-static < 1.33
135
136 %description static
137 Static version of base Boost C++ libraries.
138
139 %description static -l pl.UTF-8
140 Statyczne wersje podstawowych bibliotek C++ Boost.
141
142 %package python-devel-common
143 Summary:        Boost.Python development headers
144 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}-%{release}
147
148 %description python-devel-common
149 Headers for the Boost.Python library.
150
151 %description python-devel-common -l pl.UTF-8
152 Pliki nagłówkowe biblioteki Boost.Python.
153
154 %package python
155 Summary:        Boost.Python library for Python 2
156 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
157 Group:          Libraries
158 Requires:       python-libs
159
160 %description python
161 Use the Boost Python Library to quickly and easily export a C++
162 library to Python 2 such that the Python 2 interface is very similar
163 to the C++ interface. It is designed to be minimally intrusive on your
164 C++ design. In most cases, you should not have to alter your C++
165 classes in any way in order to use them with Boost.Python. The system
166 should simply ``reflect'' your C++ classes and functions into Python
167 3.
168
169 %description python -l pl.UTF-8
170 Biblioteka Boost Python służy do szybkiego i prostego eksportu
171 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
172 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
173 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
174 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
175 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
176 klasy C++ i funkcje do Pythona 3.
177
178 %package python-devel
179 Summary:        Boost.Python development files for Python 2
180 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
181 Group:          Development/Libraries
182 Requires:       %{name}-devel = %{version}-%{release}
183 Requires:       %{name}-python = %{version}-%{release}
184 Requires:       %{name}-python-devel-common = %{version}-%{release}
185
186 %description python-devel
187 Boost.Python development files for Python 2.
188
189 %description python-devel -l pl.UTF-8
190 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
191
192 %package python-static
193 Summary:        Static version of Boost.Python library for Python 2
194 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
195 Group:          Development/Libraries
196 Requires:       %{name}-python-devel = %{version}-%{release}
197
198 %description python-static
199 Static version of Boost.Python library for Python 2.
200
201 %description python-static -l pl.UTF-8
202 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
203
204 %package python3
205 Summary:        Boost.Python library for Python 3
206 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
207 Group:          Libraries
208 Requires:       python3-libs
209
210 %description python3
211 Use the Boost Python Library to quickly and easily export a C++
212 library to Python 3 such that the Python 3 interface is very similar
213 to the C++ interface. It is designed to be minimally intrusive on your
214 C++ design. In most cases, you should not have to alter your C++
215 classes in any way in order to use them with Boost.Python. The system
216 should simply ``reflect'' your C++ classes and functions into Python
217 3.
218
219 %description python3 -l pl.UTF-8
220 Biblioteka Boost Python służy do szybkiego i prostego eksportu
221 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
222 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
223 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
224 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
225 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
226 klasy C++ i funkcje do Pythona 3.
227
228 %package python3-devel
229 Summary:        Boost.Python development files for Python 3
230 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
231 Group:          Development/Libraries
232 Requires:       %{name}-devel = %{version}-%{release}
233 Requires:       %{name}-python3 = %{version}-%{release}
234 Requires:       %{name}-python-devel-common = %{version}-%{release}
235
236 %description python3-devel
237 Boost.Python development files for Python 3.
238
239 %description python3-devel -l pl.UTF-8
240 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
241
242 %package python3-static
243 Summary:        Static version of Boost.Python library for Python 3
244 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
245 Group:          Development/Libraries
246 Requires:       %{name}-python3-devel = %{version}-%{release}
247
248 %description python3-static
249 Static version of Boost.Python library for Python 3.
250
251 %description python3-static -l pl.UTF-8
252 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
253
254 %package chrono
255 Summary:        Useful time utilities
256 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
257 Group:          Libraries
258 Obsoletes:      boost < 1.33
259
260 %description chrono
261 Useful time utilities.
262
263 %description chrono -l pl.UTF-8
264 Przydatne funkcje związane z czasem.
265
266 %package context
267 Summary:        Boost.Context - context switching library
268 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
269 Group:          Libraries
270
271 %description context
272 Boost.Context - context switching library, providing a sort of
273 cooperative multitasking on a single thread.
274
275 %description context -l pl.UTF-8
276 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
277 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
278
279 %package date_time
280 Summary:        Date-Time library
281 Summary(pl.UTF-8):      Biblioteka daty-czasu
282 Group:          Libraries
283 Obsoletes:      boost < 1.33
284
285 %description date_time
286 A set of date-time libraries.
287
288 %description date_time -l pl.UTF-8
289 Zbiór bibliotek daty-czasu.
290
291 %package filesystem
292 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
293 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
294 Group:          Libraries
295 Requires:       %{name}-system = %{version}-%{release}
296 Obsoletes:      boost < 1.33
297
298 %description filesystem
299 The boost::filesystem library provides portable facilities to query
300 and manipulate paths, files, and directories.
301
302 %description filesystem -l pl.UTF-8
303 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
304 operacjach na ścieżkach, plikach i katalogach.
305
306 %package graph
307 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
308 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
309 Group:          Libraries
310
311 %description graph
312 The boost::graph library provides portable facilities to operate on
313 graph data structures using graph algorithms.
314
315 %description graph -l pl.UTF-8
316 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
317 strukturach danych typu graf za pomocą algorytmów związanych z
318 grafami.
319
320 %package locale
321 Summary:        Provide localization and Unicode handling tools for C++
322 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
323 Group:          Libraries
324
325 %description locale
326 Provide localization and Unicode handling tools for C++.
327
328 %description locale -l pl.UTF-8
329 Narzędzia do obsługi lokalizacji i Unikodu w C++.
330
331 %package log
332 Summary:        Provide logging tools for C++
333 Summary(pl.UTF-8):      Narzędzia do logowania w C++
334 Group:          Libraries
335
336 %description log
337 Provide logging tools for C++.
338
339 %description log -l pl.UTF-8
340 Narzędzia do logowania w C++.
341
342 %package program_options
343 Summary:        Access to program options, via conventional methods such as command line and config file
344 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
345 Group:          Libraries
346
347 %description program_options
348 The program_options library allows program developers to obtain
349 program options, that is (name, value) pairs from the user, via
350 conventional methods such as command line and config file.
351
352 %description program_options -l pl.UTF-8
353 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
354 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
355 jak linia poleceń, czy plik konfiguracyjny.
356
357 %package regex
358 Summary:        Boost C++ regular expressions library
359 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
360 Group:          Libraries
361
362 %description regex
363 Shared library for Boost C++ regular expressions.
364
365 %description regex -l pl.UTF-8
366 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
367
368 %package signals
369 Summary:        Signals & slots callback implementation
370 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
371 Group:          Libraries
372 Obsoletes:      boost < 1.33
373
374 %description signals
375 The boost::signals library is an implementation of a signals and slots
376 system.
377
378 %description signals -l pl.UTF-8
379 Biblioteka boost::signals jest implementacją systemu sygnałów i
380 slotów.
381
382 %package system
383 Summary:        Support for getting system specific error codes
384 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
385 Group:          Libraries
386
387 %description system
388 The Boost System library provides simple, light-weight error_code
389 objects that encapsulate system-specific error code values, yet also
390 provide access to more abstract and portable error conditions objects.
391
392 %description system -l pl.UTF-8
393 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
394 obudowujące wartości kodów błędów specyficznych dla systemu, dając
395 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
396 błędów.
397
398 %package test
399 Summary:        Support for program testing and execution monitoring
400 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
401 Group:          Libraries
402 Obsoletes:      boost < 1.33
403
404 %description test
405 Support for simple program testing, full unit testing, and for program
406 execution monitoring.
407
408 %description test -l pl.UTF-8
409 Wsparcie dla prostego testowania programu, pełnego testowania i
410 monitorowania wykonania programu.
411
412 %package thread
413 Summary:        Portable C++ threads library
414 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
415 Group:          Libraries
416 Obsoletes:      boost < 1.33
417
418 %description thread
419 Portable C++ threads library - shared library.
420
421 %description thread -l pl.UTF-8
422 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
423
424 %package timer
425 Summary:        Event timer, progress timer, and progress display classes
426 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
427 Group:          Libraries
428 Obsoletes:      boost < 1.33
429
430 %description timer
431 Event timer, progress timer, and progress display classes.
432
433 %description timer -l pl.UTF-8
434 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
435
436 %package wave
437 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
438 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
439 Group:          Development/Libraries
440
441 %description wave
442 Boost.Wave - a standard compliant C++ preprocessor library.
443
444 %description wave -l pl.UTF-8
445 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
446
447 %package doc
448 Summary:        Boost C++ Library documentation
449 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
450 Group:          Documentation
451 %if "%{_rpmversion}" >= "5"
452 BuildArch:      noarch
453 %endif
454
455 %description doc
456 Documentation for the Boost C++ Library.
457
458 %description doc -l pl.UTF-8
459 Dokumentacja dla biblioteki Boost C++.
460
461 %prep
462 %setup -q -n %{name}_%{fver}
463 %patch0 -p1
464 %patch1 -p1
465 %patch2 -p1
466
467 %patch203 -p0
468 %patch211 -p1
469 %patch212 -p1
470 %patch218 -p1
471 %patch221 -p1
472 %patch222 -p1
473
474 cat << EOF > tools/build/src/user-config.jam
475 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
476 EOF
477
478 # cleanup backups after patching
479 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
480
481 %build
482 EXPAT_INCLUDE=%{_includedir} \
483 EXPAT_LIBPATH=%{_libdir} \
484 ICU_PATH=%{_prefix} \
485 ./bootstrap.sh \
486         --prefix=%{_prefix} \
487         -without-libraries=python
488
489 ./b2 \
490         -d2 --toolset=gcc \
491         variant=release \
492         debug-symbols=on \
493         inlining=on \
494         link=static,shared \
495         threading=multi
496
497 %if %{with python3}
498 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
499 ./b2 \
500         --with-python python=%{py3_ver}m \
501         -a -d2 --toolset=gcc \
502         variant=release \
503         debug-symbols=on \
504         inlining=on \
505         link=static,shared \
506         threading=multi
507 %endif
508
509 %if %{with python2}
510 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
511 ./b2 \
512         --with-python python=%{py_ver} \
513         -a -d2 --toolset=gcc \
514         variant=release \
515         debug-symbols=on \
516         inlining=on \
517         link=static,shared \
518         threading=multi
519 %endif
520
521 %install
522 rm -rf $RPM_BUILD_ROOT
523 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
524
525 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
526
527 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
528 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
529 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
530
531 # documentation
532 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
533
534 # as the documentation doesn't completely reside in a directory of its
535 # own, we need to find out ourselves... this looks for HTML files and
536 # then collects everything linked from those.  this is certainly quite
537 # unoptimized wrt mkdir calls, but does it really matter?
538 installdocs() {
539 for i in $(find -type f -name '*.htm*'); do
540         # bjam docu is included in the boost-jam RPM
541         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
542                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
543                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
544                         sub rewrite_link
545                         {
546                                 my $link = shift;
547                                 # rewrite links from boost/* to %{_includedir}/boost/* and
548                                 # ignore external links as well as document-internal ones.
549                                 # HTML files are also ignored as they get installed anyway.
550                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
551                                 {
552                                         (my $file = $link) =~ s/\#.*//;
553                                         print "$file\n";
554                                 }
555                                 $link;
556                         }
557                         open IN, @ARGV[0];
558                         open OUT, ">@ARGV[1]";
559                         my $in_link;
560                         while (<IN>)
561                         {
562                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
563                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
564                                 print OUT;
565                                 $in_link = /href|src=\s*$/;
566                         }
567 EOT`; do
568                         TARGET=${i%/*}/$LINKED
569                         # ignore non-existant linked files
570                         if test -f $TARGET; then
571                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
572                         fi
573                 done
574         fi
575 done
576 }; installdocs
577
578 %clean
579 rm -rf $RPM_BUILD_ROOT
580
581 %post   -p /sbin/ldconfig
582 %postun -p /sbin/ldconfig
583
584 %post   chrono -p /sbin/ldconfig
585 %postun chrono -p /sbin/ldconfig
586
587 %post   context -p /sbin/ldconfig
588 %postun context -p /sbin/ldconfig
589
590 %post   date_time -p /sbin/ldconfig
591 %postun date_time -p /sbin/ldconfig
592
593 %post   filesystem -p /sbin/ldconfig
594 %postun filesystem -p /sbin/ldconfig
595
596 %post   graph -p /sbin/ldconfig
597 %postun graph -p /sbin/ldconfig
598
599 %post   locale -p /sbin/ldconfig
600 %postun locale -p /sbin/ldconfig
601
602 %post   python -p /sbin/ldconfig
603 %postun python -p /sbin/ldconfig
604
605 %post   python3 -p /sbin/ldconfig
606 %postun python3 -p /sbin/ldconfig
607
608 %post   program_options -p /sbin/ldconfig
609 %postun program_options -p /sbin/ldconfig
610
611 %post   regex -p /sbin/ldconfig
612 %postun regex -p /sbin/ldconfig
613
614 %post   signals -p /sbin/ldconfig
615 %postun signals -p /sbin/ldconfig
616
617 %post   system -p /sbin/ldconfig
618 %postun system -p /sbin/ldconfig
619
620 %post   test -p /sbin/ldconfig
621 %postun test -p /sbin/ldconfig
622
623 %post   thread -p /sbin/ldconfig
624 %postun thread -p /sbin/ldconfig
625
626 %post   timer -p /sbin/ldconfig
627 %postun timer -p /sbin/ldconfig
628
629 %post   wave -p /sbin/ldconfig
630 %postun wave -p /sbin/ldconfig
631
632 %files
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
635 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
636 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
637 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
638 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
639 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
640 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
641 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
642
643 %files devel
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libboost_atomic.so
646 %attr(755,root,root) %{_libdir}/libboost_chrono.so
647 %attr(755,root,root) %{_libdir}/libboost_container.so
648 %attr(755,root,root) %{_libdir}/libboost_context.so
649 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
650 %attr(755,root,root) %{_libdir}/libboost_date_time.so
651 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
652 %attr(755,root,root) %{_libdir}/libboost_graph.so
653 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
654 %attr(755,root,root) %{_libdir}/libboost_locale.so
655 %attr(755,root,root) %{_libdir}/libboost_log.so
656 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
657 %attr(755,root,root) %{_libdir}/libboost_math_*.so
658 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
659 %attr(755,root,root) %{_libdir}/libboost_program_options.so
660 %attr(755,root,root) %{_libdir}/libboost_regex.so
661 %attr(755,root,root) %{_libdir}/libboost_random.so
662 %attr(755,root,root) %{_libdir}/libboost_serialization.so
663 %attr(755,root,root) %{_libdir}/libboost_signals.so
664 %attr(755,root,root) %{_libdir}/libboost_system.so
665 %attr(755,root,root) %{_libdir}/libboost_thread.so
666 %attr(755,root,root) %{_libdir}/libboost_timer.so
667 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
668 %attr(755,root,root) %{_libdir}/libboost_wave.so
669 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
670 %{_includedir}/boost
671 %exclude %{_includedir}/boost/python
672 %exclude %{_includedir}/boost/python.hpp
673
674 %files static
675 %defattr(644,root,root,755)
676 %{_libdir}/libboost_atomic.a
677 %{_libdir}/libboost_chrono.a
678 %{_libdir}/libboost_container.a
679 %{_libdir}/libboost_context.a
680 %{_libdir}/libboost_coroutine.a
681 %{_libdir}/libboost_date_time.a
682 %{_libdir}/libboost_exception.a
683 %{_libdir}/libboost_filesystem.a
684 %{_libdir}/libboost_graph.a
685 %{_libdir}/libboost_iostreams.a
686 %{_libdir}/libboost_locale.a
687 %{_libdir}/libboost_log.a
688 %{_libdir}/libboost_log_setup.a
689 %{_libdir}/libboost_math_*.a
690 %{_libdir}/libboost_prg_exec_monitor.a
691 %{_libdir}/libboost_program_options.a
692 %{_libdir}/libboost_random.a
693 %{_libdir}/libboost_regex.a
694 %{_libdir}/libboost_serialization.a
695 %{_libdir}/libboost_signals.a
696 %{_libdir}/libboost_system.a
697 %{_libdir}/libboost_test_exec_monitor.a
698 %{_libdir}/libboost_timer.a
699 %{_libdir}/libboost_thread.a
700 %{_libdir}/libboost_unit_test_framework.a
701 %{_libdir}/libboost_wave.a
702 %{_libdir}/libboost_wserialization.a
703
704 %if %{with python2} || %{with python3}
705 %files python-devel-common
706 %defattr(644,root,root,755)
707 %{_includedir}/boost/python
708 %{_includedir}/boost/python.hpp
709 %endif
710
711 %if %{with python2}
712 %files python
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
715
716 %files python-devel
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libboost_python.so
719
720 %files python-static
721 %defattr(644,root,root,755)
722 %{_libdir}/libboost_python.a
723 %endif
724
725 %if %{with python3}
726 %files python3
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
729
730 %files python3-devel
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libboost_python3.so
733
734 %files python3-static
735 %defattr(644,root,root,755)
736 %{_libdir}/libboost_python3.a
737 %endif
738
739 %files chrono
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
742
743 %files context
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
746
747 %files date_time
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
750
751 %files filesystem
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
754
755 %files graph
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
758
759 %files locale
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
762
763 %files log
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
766 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
767
768 %files program_options
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
771
772 %files regex
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
775
776 %files signals
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
779
780 %files system
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
783
784 %files test
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
787 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
788
789 %files thread
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
792
793 %files timer
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
796
797 %files wave
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
800
801 %files doc
802 %defattr(644,root,root,755)
803 %{_docdir}/%{name}-%{version}
This page took 0.096275 seconds and 4 git commands to generate.