]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- restored python patch, updated optflags passing
[packages/boost.git] / boost.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # with boost-python support (not working now)
4 #
5 %define _ver    1.31.0
6 %define _fver   %(echo %{_ver} | tr . _)
7
8 Summary:        The Boost C++ Libraries
9 Summary(pl):    Biblioteki C++ "Boost"
10 Name:           boost
11 Version:        %{_ver}
12 Release:        0.1
13 License:        Boost Software License and others
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/boost/%{name}_%{_fver}.tar.bz2
16 # Source0-md5:  8cc183538eaa5cfc53d88d0e94bd2fd4
17 Patch0:         %{name}-python.patch
18 URL:            http://www.boost.org/
19 BuildRequires:  boost-jam >= 3.1.3
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  perl-base
22 %{?with_python:BuildRequires:   python-devel >= 2.2}
23 BuildConflicts: gcc = 5:3.3.1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Boost web site provides free peer-reviewed portable C++ source
28 libraries. The emphasis is on libraries which work well with the C++
29 Standard Library. One goal is to establish "existing practice" and
30 provide reference implementations so that the Boost libraries are
31 suitable for eventual standardization. Some of the libraries have
32 already been proposed for inclusion in the C++ Standards Committee's
33 upcoming C++ Standard Library Technical Report.
34
35 %description -l pl
36 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
37 kodem ¼ród³owym. Nacisk po³o¿ono na biblioteki, które dobrze
38 wspó³pracuj± ze standardow± bibliotek± C++. Celem jest ustanowienie
39 "isniej±cej praktyki" i dostarczenie implementacji, tak ¿e biblioteki
40 "Boost" nadaj± siê do ewentualnej standaryzacji. Niektóre z bibliotek
41 ju¿ zosta³y zg³oszone do komitetu standaryzacyjnego C++ w nadchodz±cym
42 Raporcie Technicznym Biblioteki Standardowej C++
43
44 %package devel
45 Summary:        Boost C++ development libraries and headers
46 Summary(pl):    Pliki nag³ówkowe i biblioteki statyczne Boost C++
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 # req'd by <boost/iterator_adaptors.hpp> (also included by <boost/signal.h>)
50 Requires:       %{name}-compressed_pair-devel = %{version}-%{release}
51 Requires:       %{name}-concept_check-devel = %{version}-%{release}
52 Requires:       libstdc++-devel
53
54 %description devel
55 Headers and static libraries for the Boost C++ libraries.
56
57 %description devel -l pl
58 Pliki nag³ówkowe i biblioteki statyczne bibliotek Boost C++.
59
60 %package static
61 Summary:        Static versions of Boost libraries
62 Summary(pl):    Statyczne wersje bibliotek Boost
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static versions of Boost libraries.
68
69 %description static -l pl
70 Statyczne wersje bibliotek Boost.
71
72 %package python
73 Summary:        Boost.Python library
74 Summary(pl):    biblioteka Boost.Python
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77 %pyrequires_eq  python
78
79 %description python
80 Use the Boost Python Library to quickly and easily export a C++
81 library to Python such that the Python interface is very similar to
82 the C++ interface. It is designed to be minimally intrusive on your
83 C++ design. In most cases, you should not have to alter your C++
84 classes in any way in order to use them with Boost.Python. The system
85 should simply ``reflect'' your C++ classes and functions into Python.
86
87 %description python -l pl
88 Biblioteka Boost Python s³u¿y do szybkiego i prostego eksportu
89 biblioteki C++ do Pythona, tak ¿e interfejs Pythona jest bardzo
90 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, ¿eby
91 narzucaæ jak najmniej wymagañ dotycz±cych konstrukcjii C++. W
92 wiêkszo¶ci przypadków nie trzeba w ogóle zmieniaæ w³asnych klas C++,
93 ¿eby u¿ywaæ ich z Boost.Python. System powinien po prostu ,,odbiæ''
94 klasy C++ i funkcje do Pythona.
95
96 %package python-devel
97 Summary:        Boost.Python development headers
98 Summary(pl):    Pliki nag³ówkowe dla Boost.Python
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       %{name}-python = %{version}-%{release}
102
103 %description python-devel
104 Headers for the Boost.Python library.
105
106 %description python-devel -l pl
107 Pliki nag³ówkowe dla biblioteki Boost.Python.
108
109 %package python-static
110 Summary:        Static version of Boost.Python library
111 Summary(pl):    Statyczna wersja biblioteki Boost.Python
112 Group:          Development/Libraries
113 Requires:       %{name}-python-devel = %{version}-%{release}
114
115 %description python-static
116 Static version of Boost.Python library.
117
118 %description python-static -l pl
119 Statyczna wersja biblioteki Boost.Python.
120
121 %package regex
122 Summary:        Boost C++ regular expressions library
123 Summary(pl):    Biblioteka wyra¿eñ regularnych Boost C++
124 Group:          Libraries
125 Requires:       %{name} = %{version}-%{release}
126
127 %description regex
128 Shared library for Boost C++ regular expressions.
129
130 %description regex -l pl
131 Biblioteka wyra¿eñ regularnych dla C++, biblioteki dzielone.
132
133 %package regex-devel
134 Summary:        Boost C++ Regex library headers
135 Summary(pl):    Pliki nag³ówkowe Boost C++ Regex
136 Group:          Development/Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138 Requires:       %{name}-regex = %{version}-%{release}
139
140 %description regex-devel
141 Boost C++ Regex headers.
142
143 %description regex-devel -l pl
144 Pliki nag³ówkowe dla Boost C++ Regex.
145
146 %package regex-static
147 Summary:        Boost C++ Regex static libraries
148 Summary(pl):    Biblioteki statyczne Boost C++ Regex
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151 Requires:       %{name}-regex = %{version}-%{release}
152
153 %description regex-static
154 Boost C++ Regex static libraries.
155
156 %description regex-static -l pl
157 Biblioteki statyczne dla Boost C++ Regex.
158
159 %package any-devel
160 Summary:        Header for Boost C++ "Any" Library
161 Summary(pl):    Plik nag³ówkowy dla biblioteki Boost C++ "Any"
162 Group:          Development/Libraries
163 Requires:       %{name}-devel = %{version}-%{release}
164
165 %description any-devel
166 The boost::any class, is a variant value type, which supports copying
167 of any value type and safe checked extraction of that value strictly
168 against that type.
169
170 I.e. 5 is held strictly as an int and is not implicitly convertible
171 either to "5" or to 5.0.
172
173 %description any-devel -l pl
174 Klasa boost::any jest typem, który umo¿liwia kopiowanie ze zmiennej
175 dowolnego typu i bezpieczne, sprawdzone wydobycie jej warto¶ci
176 dok³adnie tego samego typu.
177
178 Np. 5 jest trzymane jako int i nie jest niejawnie konwertowalne ani do
179 "5" ani do 5.0.
180
181 %package array-devel
182 Summary:        STL compliant container wrapper for arrays of constant size
183 Summary(pl):    Wrapper na STLowe kontenery dla tablic o sta³ym rozmiarze
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}-%{release}
186
187 %description array-devel
188 As replacement for ordinary arrays, the STL provides class vector<>.
189 However, vector<> provides the semantics of dynamic arrays. Thus, it
190 manages data to be able to change the number of elements. This results
191 in some overhead in case only arrays with static size are needed. This
192 library provides support for such static size arrays.
193
194 %description array-devel -l pl
195 STL dostarcza klasê vector<> jako zamiennik zwyk³ej tablicy. Jednak
196 vector<> dostarcza semantykê dynamicznych tablic. Zatem zarz±dza
197 danymi tak, by by³a mo¿liwa zmiana ilo¶ci elementów. To skutkuje
198 pewnym nadmiarem w przypadku kiedy tylko tablice o sta³ym rozmiarze s±
199 potrzebne. Ta biblioteka dostarcza wsparcie dla takich w³a¶nie tablic
200 o sta³ym rozmiarze.
201
202 %package bind-devel
203 Summary:        Generalized binders for function/object/pointers
204 Summary(pl):    Uogólnione bindery dla funkcji/obiektów/wska¼ników
205 Group:          Development/Libraries
206 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
207 Requires:       %{name}-ref-devel = %{version}-%{release}
208
209 %description bind-devel
210 boost::bind is a generalization of the standard functions std::bind1st
211 and std::bind2nd.
212
213 %description bind-devel -l pl
214 boost::bind jest uogólnieniem standardowych funkcji std::bind1st i
215 std::bind2nd.
216
217 %package call_traits-devel
218 Summary:        Defines types for passing parameters
219 Summary(pl):    Definiowanie typów dla przekazywania parametrów
220 Group:          Development/Libraries
221 Requires:       %{name}-devel = %{version}-%{release}
222 Requires:       %{name}-type_traits-devel = %{version}-%{release}
223
224 %description call_traits-devel
225 boost::call_traits<T> encapsulates the "best" method to pass a
226 parameter of some type T to or from a function. The purpose of
227 call_traits is to ensure that problems like "references to references"
228 never occur, and that parameters are passed in the most efficient
229 manner possible.
230
231 %description call_traits-devel -l pl
232 boost::call_traits<T> zawiera "najlepsz±" metodê przekazywania
233 parametrów jakiego¶ typu T do lub z funkcji. Celem call_traits jest
234 zapewnienie ¿e problemy takie jak "referencja referencji" nigdy nie
235 wyst±pi± i ¿e parametry s± przekazywane w mo¿liwie najbardziej
236 efektywny sposób.
237
238 %package compatibility-devel
239 Summary:        Help for non-conforming standard libraries
240 Summary(pl):    Pomoc dla nie trzymaj±cych standardu bibliotek
241 Group:          Development/Libraries
242 Requires:       %{name}-devel = %{version}-%{release}
243
244 %description compatibility-devel
245 This library provides workarounds which allow the other Boost
246 libraries to be used on otherwise non-conforming platforms.
247
248 %description compatibility-devel -l pl
249 Biblioteka dostarcza obej¶cie problemu platform nie trzymaj±cych
250 standardu C++, pozwalaj±ce na u¿ywanie bibliotek Boost na tych
251 platformach.
252
253 %package compose-devel
254 Summary:        Functional composition adapters for the STL
255 Summary(pl):    Funkcjonalne adaptery kompozycji dla STL
256 Group:          Development/Libraries
257 Requires:       %{name}-devel = %{version}-%{release}
258
259 %description compose-devel
260 The boost::compose provides compose function object adapter extensions
261 for use with the Standard Template Library (STL) portion of the C++
262 Standard Library. If you aren't currently using the STL, this library
263 won't be of any interest, but hard-core STL users will appreciate its
264 usefulness.
265
266 %description compose-devel -l pl
267 boost::compose dostarcza rozszerzenie adaptera obiektu funkcji compose
268 do u¿ytku z STL-ow± czê¶ci± Standardu C++. Je¿eli nie u¿ywasz STL,
269 biblioteka bêdzie poza twoim zainteresowaniem, lecz hardkorowi
270 u¿ytkownicy STL-a doceni± jej u¿yteczno¶æ.
271
272 %package compressed_pair-devel
273 Summary:        Empty member optimization
274 Summary(pl):    Optymalizacja pustego elementu
275 Group:          Development/Libraries
276 Requires:       %{name}-call_traits-devel = %{version}-%{release}
277 Requires:       %{name}-devel = %{version}-%{release}
278
279 %description compressed_pair-devel
280 The class boost::compressed_pair is very similar to std::pair, but if
281 either of the template arguments are empty classes, then the "empty
282 base-class optimisation" is applied to compress the size of the pair.
283
284 %description compressed_pair-devel -l pl
285 Klasa boost::compressed_pair jest bardzo podobna do std::pair, ale
286 je¿eli który¶ z argumentów wzorca jest pust± klas±, wtedy stosowana
287 jest "optymalizacja pustej klasy bazowej" do kompresji pary.
288
289 %package concept_check-devel
290 Summary:        Tools for generic programming
291 Summary(pl):    Narzêdzia dla programowania generycznego
292 Group:          Development/Libraries
293 Requires:       %{name}-static_assert-devel = %{version}-%{release}
294 Requires:       %{name}-type_traits-devel = %{version}-%{release}
295
296 %description concept_check-devel
297 The boost::concept_check library provides various tools for generic
298 programming.
299
300 %description concept_check-devel -l pl
301 Biblioteka boost::concept_check dostarcza ró¿ne narzêdzia dla
302 programowania generycznego.
303
304 %package conversion-devel
305 Summary:        Numeric, polymorphic, and lexical casts
306 Summary(pl):    Numeryczne, polimorficzne i leksykalne rzutowania
307 Group:          Development/Libraries
308 Requires:       %{name}-type_traits-devel = %{version}-%{release}
309
310 %description conversion-devel
311 The boost::conversion library improves program safety and clarity by
312 performing otherwise messy conversions. It includes cast-style
313 function templates designed to complement the C++ Standard's built-in
314 casts.
315
316 %description conversion-devel -l pl
317 Biblioteka boost::conversion zwiêksza bezpieczeñstwo i klarowno¶æ
318 programu dokonuj±c konwersji które s± w innych przypadkach niechlujne.
319 Biblioteka zawiera "rzutopodobne" wzorce funkcji uzupe³niaj±ce
320 wbudowane w Standard C++ rzutowania.
321
322 %package crc-devel
323 Summary:        CRC computing library
324 Summary(pl):    Biblioteka obliczaj±ca CRC
325 Group:          Development/Libraries
326 Requires:       %{name}-devel = %{version}-%{release}
327
328 %description crc-devel
329 The boost::crc library provides two implementations of CRC computation
330 objects and functions. The implementations are template-based.
331
332 %description crc-devel -l pl
333 Bibliteka boost::crc dostarcza dwie implementacje obiektów i funkcji
334 obliczaj±cych CRC. Implementacje s± oparte na wzorcach.
335
336 %package date_time
337 Summary:        Date-Time library
338 Summary(pl):    Biblioteka daty-czasu
339 Group:          Libraries
340
341 %description date_time
342 A set of date-time libraries.
343
344 %description date_time -l pl
345 Zbiór bibliotek daty-czasu.
346
347 %package date_time-devel
348 Summary:        Header files for boost::date_time library
349 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::date_time
350 Group:          Development/Libraries
351 Requires:       %{name}-date_time = %{version}-%{release}
352 #TODO: make decision if do separate packages include it to main devel package
353 #Requires:      %{name}-operators-devel = %{version}-%{release}
354 #Requires:      %{name}-integer-devel = %{version}-%{release}
355 #Requires:      %{name}-tokenizer-devel = %{version}-%{release}
356 Requires:       %{name}-conversion-devel = %{version}-%{release}
357
358 %description date_time-devel
359 Header files for boost::date_time library.
360
361 %description date_time-devel -l pl
362 Pliki nag³ówkowe dla biblioteki boost::date_time
363
364 %package date_time-static
365 Summary:        Static boost::date_time library
366 Summary(pl):    Statyczna biblioteka boost::date_time
367 Group:          Development/Libraries
368 Requires:       %{name}-date_time-devel = %{version}-%{release}
369
370 %description date_time-static
371 Static boost::date_time library.
372
373 %description date_time-devel -l pl
374 Statyczna biblioteka boost::date_time.
375
376 %package mem_fn-devel
377 Summary:        Generalized binders for member functions
378 Summary(pl):    Uogólnione bindery dla metod
379 Group:          Development/Libraries
380 Requires:       %{name}-bind-devel = %{version}-%{release}
381
382 %description mem_fn-devel
383 boost::mem_fn is a generalization of the standard functions
384 std::mem_fun and std::mem_fun_ref.
385
386 %description mem_fn-devel -l pl
387 boost::mem_fn jest uogólnieniem standardowych funkcji std::mem_fun i
388 std::mem_fun_ref.
389
390 %package mpl-devel
391 Summary:        Compile-time algorithms, sequences and metafunction classes
392 Summary(pl):    Algorytmy czasu kompilacji, sekwencji i klas metafunkcji
393 Group:          Development/Libraries
394 Requires:       %{name}-devel = %{version}-%{release}
395 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
396 Requires:       %{name}-type_traits-devel = %{version}-%{release}
397 Requires:       %{name}-utility-devel = %{version}-%{release}
398
399 %description mpl-devel
400 The boost-mpl library is a C++ template metaprogramming framework of
401 compile-time algorithms, sequences and metafunction classes.
402
403 %description mpl-devel -l pl
404 Biblioteka boost-mpl jest szkieletem wzorców C++ dla algorytmów czasu
405 kompilacji, sekwencji i klas metafunkcji.
406
407 %package preprocessor-devel
408 Summary:        Preprocessor metaprogramming tools including repetition and recursion
409 Summary(pl):    Narzêdzia metaprogramowania preprocesora razem z repetycj± i rekursj±
410 Group:          Development/Libraries
411 Requires:       %{name}-devel = %{version}-%{release}
412
413 %description preprocessor-devel
414 This library provides preprocessor metaprogramming tools, including
415 repetition and recursion.
416
417 %description preprocessor-devel -l pl
418 Biblioteka udostêpnia narzêdzia metaprogramowania preprocesora,
419 w³±czaj±c w to repetycje i rekursjê.
420
421 %package ref-devel
422 Summary:        Small library useful for passing references to function templates
423 Summary(pl):    Ma³a biblioteka u¿yteczna przy przekazywaniu referencji do wzorców funkcji
424 Group:          Development/Libraries
425 Requires:       %{name}-devel = %{version}-%{release}
426 Requires:       %{name}-mpl-devel = %{version}-%{release}
427 Requires:       %{name}-utility-devel = %{version}-%{release}
428
429 %description ref-devel
430 boost::ref library is a small library that is useful for passing
431 references to function templates (algorithms) that would usually take
432 copies of their arguments.
433
434 %description ref-devel -l pl
435 Biblioteka boost::ref jest ma³± bibliotek± która jest u¿yteczna w
436 przypadku przekazywania referencji do wzorców funkcji (algorytmów)
437 które zazwyczaj bior± kopiê swoich argumentów.
438
439 %package signals
440 Summary:        signals & slots callback implementation
441 Summary(pl):    implementacja sygna³ów i slotów
442 Group:          Libraries
443
444 %description signals
445 The boost::signals library is an implementation of a signals and slots
446 system.
447
448 %description signals -l pl
449 Biblioteka boost::signals jest implementacj± systemu sygna³ów i
450 slotów.
451
452 %package signals-devel
453 Summary:        Header files for boost::signals library
454 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::signals
455 Group:          Development/Libraries
456 Requires:       %{name}-any-devel = %{version}-%{release}
457 #TODO: separate smart_ptr or include to the main devel package
458 #Requires:      %{name}-iterator_adaptors-devel = %{version}-%{release}
459 #Requires:      %{name}-operators-devel = %{version}-%{release}
460 #Requires:      %{name}-smart_ptr-devel = %{version}-%{release}
461 Requires:       %{name}-mem_fn-devel = %{version}-%{release}
462 Requires:       %{name}-ref-devel = %{version}-%{release}
463 Requires:       %{name}-type_traits-devel = %{version}-%{release}
464 Requires:       %{name}-utility-devel = %{version}-%{release}
465
466 %description signals-devel
467 Header files for boost::signals library.
468
469 %description signals-devel -l pl
470 Pliki nag³ówkowe dla biblioteki boost::signals.
471
472 %package signals-static
473 Summary:        Static library for boost::signals
474 Summary(pl):    Biblioteka statyczna dla boost::signals
475 Group:          Development/Libraries
476 Requires:       %{name}-signals-devel = %{version}-%{release}
477
478 %description signals-static
479 Static library for boost::signals.
480
481 %description signals-static -l pl
482 Biblioteka statyczna dla boost::signals.
483
484 %package static_assert-devel
485 Summary:        Static assertions (compile time assertions)
486 Summary(pl):    Statyczne asercje (asercje kompilacyjne)
487 Group:          Development/Libraries
488 Requires:       %{name}-devel = %{version}
489
490 %description static_assert-devel
491 The header <boost/static_assert.hpp> supplies a single macro
492 BOOST_STATIC_ASSERT(x), which generates a compile time error message
493 if the integral-constant-expression x is not true. In other words it
494 is the compile time equivalent of the assert macro; this is sometimes
495 known as a "compile-time-assertion"
496
497 One of the aims of BOOST_STATIC_ASSERT is to generate readable error
498 messages. These immediately tell the user that a library is being used
499 in a manner that is not supported.
500
501 %description static_assert-devel -l pl
502 Plik nag³ówkowy <boost/static_assert.hpp> dostarcza pojedyncze makro
503 BOOST_STATIC_ASSERT(x), które generuje komunikat b³êdu kompilacji
504 je¿eli sta³e wyra¿enie x nie jest prawdziwe. Innymi s³owy jest to
505 kompilacyjny ekwiwalent makra 'assert'; czasami znane jest jako
506 "asercja czasu kompilacji"
507
508 Jednym z celów BOOST_STATIC_ASSERT jest generowanie czytelnych
509 komunikatów o b³êdach. One b³yskawicznie powiedz± u¿ytkownikowi ¿e
510 biblioteka zosta³a u¿yta w sposób który nie jest zalecany.
511
512 %package thread
513 Summary:        Portable C++ threads library
514 Summary(pl):    Przeno¶na biblioteka w±tków C++
515 Group:          Libraries
516
517 %description thread
518 Portable C++ threads library - shared library.
519
520 %description thread -l pl
521 Przeno¶na biblioteka w±tków dla C++ - biblioteka dzielona.
522
523 %package thread-devel
524 Summary:        Header files for boost::thread library
525 Summary(pl):    Pliki nag³ówkowe dla biblioteki boost::thread
526 Group:          Development/Libraries
527 Requires:       %{name}-thread = %{version}-%{release}
528 Requires:       %{name}-utility-devel = %{version}-%{release}
529 #TODO:requires boost::function or boost::function to boost-devel
530
531 %description thread-devel
532 Header files for boost::thread library.
533
534 %description thread-devel -l pl
535 Pliki nag³ówkowe dla biblioteki boost::thread.
536
537 %package type_traits-devel
538 Summary:        Templates for fundamental properties of types
539 Summary(pl):    Wzorce dla fundamentalnych w³a¶ciwo¶ci typów
540 Group:          Development/Libraries
541 Requires:       %{name}-devel = %{version}-%{release}
542 Requires:       %{name}-mpl-devel = %{version}-%{release}
543 Requires:       %{name}-preprocessor-devel = %{version}-%{release}
544 Requires:       %{name}-static_assert-devel = %{version}-%{release}
545 Requires:       %{name}-utility-devel = %{version}-%{release}
546
547 %description type_traits-devel
548 The boost-type_traits library defines three kinds of type trait:
549  1. The properties of a specific type.
550  2. The relationship between two types.
551  3. A transformation from one type to another.
552
553 %description type_traits-devel -l pl
554 Biblioteka boost-type_traits definiuje trzy rodzaje cech typów:
555  1. w³a¶ciwo¶ci konkretnego typu.
556  2. powi±zania miêdzy dwoma typami.
557  3. transformacjê z jednego typu do drugiego.
558
559 %package utility-devel
560 Summary:        Useful utilities: classes and function templates
561 Summary(pl):    U¿yteczne narzêdzia: klasy i wzorce funkcji
562 Group:          Development/Libraries
563 Requires:       %{name}-type_traits-devel = %{version}
564
565 %description utility-devel
566 Class noncopyable plus checked_delete(), checked_array_delete(),
567 next(), prior() function templates, plus base-from-member idiom.
568
569 %description utility-devel -l pl
570 Klasy noncopyable i checked_delete, funkcje checked_array_delete(),
571 next(), prior() oraz idiom base-from-member.
572
573 %package doc
574 Summary:        Boost C++ Library documentation
575 Summary(pl):    Dokumentacja dla biblioteki Boost C++
576 Group:          Documentation
577 Requires:       %{name}-devel = %{version}-%{release}
578
579 %description doc
580 Documentation for the Boost C++ Library.
581
582 %description doc -l pl
583 Dokumentacja dla biblioteki Boost C++.
584
585 %prep
586 %setup -q -n %{name}_%{_fver}
587 %patch0 -p1
588
589 # don't know how to pass it through (b)jam -s (no way?)
590 # due to oversophisticated build flags system
591 %{__perl} -pi -e 's/ -O3 / %{rpmcflags} /' tools/build/v1/gcc-tools.jam
592
593 %build
594 %if %{with python}
595 PYTHON_VERSION=`python -V 2>&1 | sed 's,.* \([0-9]\.[0-9]\)\(\.[0-9]\)\?.*,\1,'`
596 PYTHON_ROOT=%{_prefix}
597 %else
598 PYTHON_ROOT=
599 PYTHON_VERSION=
600 %endif
601 bjam \
602         -d2 \
603         -sBUILD=release \
604         -sPYTHON_ROOT=$PYTHON_ROOT \
605         -sPYTHON_VERSION=$PYTHON_VERSION
606
607 %install
608 rm -rf $RPM_BUILD_ROOT
609 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
610
611 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
612
613 install bin/boost/libs/*/build/*.a/*/release/lib*.a $RPM_BUILD_ROOT%{_libdir}
614 install bin/boost/libs/*/build/*.so/*/release/*/{*/,}lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
615 # use cp -d, install follows symlinks instead of preserving them!
616 cp -df bin/boost/libs/*/build/*.so/*/release/*/{*/,}lib*.so $RPM_BUILD_ROOT%{_libdir}
617
618 # documentation
619 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
620 install README $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
621
622 # as the documentation doesn't completely reside in a directory of its
623 # own, we need to find out ourselves... this looks for HTML files and
624 # then collects everything linked from those.  this is certainly quite
625 # unoptimized wrt mkdir calls, but does it really matter?
626 for i in `find -type f -name '*.htm*'`; do
627         # bjam docu is included in the boost-jam RPM
628         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
629                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $i`
630                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
631                         sub rewrite_link
632                         {
633                                 my $link = shift;
634                                 # rewrite links from boost/* to %{_includedir}/boost/* and
635                                 # ignore external links as well as document-internal ones.
636                                 # HTML files are also ignored as they get installed anyway.
637                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
638                                 {
639                                         (my $file = $link) =~ s/\#.*//;
640                                         print "$file\n";
641                                 }
642                                 $link;
643                         }
644                         open IN, @ARGV[0];
645                         open OUT, ">@ARGV[1]";
646                         my $in_link;
647                         while (<IN>)
648                         {
649                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
650                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
651                                 print OUT;
652                                 $in_link = /href|src=\s*$/;
653                         }
654 EOT`; do
655                         TARGET=`dirname $i`/$LINKED
656                         # ignore non-existant linked files
657                         if test -f $TARGET; then
658                                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/`dirname $TARGET`
659                                 install -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
660                         fi
661                 done
662         fi
663 done
664
665 %clean
666 rm -rf $RPM_BUILD_ROOT
667
668 %post   -p /sbin/ldconfig
669 %postun -p /sbin/ldconfig
670
671 %post   date_time -p /sbin/ldconfig
672 %postun date_time -p /sbin/ldconfig
673
674 %post   python  -p /sbin/ldconfig
675 %postun python  -p /sbin/ldconfig
676
677 %post   regex   -p /sbin/ldconfig
678 %postun regex   -p /sbin/ldconfig
679
680 %post   signals -p /sbin/ldconfig
681 %postun signals -p /sbin/ldconfig
682
683 %post   thread  -p /sbin/ldconfig
684 %postun thread  -p /sbin/ldconfig
685
686 %files
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.so.*.*.*
689 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor-gcc-1_31.so.*.*.*
690 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework-gcc-1_31.so.*.*.*
691 %attr(755,root,root) %{_libdir}/libboost_filesystem-gcc-1_31.so.*.*.*
692
693 %files devel
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.so
696 %attr(755,root,root) %{_libdir}/libboost_test_exec_monitor-gcc-1_31.so
697 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework-gcc-1_31.so
698 %attr(755,root,root) %{_libdir}/libboost_filesystem-gcc-1_31.so
699 %dir %{_includedir}/boost
700 %{_includedir}/boost/assert.hpp
701 %{_includedir}/boost/blank_fwd.hpp
702 %{_includedir}/boost/config
703 %{_includedir}/boost/config.hpp
704 %{_includedir}/boost/iterator/counting_iterator.hpp
705 %{_includedir}/boost/cstd*.hpp
706 %{_includedir}/boost/current_function.hpp
707 %dir %{_includedir}/boost/detail
708 %{_includedir}/boost/detail/algorithm.hpp
709 %{_includedir}/boost/detail/allocator.hpp
710 %{_includedir}/boost/detail/atomic_count*.hpp
711 %{_includedir}/boost/detail/binary_search.hpp
712 %{_includedir}/boost/detail/catch_exceptions.hpp
713 %{_includedir}/boost/detail/dynamic_bitset.hpp
714 %{_includedir}/boost/detail/is_incrementable.hpp
715 %{_includedir}/boost/detail/iterator.hpp
716 %{_includedir}/boost/detail/lightweight_*.hpp
717 %{_includedir}/boost/detail/limits.hpp
718 %{_includedir}/boost/detail/lwm_*.hpp
719 %{_includedir}/boost/detail/named_template_params.hpp
720 %{_includedir}/boost/detail/numeric_traits.hpp
721 %{_includedir}/boost/detail/reference_content.hpp
722 %{_includedir}/boost/detail/quick_allocator.hpp
723 %{_includedir}/boost/detail/select_type.hpp
724 %{_includedir}/boost/detail/shared_*.hpp
725 %{_includedir}/boost/detail/workaround.hpp
726 %{_includedir}/boost/dynamic_bitset*.hpp
727 %{_includedir}/boost/enable_shared_from_this.hpp
728 %{_includedir}/boost/filesystem
729 %{_includedir}/boost/format
730 %{_includedir}/boost/format.hpp
731 %{_includedir}/boost/function
732 %{_includedir}/boost/function.hpp
733 %{_includedir}/boost/function_output_iterator.hpp
734 %{_includedir}/boost/functional.hpp
735 %{_includedir}/boost/generator_iterator.hpp
736 %{_includedir}/boost/graph
737 %{_includedir}/boost/half_open_range.hpp
738 %{_includedir}/boost/indirect_reference.hpp
739 %{_includedir}/boost/integer
740 %{_includedir}/boost/integer*.hpp
741 %{_includedir}/boost/intrusive_ptr.hpp
742 %{_includedir}/boost/io
743 %{_includedir}/boost/io_fwd.hpp
744 %{_includedir}/boost/iterator*.hpp
745 %{_includedir}/boost/iterator
746 %{_includedir}/boost/lambda
747 %{_includedir}/boost/limits.hpp
748 %{_includedir}/boost/math
749 %{_includedir}/boost/math_fwd.hpp
750 %{_includedir}/boost/multi_array
751 %{_includedir}/boost/multi_array.hpp
752 %{_includedir}/boost/nondet_random.hpp
753 %{_includedir}/boost/non_type.hpp
754 %{_includedir}/boost/numeric
755 %{_includedir}/boost/operators.hpp
756 %{_includedir}/boost/optional.hpp
757 %{_includedir}/boost/pending
758 %{_includedir}/boost/iterator/permutation_iterator.hpp
759 %{_includedir}/boost/pool
760 %{_includedir}/boost/pointee.hpp
761 %{_includedir}/boost/progress.hpp
762 %{_includedir}/boost/property_map*.hpp
763 %{_includedir}/boost/random
764 %{_includedir}/boost/random.hpp
765 %{_includedir}/boost/rational.hpp
766 %{_includedir}/boost/scoped_*.hpp
767 %{_includedir}/boost/shared_*.hpp
768 %{_includedir}/boost/smart_ptr.hpp
769 %{_includedir}/boost/spirit
770 %{_includedir}/boost/spirit.hpp
771 %{_includedir}/boost/test
772 %{_includedir}/boost/throw_exception.hpp
773 %{_includedir}/boost/timer.hpp
774 %{_includedir}/boost/token*.hpp
775 %{_includedir}/boost/tuple
776 %{_includedir}/boost/type.hpp
777 %{_includedir}/boost/type_traits
778 %{_includedir}/boost/utility
779 %{_includedir}/boost/version.hpp
780 %{_includedir}/boost/vector_property_map.hpp
781 %{_includedir}/boost/weak_ptr.hpp
782 #boost::enable_if
783 %{_includedir}/boost/utility/enable_if.hpp
784 #boost::variant
785 %{_includedir}/boost/variant.hpp
786 %{_includedir}/boost/variant
787 %{_includedir}/boost/blank.hpp
788 %{_includedir}/boost/detail/templated_streams.hpp
789 #boost::optional
790 %{_includedir}/boost/aligned_storage.hpp
791 %{_includedir}/boost/detail/in_place_factory*.hpp
792 %{_includedir}/boost/detail/none.hpp
793 %{_includedir}/boost/detail/none_t.hpp
794 %{_includedir}/boost/detail/typed_in_place_factory.hpp
795
796 %files static
797 %defattr(644,root,root,755)
798 %{_libdir}/libboost_prg_exec_monitor-gcc-1_31.a
799 %{_libdir}/libboost_test_exec_monitor-gcc-1_31.a
800 %{_libdir}/libboost_unit_test_framework-gcc-1_31.a
801 %{_libdir}/libboost_filesystem-gcc-1_31.a
802
803 %if %{with python}
804 %files python
805 %defattr(644,root,root,755)
806 %attr(755,root,root) %{_libdir}/libboost_python-gcc-1_31.so.*.*.*
807
808 %files python-devel
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libboost_python-gcc-1_31.so
811 %{_includedir}/boost/python
812 %{_includedir}/boost/python.hpp
813
814 %files python-static
815 %defattr(644,root,root,755)
816 %{_libdir}/libboost_python-gcc-1_31.a
817 %endif
818
819 %files regex
820 %defattr(644,root,root,755)
821 %attr(755,root,root) %{_libdir}/libboost_regex-gcc-1_31.so.*.*.*
822
823 %files regex-devel
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libboost_regex-gcc-1_31.so
826 %{_includedir}/boost/cregex.hpp
827 %{_includedir}/boost/regex.h
828 %{_includedir}/boost/regex*.hpp
829 %{_includedir}/boost/regex
830
831 %files regex-static
832 %defattr(644,root,root,755)
833 %{_libdir}/libboost_regex-gcc-1_31.a
834
835 %files any-devel
836 %defattr(644,root,root,755)
837 %{_includedir}/boost/any.hpp
838
839 %files array-devel
840 %defattr(644,root,root,755)
841 %{_includedir}/boost/array.hpp
842
843 %files bind-devel
844 %defattr(644,root,root,755)
845 %{_includedir}/boost/bind
846 %{_includedir}/boost/bind.hpp
847
848 %files call_traits-devel
849 %defattr(644,root,root,755)
850 %{_includedir}/boost/call_traits.hpp
851 %{_includedir}/boost/detail/call_traits.hpp
852 %{_includedir}/boost/detail/ob_call_traits.hpp
853
854 %files compatibility-devel
855 %defattr(644,root,root,755)
856 %{_includedir}/boost/compatibility
857
858 %files compose-devel
859 %defattr(644,root,root,755)
860 %{_includedir}/boost/compose.hpp
861
862 %files compressed_pair-devel
863 %defattr(644,root,root,755)
864 %{_includedir}/boost/compressed_pair.hpp
865 %{_includedir}/boost/detail/compressed_pair.hpp
866 %{_includedir}/boost/detail/ob_compressed_pair.hpp
867
868 %files concept_check-devel
869 %defattr(644,root,root,755)
870 %{_includedir}/boost/concept_archetype.hpp
871 %{_includedir}/boost/concept_check.hpp
872
873 %files conversion-devel
874 %defattr(644,root,root,755)
875 %{_includedir}/boost/cast.hpp
876 %{_includedir}/boost/implicit_cast.hpp
877 %{_includedir}/boost/lexical_cast.hpp
878
879 %files crc-devel
880 %defattr(644,root,root,755)
881 %{_includedir}/boost/crc.hpp
882
883 %files date_time
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/libboost_date_time-gcc-1_31.so.*.*.*
886
887 %files date_time-devel
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/libboost_date_time-gcc-1_31.so
890 %{_includedir}/boost/date_time
891
892 %files date_time-static
893 %defattr(644,root,root,755)
894 %{_libdir}/libboost_date_time-gcc-1_31.a
895
896 %files mem_fn-devel
897 %defattr(644,root,root,755)
898 %{_includedir}/boost/get_pointer.hpp
899 %{_includedir}/boost/mem_fn.hpp
900
901 %files mpl-devel
902 %defattr(644,root,root,755)
903 %{_includedir}/boost/mpl
904
905 %files preprocessor-devel
906 %defattr(644,root,root,755)
907 %{_includedir}/boost/preprocessor
908 %{_includedir}/boost/preprocessor.hpp
909
910 %files ref-devel
911 %defattr(644,root,root,755)
912 %{_includedir}/boost/ref.hpp
913
914 %files signals
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/libboost_signals-gcc-1_31.so.*.*.*
917
918 %files signals-devel
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/libboost_signals-gcc-1_31.so
921 %{_includedir}/boost/signal*.hpp
922 %{_includedir}/boost/signals
923 %{_includedir}/boost/last_value.hpp
924 %{_includedir}/boost/visit_each.hpp
925
926 %files signals-static
927 %defattr(644,root,root,755)
928 %{_libdir}/libboost_signals-gcc-1_31.a
929
930 %files static_assert-devel
931 %defattr(644,root,root,755)
932 %{_includedir}/boost/static_assert.hpp
933
934 %files thread
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/libboost_thread-gcc-mt-1_31.so.*.*.*
937
938 %files thread-devel
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/libboost_thread-gcc-mt-1_31.so
941 %{_includedir}/boost/thread
942 %{_includedir}/boost/thread.hpp
943
944 %files type_traits-devel
945 %defattr(644,root,root,755)
946 %{_includedir}/boost/type_traits.hpp
947 %{_includedir}/boost/type_traits
948
949 %files utility-devel
950 %defattr(644,root,root,755)
951 %{_includedir}/boost/checked_delete.hpp
952 %{_includedir}/boost/next_prior.hpp
953 %{_includedir}/boost/noncopyable.hpp
954 %{_includedir}/boost/utility*.hpp
955 %{_includedir}/boost/utility
956
957 %files doc
958 %defattr(644,root,root,755)
959 %{_docdir}/boost-%{version}
This page took 0.834473 seconds and 4 git commands to generate.