]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
- context and coroutine do not build on x32 (added TODO)
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #       - fix building context and corouting on x32 (patch1)
6 #
7 # Conditional build:
8 %bcond_without  python  # without boost-python support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.56.0
15 Release:        2
16 License:        Boost Software License and others
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
19 # Source0-md5:  a744cf167b05d72335f27c88115f211d
20 Patch0:         %{name}-link.patch
21 Patch1:         %{name}-x32-context.patch
22 # FC Patches:
23 # https://svn.boost.org/trac/boost/ticket/5637
24 Patch203:       %{name}-1.54.0-mpl-print.patch
25 # https://svn.boost.org/trac/boost/ticket/8870
26 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
27 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
28 # https://svn.boost.org/trac/boost/ticket/8871
29 Patch213:       %{name}-1.54.0-numeric-unused_typedef.patch
30 # https://svn.boost.org/trac/boost/ticket/8878
31 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
32 # https://svn.boost.org/trac/boost/ticket/8881
33 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
34 # https://svn.boost.org/trac/boost/ticket/8888
35 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
36 # https://svn.boost.org/trac/boost/ticket/9038
37 Patch224:       %{name}-1.54.0-pool-test_linking.patch
38 URL:            http://www.boost.org/
39 BuildRequires:  bzip2-devel
40 BuildRequires:  expat-devel
41 BuildRequires:  libicu-devel
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  perl-base
44 %{?with_python:BuildRequires:   python-devel >= 2.2}
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  zlib-devel
47 BuildConflicts: gcc = 5:3.3.1
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
51
52 %description
53 The Boost web site provides free peer-reviewed portable C++ source
54 libraries. The emphasis is on libraries which work well with the C++
55 Standard Library. One goal is to establish "existing practice" and
56 provide reference implementations so that the Boost libraries are
57 suitable for eventual standardization. Some of the libraries have
58 already been proposed for inclusion in the C++ Standards Committee's
59 upcoming C++ Standard Library Technical Report.
60
61 %description -l pl.UTF-8
62 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
63 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
64 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
65 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
66 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
67 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
68 Raporcie Technicznym Biblioteki Standardowej C++.
69
70 %package devel
71 Summary:        Boost C++ development headers
72 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       %{name}-chrono = %{version}-%{release}
76 Requires:       %{name}-context = %{version}-%{release}
77 Requires:       %{name}-date_time = %{version}-%{release}
78 Requires:       %{name}-filesystem = %{version}-%{release}
79 Requires:       %{name}-graph = %{version}-%{release}
80 Requires:       %{name}-locale = %{version}-%{release}
81 Requires:       %{name}-log = %{version}-%{release}
82 Requires:       %{name}-program_options = %{version}-%{release}
83 Requires:       %{name}-regex = %{version}-%{release}
84 Requires:       %{name}-signals = %{version}-%{release}
85 Requires:       %{name}-system = %{version}-%{release}
86 Requires:       %{name}-test = %{version}-%{release}
87 Requires:       %{name}-thread = %{version}-%{release}
88 Requires:       %{name}-timer = %{version}-%{release}
89 Requires:       %{name}-wave = %{version}-%{release}
90 Requires:       libstdc++-devel
91 Obsoletes:      boost-any-devel
92 Obsoletes:      boost-array-devel
93 Obsoletes:      boost-asio
94 Obsoletes:      boost-bind-devel
95 Obsoletes:      boost-call_traits-devel
96 Obsoletes:      boost-compatibility-devel
97 Obsoletes:      boost-compose-devel
98 Obsoletes:      boost-compressed_pair-devel
99 Obsoletes:      boost-concept_check-devel
100 Obsoletes:      boost-conversion-devel
101 Obsoletes:      boost-crc-devel
102 Obsoletes:      boost-date_time-devel
103 Obsoletes:      boost-filesystem-devel
104 Obsoletes:      boost-graph-devel
105 Obsoletes:      boost-mem_fn-devel
106 Obsoletes:      boost-mpl-devel
107 Obsoletes:      boost-preprocessor-devel
108 Obsoletes:      boost-program_options-devel
109 Obsoletes:      boost-ref-devel
110 Obsoletes:      boost-regex-devel
111 Obsoletes:      boost-signals-devel
112 Obsoletes:      boost-spirit-devel
113 Obsoletes:      boost-statechart-devel
114 Obsoletes:      boost-static_assert-devel
115 Obsoletes:      boost-test-devel
116 Obsoletes:      boost-thread-devel
117 Obsoletes:      boost-tr1-devel
118 Obsoletes:      boost-type_traits-devel
119 Obsoletes:      boost-typeof-devel
120 Obsoletes:      boost-uBLAS-devel
121 Obsoletes:      boost-utility-devel
122 Obsoletes:      boost-wave-devel
123 Obsoletes:      boost-xpressive-devel
124
125 %description devel
126 Header files for the Boost C++ libraries.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe bibliotek C++ Boost.
130
131 %package static
132 Summary:        Static version of base Boost C++ libraries
133 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136 Obsoletes:      boost-static < 1.33
137
138 %description static
139 Static version of base Boost C++ libraries.
140
141 %description static -l pl.UTF-8
142 Statyczne wersje podstawowych bibliotek C++ Boost.
143
144 %package python
145 Summary:        Boost.Python library
146 Summary(pl.UTF-8):      biblioteka Boost.Python
147 Group:          Libraries
148 Requires:       python
149
150 %description python
151 Use the Boost Python Library to quickly and easily export a C++
152 library to Python such that the Python interface is very similar to
153 the C++ interface. It is designed to be minimally intrusive on your
154 C++ design. In most cases, you should not have to alter your C++
155 classes in any way in order to use them with Boost.Python. The system
156 should simply ``reflect'' your C++ classes and functions into Python.
157
158 %description python -l pl.UTF-8
159 Biblioteka Boost Python służy do szybkiego i prostego eksportu
160 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
161 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
162 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
163 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
164 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
165 klasy C++ i funkcje do Pythona.
166
167 %package python-devel
168 Summary:        Boost.Python development headers
169 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
170 Group:          Development/Libraries
171 Requires:       %{name}-devel = %{version}-%{release}
172 Requires:       %{name}-python = %{version}-%{release}
173
174 %description python-devel
175 Headers for the Boost.Python library.
176
177 %description python-devel -l pl.UTF-8
178 Pliki nagłówkowe dla biblioteki Boost.Python.
179
180 %package python-static
181 Summary:        Static version of Boost.Python library
182 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
183 Group:          Development/Libraries
184 Requires:       %{name}-python-devel = %{version}-%{release}
185
186 %description python-static
187 Static version of Boost.Python library.
188
189 %description python-static -l pl.UTF-8
190 Statyczna wersja biblioteki Boost.Python.
191
192 %package chrono
193 Summary:        Useful time utilities
194 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
195 Group:          Libraries
196 Obsoletes:      boost < 1.33
197
198 %description chrono
199 Useful time utilities.
200
201 %description chrono -l pl.UTF-8
202 Przydatne funkcje związane z czasem.
203
204 %package context
205 Summary:        Boost.Context - context switching library
206 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
207 Group:          Libraries
208
209 %description context
210 Boost.Context - context switching library, providing a sort of
211 cooperative multitasking on a single thread.
212
213 %description context -l pl.UTF-8
214 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
215 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
216
217 %package date_time
218 Summary:        Date-Time library
219 Summary(pl.UTF-8):      Biblioteka daty-czasu
220 Group:          Libraries
221 Obsoletes:      boost < 1.33
222
223 %description date_time
224 A set of date-time libraries.
225
226 %description date_time -l pl.UTF-8
227 Zbiór bibliotek daty-czasu.
228
229 %package filesystem
230 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
231 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
232 Group:          Libraries
233 Requires:       %{name}-system = %{version}-%{release}
234 Obsoletes:      boost < 1.33
235
236 %description filesystem
237 The boost::filesystem library provides portable facilities to query
238 and manipulate paths, files, and directories.
239
240 %description filesystem -l pl.UTF-8
241 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
242 operacjach na ścieżkach, plikach i katalogach.
243
244 %package graph
245 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
246 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
247 Group:          Libraries
248
249 %description graph
250 The boost::graph library provides portable facilities to operate on
251 graph data structures using graph algorithms.
252
253 %description graph -l pl.UTF-8
254 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
255 strukturach danych typu graf za pomocą algorytmów związanych z
256 grafami.
257
258 %package locale
259 Summary:        Provide localization and Unicode handling tools for C++
260 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
261 Group:          Libraries
262
263 %description locale
264 Provide localization and Unicode handling tools for C++.
265
266 %description locale -l pl.UTF-8
267 Narzędzia do obsługi lokalizacji i Unikodu w C++.
268
269 %package log
270 Summary:        Provide logging tools for C++
271 Summary(pl.UTF-8):      Narzędzia do logowania w C++
272 Group:          Libraries
273
274 %description log
275 Provide logging tools for C++.
276
277 %description log -l pl.UTF-8
278 Narzędzia do logowania w C++.
279
280 %package program_options
281 Summary:        Access to program options, via conventional methods such as command line and config file
282 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
283 Group:          Libraries
284
285 %description program_options
286 The program_options library allows program developers to obtain
287 program options, that is (name, value) pairs from the user, via
288 conventional methods such as command line and config file.
289
290 %description program_options -l pl.UTF-8
291 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
292 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
293 jak linia poleceń, czy plik konfiguracyjny.
294
295 %package regex
296 Summary:        Boost C++ regular expressions library
297 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
298 Group:          Libraries
299
300 %description regex
301 Shared library for Boost C++ regular expressions.
302
303 %description regex -l pl.UTF-8
304 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
305
306 %package signals
307 Summary:        Signals & slots callback implementation
308 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
309 Group:          Libraries
310 Obsoletes:      boost < 1.33
311
312 %description signals
313 The boost::signals library is an implementation of a signals and slots
314 system.
315
316 %description signals -l pl.UTF-8
317 Biblioteka boost::signals jest implementacją systemu sygnałów i
318 slotów.
319
320 %package system
321 Summary:        Support for getting system specific error codes
322 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
323 Group:          Libraries
324
325 %description system
326 The Boost System library provides simple, light-weight error_code
327 objects that encapsulate system-specific error code values, yet also
328 provide access to more abstract and portable error conditions objects.
329
330 %description system -l pl.UTF-8
331 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
332 obudowujące wartości kodów błędów specyficznych dla systemu, dając
333 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
334 błędów.
335
336 %package test
337 Summary:        Support for program testing and execution monitoring
338 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
339 Group:          Libraries
340 Obsoletes:      boost < 1.33
341
342 %description test
343 Support for simple program testing, full unit testing, and for program
344 execution monitoring.
345
346 %description test -l pl.UTF-8
347 Wsparcie dla prostego testowania programu, pełnego testowania i
348 monitorowania wykonania programu.
349
350 %package thread
351 Summary:        Portable C++ threads library
352 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
353 Group:          Libraries
354 Obsoletes:      boost < 1.33
355
356 %description thread
357 Portable C++ threads library - shared library.
358
359 %description thread -l pl.UTF-8
360 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
361
362 %package timer
363 Summary:        Event timer, progress timer, and progress display classes
364 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
365 Group:          Libraries
366 Obsoletes:      boost < 1.33
367
368 %description timer
369 Event timer, progress timer, and progress display classes.
370
371 %description timer -l pl.UTF-8
372 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
373
374 %package wave
375 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
376 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
377 Group:          Development/Libraries
378
379 %description wave
380 Boost.Wave - a standard compliant C++ preprocessor library.
381
382 %description wave -l pl.UTF-8
383 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
384
385 %package doc
386 Summary:        Boost C++ Library documentation
387 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
388 Group:          Documentation
389 Requires:       %{name}-devel = %{version}-%{release}
390
391 %description doc
392 Documentation for the Boost C++ Library.
393
394 %description doc -l pl.UTF-8
395 Dokumentacja dla biblioteki Boost C++.
396
397 %prep
398 %setup -q -n %{name}_%{fver}
399 %patch0 -p1
400 #patch1 -p0
401
402 %patch203 -p0
403 %patch211 -p1
404 %patch212 -p1
405 %patch213 -p1
406 %patch218 -p1
407 %patch221 -p1
408 %patch222 -p1
409 %patch224 -p1
410
411 # - don't know how to pass it through (b)jam -s (no way?)
412 #   due to oversophisticated build flags system.
413 # - pass -fPIC due to <shared-linkable> removal.
414 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/src/tools/gcc.jam
415
416 # cleanup -g switch to avoid override debuginfocflags.
417 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/src/tools/gcc.jam
418 # link against shared expat library.
419 #%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
420
421 cat << EOF > tools/build/src/user-config.jam
422 using gcc : %{cxx_version} : %{__cxx} ;
423 EOF
424
425 # cleanup backups after patching
426 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
427
428 %build
429 %if %{with python}
430 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
431 PYTHON_ROOT=%{_prefix}
432 %else
433 PYTHON_ROOT=
434 PYTHON_VERSION=
435 %endif
436 EXPAT_INCLUDE=%{_includedir} \
437 EXPAT_LIBPATH=%{_libdir} \
438 ICU_PATH=%{_prefix} \
439 ./bootstrap.sh \
440         --prefix=%{_prefix}
441
442 ./b2 \
443 %ifarch x32
444         --without-context \
445         --without-coroutine \
446 %endif
447         -d2 --toolset=gcc \
448         variant=release \
449         debug-symbols=on \
450         inlining=on \
451         link=static,shared \
452         threading=multi
453
454 %install
455 rm -rf $RPM_BUILD_ROOT
456 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
457
458 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
459
460 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
461 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
462 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
463
464 # documentation
465 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
466
467 # as the documentation doesn't completely reside in a directory of its
468 # own, we need to find out ourselves... this looks for HTML files and
469 # then collects everything linked from those.  this is certainly quite
470 # unoptimized wrt mkdir calls, but does it really matter?
471 installdocs() {
472 for i in $(find -type f -name '*.htm*'); do
473         # bjam docu is included in the boost-jam RPM
474         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
475                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
476                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
477                         sub rewrite_link
478                         {
479                                 my $link = shift;
480                                 # rewrite links from boost/* to %{_includedir}/boost/* and
481                                 # ignore external links as well as document-internal ones.
482                                 # HTML files are also ignored as they get installed anyway.
483                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
484                                 {
485                                         (my $file = $link) =~ s/\#.*//;
486                                         print "$file\n";
487                                 }
488                                 $link;
489                         }
490                         open IN, @ARGV[0];
491                         open OUT, ">@ARGV[1]";
492                         my $in_link;
493                         while (<IN>)
494                         {
495                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
496                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
497                                 print OUT;
498                                 $in_link = /href|src=\s*$/;
499                         }
500 EOT`; do
501                         TARGET=${i%/*}/$LINKED
502                         # ignore non-existant linked files
503                         if test -f $TARGET; then
504                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
505                         fi
506                 done
507         fi
508 done
509 }; installdocs
510
511 %clean
512 rm -rf $RPM_BUILD_ROOT
513
514 %post   -p /sbin/ldconfig
515 %postun -p /sbin/ldconfig
516
517 %post   chrono -p /sbin/ldconfig
518 %postun chrono -p /sbin/ldconfig
519
520 %post   context -p /sbin/ldconfig
521 %postun context -p /sbin/ldconfig
522
523 %post   date_time -p /sbin/ldconfig
524 %postun date_time -p /sbin/ldconfig
525
526 %post   filesystem -p /sbin/ldconfig
527 %postun filesystem -p /sbin/ldconfig
528
529 %post   graph -p /sbin/ldconfig
530 %postun graph -p /sbin/ldconfig
531
532 %post   locale -p /sbin/ldconfig
533 %postun locale -p /sbin/ldconfig
534
535 %post   python -p /sbin/ldconfig
536 %postun python -p /sbin/ldconfig
537
538 %post   program_options -p /sbin/ldconfig
539 %postun program_options -p /sbin/ldconfig
540
541 %post   regex -p /sbin/ldconfig
542 %postun regex -p /sbin/ldconfig
543
544 %post   signals -p /sbin/ldconfig
545 %postun signals -p /sbin/ldconfig
546
547 %post   system -p /sbin/ldconfig
548 %postun system -p /sbin/ldconfig
549
550 %post   test -p /sbin/ldconfig
551 %postun test -p /sbin/ldconfig
552
553 %post   thread -p /sbin/ldconfig
554 %postun thread -p /sbin/ldconfig
555
556 %post   timer -p /sbin/ldconfig
557 %postun timer -p /sbin/ldconfig
558
559 %post   wave -p /sbin/ldconfig
560 %postun wave -p /sbin/ldconfig
561
562 %files
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
565 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
566 %ifnarch x32
567 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
568 %endif
569 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
570 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
571 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
572 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
573 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
574
575 %files devel
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/libboost_atomic.so
578 %attr(755,root,root) %{_libdir}/libboost_chrono.so
579 %attr(755,root,root) %{_libdir}/libboost_container.so
580 %ifnarch x32
581 %attr(755,root,root) %{_libdir}/libboost_context.so
582 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
583 %endif
584 %attr(755,root,root) %{_libdir}/libboost_date_time.so
585 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
586 %attr(755,root,root) %{_libdir}/libboost_graph.so
587 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
588 %attr(755,root,root) %{_libdir}/libboost_locale.so
589 %attr(755,root,root) %{_libdir}/libboost_log.so
590 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
591 %attr(755,root,root) %{_libdir}/libboost_math_*.so
592 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
593 %attr(755,root,root) %{_libdir}/libboost_program_options.so
594 %attr(755,root,root) %{_libdir}/libboost_regex.so
595 %attr(755,root,root) %{_libdir}/libboost_random.so
596 %attr(755,root,root) %{_libdir}/libboost_serialization.so
597 %attr(755,root,root) %{_libdir}/libboost_signals.so
598 %attr(755,root,root) %{_libdir}/libboost_system.so
599 %attr(755,root,root) %{_libdir}/libboost_thread.so
600 %attr(755,root,root) %{_libdir}/libboost_timer.so
601 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
602 %attr(755,root,root) %{_libdir}/libboost_wave.so
603 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
604 %{_includedir}/boost
605 %exclude %{_includedir}/boost/python
606 %exclude %{_includedir}/boost/python.hpp
607
608 %files static
609 %defattr(644,root,root,755)
610 %{_libdir}/libboost_atomic.a
611 %{_libdir}/libboost_chrono.a
612 %{_libdir}/libboost_container.a
613 %ifnarch x32
614 %{_libdir}/libboost_context.a
615 %{_libdir}/libboost_coroutine.a
616 %endif
617 %{_libdir}/libboost_date_time.a
618 %{_libdir}/libboost_exception.a
619 %{_libdir}/libboost_filesystem.a
620 %{_libdir}/libboost_graph.a
621 %{_libdir}/libboost_iostreams.a
622 %{_libdir}/libboost_locale.a
623 %{_libdir}/libboost_log.a
624 %{_libdir}/libboost_log_setup.a
625 %{_libdir}/libboost_math_*.a
626 %{_libdir}/libboost_prg_exec_monitor.a
627 %{_libdir}/libboost_program_options.a
628 %{_libdir}/libboost_random.a
629 %{_libdir}/libboost_regex.a
630 %{_libdir}/libboost_serialization.a
631 %{_libdir}/libboost_signals.a
632 %{_libdir}/libboost_system.a
633 %{_libdir}/libboost_test_exec_monitor.a
634 %{_libdir}/libboost_timer.a
635 %{_libdir}/libboost_thread.a
636 %{_libdir}/libboost_unit_test_framework.a
637 %{_libdir}/libboost_wave.a
638 %{_libdir}/libboost_wserialization.a
639
640 %if %{with python}
641 %files python
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
644
645 %files python-devel
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libboost_python.so
648 %{_includedir}/boost/python
649 %{_includedir}/boost/python.hpp
650
651 %files python-static
652 %defattr(644,root,root,755)
653 %{_libdir}/libboost_python.a
654 %endif
655
656 %files chrono
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
659
660 %ifnarch x32
661 %files context
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
664 %endif
665
666 %files date_time
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
669
670 %files filesystem
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
673
674 %files graph
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
677
678 %files locale
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
681
682 %files log
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
685 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
686
687 %files program_options
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
690
691 %files regex
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
694
695 %files signals
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
698
699 %files system
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
702
703 %files test
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
706 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
707
708 %files thread
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
711
712 %files timer
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
715
716 %files wave
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
719
720 %files doc
721 %defattr(644,root,root,755)
722 %{_docdir}/%{name}-%{version}
This page took 0.104649 seconds and 3 git commands to generate.