]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
do not package .orig files; adapter
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python  # without boost-python support
8
9 %define         fver    %(echo %{version} | tr . _)
10 Summary:        The Boost C++ Libraries
11 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
12 Name:           boost
13 Version:        1.55.0
14 Release:        2
15 License:        Boost Software License and others
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
18 # Source0-md5:  d6eef4b4cacb2183f2bf265a5a03a354
19 Patch0:         %{name}-link.patch
20 # FC Patches:
21 # https://svn.boost.org/trac/boost/ticket/8844
22 Patch201:       %{name}-1.54.0-bind-static_assert.patch
23 # https://svn.boost.org/trac/boost/ticket/8847
24 Patch202:       %{name}-1.54.0-concept-unused_typedef.patch
25 # https://svn.boost.org/trac/boost/ticket/5637
26 Patch203:       %{name}-1.54.0-mpl-print.patch
27 # https://svn.boost.org/trac/boost/ticket/8859
28 Patch204:       %{name}-1.54.0-static_warning-unused_typedef.patch
29 # https://svn.boost.org/trac/boost/ticket/8853
30 Patch207:       %{name}-1.54.0-tuple-unused_typedef.patch
31 # https://svn.boost.org/trac/boost/ticket/8854
32 Patch208:       %{name}-1.54.0-random-unused_typedef.patch
33 # https://svn.boost.org/trac/boost/ticket/8856
34 Patch209:       %{name}-1.54.0-date_time-unused_typedef.patch
35 Patch210:       %{name}-1.54.0-date_time-unused_typedef-2.patch
36 # https://svn.boost.org/trac/boost/ticket/8870
37 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
38 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
39 # https://svn.boost.org/trac/boost/ticket/8871
40 Patch213:       %{name}-1.54.0-numeric-unused_typedef.patch
41 # https://svn.boost.org/trac/boost/ticket/8878
42 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
43 # https://svn.boost.org/trac/boost/ticket/8879
44 Patch219:       %{name}-1.54.0-property_tree-unused_typedef.patch
45 # https://svn.boost.org/trac/boost/ticket/8881
46 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
47 # https://svn.boost.org/trac/boost/ticket/8888
48 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
49 # https://svn.boost.org/trac/boost/ticket/9038
50 Patch224:       %{name}-1.54.0-pool-test_linking.patch
51 URL:            http://www.boost.org/
52 BuildRequires:  bzip2-devel
53 BuildRequires:  expat-devel
54 BuildRequires:  libicu-devel
55 BuildRequires:  libstdc++-devel
56 BuildRequires:  perl-base
57 %{?with_python:BuildRequires:   python-devel >= 2.2}
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  zlib-devel
60 BuildConflicts: gcc = 5:3.3.1
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
64
65 %description
66 The Boost web site provides free peer-reviewed portable C++ source
67 libraries. The emphasis is on libraries which work well with the C++
68 Standard Library. One goal is to establish "existing practice" and
69 provide reference implementations so that the Boost libraries are
70 suitable for eventual standardization. Some of the libraries have
71 already been proposed for inclusion in the C++ Standards Committee's
72 upcoming C++ Standard Library Technical Report.
73
74 %description -l pl.UTF-8
75 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
76 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
77 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
78 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
79 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
80 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
81 Raporcie Technicznym Biblioteki Standardowej C++.
82
83 %package devel
84 Summary:        Boost C++ development headers
85 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       %{name}-chrono = %{version}-%{release}
89 Requires:       %{name}-context = %{version}-%{release}
90 Requires:       %{name}-date_time = %{version}-%{release}
91 Requires:       %{name}-filesystem = %{version}-%{release}
92 Requires:       %{name}-graph = %{version}-%{release}
93 Requires:       %{name}-locale = %{version}-%{release}
94 Requires:       %{name}-program_options = %{version}-%{release}
95 Requires:       %{name}-regex = %{version}-%{release}
96 Requires:       %{name}-signals = %{version}-%{release}
97 Requires:       %{name}-system = %{version}-%{release}
98 Requires:       %{name}-test = %{version}-%{release}
99 Requires:       %{name}-thread = %{version}-%{release}
100 Requires:       %{name}-timer = %{version}-%{release}
101 Requires:       %{name}-wave = %{version}-%{release}
102 Requires:       libstdc++-devel
103 Obsoletes:      boost-any-devel
104 Obsoletes:      boost-array-devel
105 Obsoletes:      boost-asio
106 Obsoletes:      boost-bind-devel
107 Obsoletes:      boost-call_traits-devel
108 Obsoletes:      boost-compatibility-devel
109 Obsoletes:      boost-compose-devel
110 Obsoletes:      boost-compressed_pair-devel
111 Obsoletes:      boost-concept_check-devel
112 Obsoletes:      boost-conversion-devel
113 Obsoletes:      boost-crc-devel
114 Obsoletes:      boost-date_time-devel
115 Obsoletes:      boost-filesystem-devel
116 Obsoletes:      boost-graph-devel
117 Obsoletes:      boost-mem_fn-devel
118 Obsoletes:      boost-mpl-devel
119 Obsoletes:      boost-preprocessor-devel
120 Obsoletes:      boost-program_options-devel
121 Obsoletes:      boost-ref-devel
122 Obsoletes:      boost-regex-devel
123 Obsoletes:      boost-signals-devel
124 Obsoletes:      boost-spirit-devel
125 Obsoletes:      boost-statechart-devel
126 Obsoletes:      boost-static_assert-devel
127 Obsoletes:      boost-test-devel
128 Obsoletes:      boost-thread-devel
129 Obsoletes:      boost-tr1-devel
130 Obsoletes:      boost-type_traits-devel
131 Obsoletes:      boost-typeof-devel
132 Obsoletes:      boost-uBLAS-devel
133 Obsoletes:      boost-utility-devel
134 Obsoletes:      boost-wave-devel
135 Obsoletes:      boost-xpressive-devel
136
137 %description devel
138 Header files for the Boost C++ libraries.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe bibliotek C++ Boost.
142
143 %package static
144 Summary:        Static version of base Boost C++ libraries
145 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
146 Group:          Development/Libraries
147 Requires:       %{name}-devel = %{version}-%{release}
148 Obsoletes:      boost-static < 1.33
149
150 %description static
151 Static version of base Boost C++ libraries.
152
153 %description static -l pl.UTF-8
154 Statyczne wersje podstawowych bibliotek C++ Boost.
155
156 %package python
157 Summary:        Boost.Python library
158 Summary(pl.UTF-8):      biblioteka Boost.Python
159 Group:          Libraries
160 Requires:       python
161
162 %description python
163 Use the Boost Python Library to quickly and easily export a C++
164 library to Python such that the Python interface is very similar to
165 the C++ interface. It is designed to be minimally intrusive on your
166 C++ design. In most cases, you should not have to alter your C++
167 classes in any way in order to use them with Boost.Python. The system
168 should simply ``reflect'' your C++ classes and functions into Python.
169
170 %description python -l pl.UTF-8
171 Biblioteka Boost Python służy do szybkiego i prostego eksportu
172 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
173 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
174 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
175 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
176 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
177 klasy C++ i funkcje do Pythona.
178
179 %package python-devel
180 Summary:        Boost.Python development headers
181 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
182 Group:          Development/Libraries
183 Requires:       %{name}-devel = %{version}-%{release}
184 Requires:       %{name}-python = %{version}-%{release}
185
186 %description python-devel
187 Headers for the Boost.Python library.
188
189 %description python-devel -l pl.UTF-8
190 Pliki nagłówkowe dla biblioteki Boost.Python.
191
192 %package python-static
193 Summary:        Static version of Boost.Python library
194 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
195 Group:          Development/Libraries
196 Requires:       %{name}-python-devel = %{version}-%{release}
197
198 %description python-static
199 Static version of Boost.Python library.
200
201 %description python-static -l pl.UTF-8
202 Statyczna wersja biblioteki Boost.Python.
203
204 %package chrono
205 Summary:        Useful time utilities
206 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
207 Group:          Libraries
208 Obsoletes:      boost < 1.33
209
210 %description chrono
211 Useful time utilities.
212
213 %description chrono -l pl.UTF-8
214 Przydatne funkcje związane z czasem.
215
216 %package context
217 Summary:        Boost.Context - context switching library
218 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
219 Group:          Libraries
220
221 %description context
222 Boost.Context - context switching library, providing a sort of
223 cooperative multitasking on a single thread.
224
225 %description context -l pl.UTF-8
226 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
227 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
228
229 %package date_time
230 Summary:        Date-Time library
231 Summary(pl.UTF-8):      Biblioteka daty-czasu
232 Group:          Libraries
233 Obsoletes:      boost < 1.33
234
235 %description date_time
236 A set of date-time libraries.
237
238 %description date_time -l pl.UTF-8
239 Zbiór bibliotek daty-czasu.
240
241 %package filesystem
242 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
243 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
244 Group:          Libraries
245 Requires:       %{name}-system = %{version}-%{release}
246 Obsoletes:      boost < 1.33
247
248 %description filesystem
249 The boost::filesystem library provides portable facilities to query
250 and manipulate paths, files, and directories.
251
252 %description filesystem -l pl.UTF-8
253 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
254 operacjach na ścieżkach, plikach i katalogach.
255
256 %package graph
257 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
258 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
259 Group:          Libraries
260
261 %description graph
262 The boost::graph library provides portable facilities to operate on
263 graph data structures using graph algorithms.
264
265 %description graph -l pl.UTF-8
266 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
267 strukturach danych typu graf za pomocą algorytmów związanych z
268 grafami.
269
270 %package locale
271 Summary:        Provide localization and Unicode handling tools for C++
272 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
273 Group:          Libraries
274
275 %description locale
276 Provide localization and Unicode handling tools for C++.
277
278 %description locale -l pl.UTF-8
279 Narzędzia do obsługi lokalizacji i Unikodu w C++.
280
281 %package log
282 Summary:        Provide logging tools for C++
283 Summary(pl.UTF-8):      Narzędzia do logowania w C++
284 Group:          Libraries
285
286 %description log
287 Provide logging tools for C++.
288
289 %description log -l pl.UTF-8
290 Narzędzia do logowania w C++.
291
292 %package program_options
293 Summary:        Access to program options, via conventional methods such as command line and config file
294 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
295 Group:          Libraries
296
297 %description program_options
298 The program_options library allows program developers to obtain
299 program options, that is (name, value) pairs from the user, via
300 conventional methods such as command line and config file.
301
302 %description program_options -l pl.UTF-8
303 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
304 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
305 jak linia poleceń, czy plik konfiguracyjny.
306
307 %package regex
308 Summary:        Boost C++ regular expressions library
309 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
310 Group:          Libraries
311
312 %description regex
313 Shared library for Boost C++ regular expressions.
314
315 %description regex -l pl.UTF-8
316 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
317
318 %package signals
319 Summary:        Signals & slots callback implementation
320 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
321 Group:          Libraries
322 Obsoletes:      boost < 1.33
323
324 %description signals
325 The boost::signals library is an implementation of a signals and slots
326 system.
327
328 %description signals -l pl.UTF-8
329 Biblioteka boost::signals jest implementacją systemu sygnałów i
330 slotów.
331
332 %package system
333 Summary:        Support for getting system specific error codes
334 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
335 Group:          Libraries
336
337 %description system
338 The Boost System library provides simple, light-weight error_code
339 objects that encapsulate system-specific error code values, yet also
340 provide access to more abstract and portable error conditions objects.
341
342 %description system -l pl.UTF-8
343 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
344 obudowujące wartości kodów błędów specyficznych dla systemu, dając
345 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
346 błędów.
347
348 %package test
349 Summary:        Support for program testing and execution monitoring
350 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
351 Group:          Libraries
352 Obsoletes:      boost < 1.33
353
354 %description test
355 Support for simple program testing, full unit testing, and for program
356 execution monitoring.
357
358 %description test -l pl.UTF-8
359 Wsparcie dla prostego testowania programu, pełnego testowania i
360 monitorowania wykonania programu.
361
362 %package thread
363 Summary:        Portable C++ threads library
364 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
365 Group:          Libraries
366 Obsoletes:      boost < 1.33
367
368 %description thread
369 Portable C++ threads library - shared library.
370
371 %description thread -l pl.UTF-8
372 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
373
374 %package timer
375 Summary:        Event timer, progress timer, and progress display classes
376 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
377 Group:          Libraries
378 Obsoletes:      boost < 1.33
379
380 %description timer
381 Event timer, progress timer, and progress display classes.
382
383 %description timer -l pl.UTF-8
384 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
385
386 %package wave
387 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
388 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
389 Group:          Development/Libraries
390
391 %description wave
392 Boost.Wave - a standard compliant C++ preprocessor library.
393
394 %description wave -l pl.UTF-8
395 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
396
397 %package doc
398 Summary:        Boost C++ Library documentation
399 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
400 Group:          Documentation
401 Requires:       %{name}-devel = %{version}-%{release}
402
403 %description doc
404 Documentation for the Boost C++ Library.
405
406 %description doc -l pl.UTF-8
407 Dokumentacja dla biblioteki Boost C++.
408
409 %prep
410 %setup -q -n %{name}_%{fver}
411 %patch0 -p1
412
413 %patch201 -p1
414 %patch202 -p1
415 %patch203 -p0
416 %patch204 -p1
417 %patch207 -p0
418 %patch208 -p0
419 %patch209 -p0
420 %patch210 -p1
421 %patch211 -p1
422 %patch212 -p1
423 %patch213 -p1
424 %patch218 -p1
425 %patch219 -p1
426 %patch221 -p1
427 %patch222 -p1
428 %patch224 -p1
429
430 # - don't know how to pass it through (b)jam -s (no way?)
431 #   due to oversophisticated build flags system.
432 # - pass -fPIC due to <shared-linkable> removal.
433 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/v2/tools/gcc.jam
434
435 # cleanup -g switch to avoid override debuginfocflags.
436 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
437 # link against shared expat library.
438 %{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
439
440 cat << EOF > tools/build/v2/user-config.jam
441 using gcc : %{cxx_version} : %{__cxx} ;
442 EOF
443
444 # cleanup backups after patching
445 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
446
447 %build
448 %if %{with python}
449 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
450 PYTHON_ROOT=%{_prefix}
451 %else
452 PYTHON_ROOT=
453 PYTHON_VERSION=
454 %endif
455 EXPAT_INCLUDE=%{_includedir} \
456 EXPAT_LIBPATH=%{_libdir} \
457 ICU_PATH=%{_prefix} \
458 ./bootstrap.sh --prefix=%{_prefix}
459 ./b2 \
460         -d2 --toolset=gcc \
461         variant=release debug-symbols=on inlining=on link=static,shared threading=multi
462
463 %install
464 rm -rf $RPM_BUILD_ROOT
465 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
466
467 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
468
469 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
470 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
471 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
472
473 # documentation
474 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
475
476 # as the documentation doesn't completely reside in a directory of its
477 # own, we need to find out ourselves... this looks for HTML files and
478 # then collects everything linked from those.  this is certainly quite
479 # unoptimized wrt mkdir calls, but does it really matter?
480 installdocs() {
481 for i in $(find -type f -name '*.htm*'); do
482         # bjam docu is included in the boost-jam RPM
483         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
484                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
485                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
486                         sub rewrite_link
487                         {
488                                 my $link = shift;
489                                 # rewrite links from boost/* to %{_includedir}/boost/* and
490                                 # ignore external links as well as document-internal ones.
491                                 # HTML files are also ignored as they get installed anyway.
492                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
493                                 {
494                                         (my $file = $link) =~ s/\#.*//;
495                                         print "$file\n";
496                                 }
497                                 $link;
498                         }
499                         open IN, @ARGV[0];
500                         open OUT, ">@ARGV[1]";
501                         my $in_link;
502                         while (<IN>)
503                         {
504                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
505                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
506                                 print OUT;
507                                 $in_link = /href|src=\s*$/;
508                         }
509 EOT`; do
510                         TARGET=${i%/*}/$LINKED
511                         # ignore non-existant linked files
512                         if test -f $TARGET; then
513                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
514                         fi
515                 done
516         fi
517 done
518 }; installdocs
519
520 %clean
521 rm -rf $RPM_BUILD_ROOT
522
523 %post   -p /sbin/ldconfig
524 %postun -p /sbin/ldconfig
525
526 %post   chrono -p /sbin/ldconfig
527 %postun chrono -p /sbin/ldconfig
528
529 %post   context -p /sbin/ldconfig
530 %postun context -p /sbin/ldconfig
531
532 %post   date_time -p /sbin/ldconfig
533 %postun date_time -p /sbin/ldconfig
534
535 %post   filesystem -p /sbin/ldconfig
536 %postun filesystem -p /sbin/ldconfig
537
538 %post   graph -p /sbin/ldconfig
539 %postun graph -p /sbin/ldconfig
540
541 %post   locale -p /sbin/ldconfig
542 %postun locale -p /sbin/ldconfig
543
544 %post   python -p /sbin/ldconfig
545 %postun python -p /sbin/ldconfig
546
547 %post   program_options -p /sbin/ldconfig
548 %postun program_options -p /sbin/ldconfig
549
550 %post   regex -p /sbin/ldconfig
551 %postun regex -p /sbin/ldconfig
552
553 %post   signals -p /sbin/ldconfig
554 %postun signals -p /sbin/ldconfig
555
556 %post   system -p /sbin/ldconfig
557 %postun system -p /sbin/ldconfig
558
559 %post   test -p /sbin/ldconfig
560 %postun test -p /sbin/ldconfig
561
562 %post   thread -p /sbin/ldconfig
563 %postun thread -p /sbin/ldconfig
564
565 %post   timer -p /sbin/ldconfig
566 %postun timer -p /sbin/ldconfig
567
568 %post   wave -p /sbin/ldconfig
569 %postun wave -p /sbin/ldconfig
570
571 %files
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
574 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
575 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
576 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
577 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
578 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
579 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
580
581 %files devel
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/libboost_atomic.so
584 %attr(755,root,root) %{_libdir}/libboost_chrono.so
585 %attr(755,root,root) %{_libdir}/libboost_context.so
586 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
587 %attr(755,root,root) %{_libdir}/libboost_date_time.so
588 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
589 %attr(755,root,root) %{_libdir}/libboost_graph.so
590 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
591 %attr(755,root,root) %{_libdir}/libboost_locale.so
592 %attr(755,root,root) %{_libdir}/libboost_log.so
593 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
594 %attr(755,root,root) %{_libdir}/libboost_math_*.so
595 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
596 %attr(755,root,root) %{_libdir}/libboost_program_options.so
597 %attr(755,root,root) %{_libdir}/libboost_regex.so
598 %attr(755,root,root) %{_libdir}/libboost_random.so
599 %attr(755,root,root) %{_libdir}/libboost_serialization.so
600 %attr(755,root,root) %{_libdir}/libboost_signals.so
601 %attr(755,root,root) %{_libdir}/libboost_system.so
602 %attr(755,root,root) %{_libdir}/libboost_thread.so
603 %attr(755,root,root) %{_libdir}/libboost_timer.so
604 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
605 %attr(755,root,root) %{_libdir}/libboost_wave.so
606 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
607 %{_includedir}/boost
608 %exclude %{_includedir}/boost/python
609 %exclude %{_includedir}/boost/python.hpp
610
611 %files static
612 %defattr(644,root,root,755)
613 %{_libdir}/libboost_atomic.a
614 %{_libdir}/libboost_chrono.a
615 %{_libdir}/libboost_context.a
616 %{_libdir}/libboost_coroutine.a
617 %{_libdir}/libboost_date_time.a
618 %{_libdir}/libboost_exception.a
619 %{_libdir}/libboost_filesystem.a
620 %{_libdir}/libboost_graph.a
621 %{_libdir}/libboost_iostreams.a
622 %{_libdir}/libboost_locale.a
623 %{_libdir}/libboost_log.a
624 %{_libdir}/libboost_log_setup.a
625 %{_libdir}/libboost_math_*.a
626 %{_libdir}/libboost_prg_exec_monitor.a
627 %{_libdir}/libboost_program_options.a
628 %{_libdir}/libboost_random.a
629 %{_libdir}/libboost_regex.a
630 %{_libdir}/libboost_serialization.a
631 %{_libdir}/libboost_signals.a
632 %{_libdir}/libboost_system.a
633 %{_libdir}/libboost_test_exec_monitor.a
634 %{_libdir}/libboost_timer.a
635 %{_libdir}/libboost_thread.a
636 %{_libdir}/libboost_unit_test_framework.a
637 %{_libdir}/libboost_wave.a
638 %{_libdir}/libboost_wserialization.a
639
640 %if %{with python}
641 %files python
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
644
645 %files python-devel
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libboost_python.so
648 %{_includedir}/boost/python
649 %{_includedir}/boost/python.hpp
650
651 %files python-static
652 %defattr(644,root,root,755)
653 %{_libdir}/libboost_python.a
654 %endif
655
656 %files chrono
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
659
660 %files context
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
663
664 %files date_time
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
667
668 %files filesystem
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
671
672 %files graph
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
675
676 %files locale
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
679
680 %files log
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
683 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
684
685 %files program_options
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
688
689 %files regex
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
692
693 %files signals
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
696
697 %files system
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
700
701 %files test
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
704 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
705
706 %files thread
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
709
710 %files timer
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
713
714 %files wave
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
717
718 %files doc
719 %defattr(644,root,root,755)
720 %{_docdir}/%{name}-%{version}
This page took 0.103009 seconds and 3 git commands to generate.