]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
future todo: use .7z download
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python2         # without boost-python2 support
8 %bcond_without  python3         # without boost-python3 support
9
10 %define         fver    %(echo %{version} | tr . _)
11 Summary:        The Boost C++ Libraries
12 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
13 Name:           boost
14 Version:        1.61.0
15 Release:        2
16 License:        Boost Software License and others
17 Group:          Libraries
18 # TODO: use .7z extension:
19 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
20 # Source0-md5:  6095876341956f65f9d35939ccea1a9f
21 Patch0:         %{name}-link.patch
22 Patch1:         %{name}-x32-context.patch
23 Patch2:         %{name}-clean-gcc-flags.patch
24 # FC Patches:
25 # https://svn.boost.org/trac/boost/ticket/5637
26 Patch203:       %{name}-1.54.0-mpl-print.patch
27 # https://svn.boost.org/trac/boost/ticket/8881
28 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
29 URL:            http://www.boost.org/
30 BuildRequires:  bzip2-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  libicu-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  perl-base
35 %{?with_python:BuildRequires:   python-devel >= 2.2}
36 %{?with_python3:BuildRequires:  python3-devel}
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  zlib-devel
39 BuildConflicts: gcc = 5:3.3.1
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
43
44 %description
45 The Boost web site provides free peer-reviewed portable C++ source
46 libraries. The emphasis is on libraries which work well with the C++
47 Standard Library. One goal is to establish "existing practice" and
48 provide reference implementations so that the Boost libraries are
49 suitable for eventual standardization. Some of the libraries have
50 already been proposed for inclusion in the C++ Standards Committee's
51 upcoming C++ Standard Library Technical Report.
52
53 %description -l pl.UTF-8
54 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
55 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
56 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
57 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
58 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
59 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
60 Raporcie Technicznym Biblioteki Standardowej C++.
61
62 %package devel
63 Summary:        Boost C++ development headers
64 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       %{name}-chrono = %{version}-%{release}
68 Requires:       %{name}-context = %{version}-%{release}
69 Requires:       %{name}-date_time = %{version}-%{release}
70 Requires:       %{name}-filesystem = %{version}-%{release}
71 Requires:       %{name}-graph = %{version}-%{release}
72 Requires:       %{name}-locale = %{version}-%{release}
73 Requires:       %{name}-log = %{version}-%{release}
74 Requires:       %{name}-program_options = %{version}-%{release}
75 Requires:       %{name}-regex = %{version}-%{release}
76 Requires:       %{name}-signals = %{version}-%{release}
77 Requires:       %{name}-system = %{version}-%{release}
78 Requires:       %{name}-test = %{version}-%{release}
79 Requires:       %{name}-thread = %{version}-%{release}
80 Requires:       %{name}-timer = %{version}-%{release}
81 Requires:       %{name}-wave = %{version}-%{release}
82 Requires:       libstdc++-devel
83 Obsoletes:      boost-any-devel
84 Obsoletes:      boost-array-devel
85 Obsoletes:      boost-asio
86 Obsoletes:      boost-bind-devel
87 Obsoletes:      boost-call_traits-devel
88 Obsoletes:      boost-compatibility-devel
89 Obsoletes:      boost-compose-devel
90 Obsoletes:      boost-compressed_pair-devel
91 Obsoletes:      boost-concept_check-devel
92 Obsoletes:      boost-conversion-devel
93 Obsoletes:      boost-crc-devel
94 Obsoletes:      boost-date_time-devel
95 Obsoletes:      boost-filesystem-devel
96 Obsoletes:      boost-graph-devel
97 Obsoletes:      boost-mem_fn-devel
98 Obsoletes:      boost-mpl-devel
99 Obsoletes:      boost-preprocessor-devel
100 Obsoletes:      boost-program_options-devel
101 Obsoletes:      boost-ref-devel
102 Obsoletes:      boost-regex-devel
103 Obsoletes:      boost-signals-devel
104 Obsoletes:      boost-spirit-devel
105 Obsoletes:      boost-statechart-devel
106 Obsoletes:      boost-static_assert-devel
107 Obsoletes:      boost-test-devel
108 Obsoletes:      boost-thread-devel
109 Obsoletes:      boost-tr1-devel
110 Obsoletes:      boost-type_traits-devel
111 Obsoletes:      boost-typeof-devel
112 Obsoletes:      boost-uBLAS-devel
113 Obsoletes:      boost-utility-devel
114 Obsoletes:      boost-wave-devel
115 Obsoletes:      boost-xpressive-devel
116
117 %description devel
118 Header files for the Boost C++ libraries.
119
120 %description devel -l pl.UTF-8
121 Pliki nagłówkowe bibliotek C++ Boost.
122
123 %package static
124 Summary:        Static version of base Boost C++ libraries
125 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
126 Group:          Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128 Obsoletes:      boost-static < 1.33
129
130 %description static
131 Static version of base Boost C++ libraries.
132
133 %description static -l pl.UTF-8
134 Statyczne wersje podstawowych bibliotek C++ Boost.
135
136 %package python-devel-common
137 Summary:        Boost.Python development headers
138 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Boost.Python
139 Group:          Development/Libraries
140 Requires:       %{name}-devel = %{version}-%{release}
141
142 %description python-devel-common
143 Headers for the Boost.Python library.
144
145 %description python-devel-common -l pl.UTF-8
146 Pliki nagłówkowe biblioteki Boost.Python.
147
148 %package python
149 Summary:        Boost.Python library for Python 2
150 Summary(pl.UTF-8):      Biblioteka Boost.Python dla Pythona 2
151 Group:          Libraries
152 Requires:       python-libs
153
154 %description python
155 Use the Boost Python Library to quickly and easily export a C++
156 library to Python 2 such that the Python 2 interface is very similar
157 to the C++ interface. It is designed to be minimally intrusive on your
158 C++ design. In most cases, you should not have to alter your C++
159 classes in any way in order to use them with Boost.Python. The system
160 should simply ``reflect'' your C++ classes and functions into Python
161 3.
162
163 %description python -l pl.UTF-8
164 Biblioteka Boost Python służy do szybkiego i prostego eksportu
165 biblioteki C++ do Pythona 2, tak że interfejs Pythona 2 jest bardzo
166 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
167 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
168 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
169 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
170 klasy C++ i funkcje do Pythona 3.
171
172 %package python-devel
173 Summary:        Boost.Python development files for Python 2
174 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 2
175 Group:          Development/Libraries
176 Requires:       %{name}-devel = %{version}-%{release}
177 Requires:       %{name}-python = %{version}-%{release}
178 Requires:       %{name}-python-devel-common = %{version}-%{release}
179
180 %description python-devel
181 Boost.Python development files for Python 2.
182
183 %description python-devel -l pl.UTF-8
184 Pliki programistyczne biblioteki Boost.Python dla Pythona 2.
185
186 %package python-static
187 Summary:        Static version of Boost.Python library for Python 2
188 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 2
189 Group:          Development/Libraries
190 Requires:       %{name}-python-devel = %{version}-%{release}
191
192 %description python-static
193 Static version of Boost.Python library for Python 2.
194
195 %description python-static -l pl.UTF-8
196 Statyczna wersja biblioteki Boost.Python dla Pythona 2.
197
198 %package python3
199 Summary:        Boost.Python library for Python 3
200 Summary(pl.UTF-8):      biblioteka Boost.Python dla Pythona 3
201 Group:          Libraries
202 Requires:       python3-libs
203
204 %description python3
205 Use the Boost Python Library to quickly and easily export a C++
206 library to Python 3 such that the Python 3 interface is very similar
207 to the C++ interface. It is designed to be minimally intrusive on your
208 C++ design. In most cases, you should not have to alter your C++
209 classes in any way in order to use them with Boost.Python. The system
210 should simply ``reflect'' your C++ classes and functions into Python
211 3.
212
213 %description python3 -l pl.UTF-8
214 Biblioteka Boost Python służy do szybkiego i prostego eksportu
215 biblioteki C++ do Pythona 3, tak że interfejs Pythona 3 jest bardzo
216 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
217 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
218 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
219 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
220 klasy C++ i funkcje do Pythona 3.
221
222 %package python3-devel
223 Summary:        Boost.Python development files for Python 3
224 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Boost.Python dla Pythona 3
225 Group:          Development/Libraries
226 Requires:       %{name}-devel = %{version}-%{release}
227 Requires:       %{name}-python-devel-common = %{version}-%{release}
228 Requires:       %{name}-python3 = %{version}-%{release}
229
230 %description python3-devel
231 Boost.Python development files for Python 3.
232
233 %description python3-devel -l pl.UTF-8
234 Pliki programistyczne biblioteki Boost.Python dla Pythona 3.
235
236 %package python3-static
237 Summary:        Static version of Boost.Python library for Python 3
238 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python dla Pythona 3
239 Group:          Development/Libraries
240 Requires:       %{name}-python3-devel = %{version}-%{release}
241
242 %description python3-static
243 Static version of Boost.Python library for Python 3.
244
245 %description python3-static -l pl.UTF-8
246 Statyczna wersja biblioteki Boost.Python dla Pythona 3.
247
248 %package chrono
249 Summary:        Useful time utilities
250 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
251 Group:          Libraries
252 Obsoletes:      boost < 1.33
253
254 %description chrono
255 Useful time utilities.
256
257 %description chrono -l pl.UTF-8
258 Przydatne funkcje związane z czasem.
259
260 %package context
261 Summary:        Boost.Context - context switching library
262 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
263 Group:          Libraries
264
265 %description context
266 Boost.Context - context switching library, providing a sort of
267 cooperative multitasking on a single thread.
268
269 %description context -l pl.UTF-8
270 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
271 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
272
273 %package date_time
274 Summary:        Date-Time library
275 Summary(pl.UTF-8):      Biblioteka daty-czasu
276 Group:          Libraries
277 Obsoletes:      boost < 1.33
278
279 %description date_time
280 A set of date-time libraries.
281
282 %description date_time -l pl.UTF-8
283 Zbiór bibliotek daty-czasu.
284
285 %package filesystem
286 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
287 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
288 Group:          Libraries
289 Requires:       %{name}-system = %{version}-%{release}
290 Obsoletes:      boost < 1.33
291
292 %description filesystem
293 The boost::filesystem library provides portable facilities to query
294 and manipulate paths, files, and directories.
295
296 %description filesystem -l pl.UTF-8
297 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
298 operacjach na ścieżkach, plikach i katalogach.
299
300 %package graph
301 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
302 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
303 Group:          Libraries
304
305 %description graph
306 The boost::graph library provides portable facilities to operate on
307 graph data structures using graph algorithms.
308
309 %description graph -l pl.UTF-8
310 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
311 strukturach danych typu graf za pomocą algorytmów związanych z
312 grafami.
313
314 %package locale
315 Summary:        Provide localization and Unicode handling tools for C++
316 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
317 Group:          Libraries
318
319 %description locale
320 Provide localization and Unicode handling tools for C++.
321
322 %description locale -l pl.UTF-8
323 Narzędzia do obsługi lokalizacji i Unikodu w C++.
324
325 %package log
326 Summary:        Provide logging tools for C++
327 Summary(pl.UTF-8):      Narzędzia do logowania w C++
328 Group:          Libraries
329
330 %description log
331 Provide logging tools for C++.
332
333 %description log -l pl.UTF-8
334 Narzędzia do logowania w C++.
335
336 %package program_options
337 Summary:        Access to program options, via conventional methods such as command line and config file
338 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
339 Group:          Libraries
340
341 %description program_options
342 The program_options library allows program developers to obtain
343 program options, that is (name, value) pairs from the user, via
344 conventional methods such as command line and config file.
345
346 %description program_options -l pl.UTF-8
347 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
348 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
349 jak linia poleceń, czy plik konfiguracyjny.
350
351 %package regex
352 Summary:        Boost C++ regular expressions library
353 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
354 Group:          Libraries
355
356 %description regex
357 Shared library for Boost C++ regular expressions.
358
359 %description regex -l pl.UTF-8
360 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
361
362 %package signals
363 Summary:        Signals & slots callback implementation
364 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
365 Group:          Libraries
366 Obsoletes:      boost < 1.33
367
368 %description signals
369 The boost::signals library is an implementation of a signals and slots
370 system.
371
372 %description signals -l pl.UTF-8
373 Biblioteka boost::signals jest implementacją systemu sygnałów i
374 slotów.
375
376 %package system
377 Summary:        Support for getting system specific error codes
378 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
379 Group:          Libraries
380
381 %description system
382 The Boost System library provides simple, light-weight error_code
383 objects that encapsulate system-specific error code values, yet also
384 provide access to more abstract and portable error conditions objects.
385
386 %description system -l pl.UTF-8
387 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
388 obudowujące wartości kodów błędów specyficznych dla systemu, dając
389 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
390 błędów.
391
392 %package test
393 Summary:        Support for program testing and execution monitoring
394 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
395 Group:          Libraries
396 Obsoletes:      boost < 1.33
397
398 %description test
399 Support for simple program testing, full unit testing, and for program
400 execution monitoring.
401
402 %description test -l pl.UTF-8
403 Wsparcie dla prostego testowania programu, pełnego testowania i
404 monitorowania wykonania programu.
405
406 %package thread
407 Summary:        Portable C++ threads library
408 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
409 Group:          Libraries
410 Obsoletes:      boost < 1.33
411
412 %description thread
413 Portable C++ threads library - shared library.
414
415 %description thread -l pl.UTF-8
416 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
417
418 %package timer
419 Summary:        Event timer, progress timer, and progress display classes
420 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
421 Group:          Libraries
422 Obsoletes:      boost < 1.33
423
424 %description timer
425 Event timer, progress timer, and progress display classes.
426
427 %description timer -l pl.UTF-8
428 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
429
430 %package wave
431 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
432 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
433 Group:          Development/Libraries
434
435 %description wave
436 Boost.Wave - a standard compliant C++ preprocessor library.
437
438 %description wave -l pl.UTF-8
439 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
440
441 %package doc
442 Summary:        Boost C++ Library documentation
443 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
444 Group:          Documentation
445 %if "%{_rpmversion}" >= "5"
446 BuildArch:      noarch
447 %endif
448
449 %description doc
450 Documentation for the Boost C++ Library.
451
452 %description doc -l pl.UTF-8
453 Dokumentacja dla biblioteki Boost C++.
454
455 %prep
456 %setup -q -n %{name}_%{fver}
457 %patch0 -p1
458 %patch1 -p1
459 %patch2 -p1
460
461 %patch203 -p0
462 %patch221 -p1
463
464 cat << EOF > tools/build/src/user-config.jam
465 using gcc : %{cxx_version} : %{__cxx} : <cflags>"%{rpmcflags} -fPIC" <cxxflags>"%{rpmcxxflags} -fPIC" <linkflags>"%{rpmldflags}" ;
466 EOF
467
468 # cleanup backups after patching
469 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
470
471 %build
472 EXPAT_INCLUDE=%{_includedir} \
473 EXPAT_LIBPATH=%{_libdir} \
474 ICU_PATH=%{_prefix} \
475 ./bootstrap.sh \
476         --prefix=%{_prefix} \
477         -without-libraries=python
478
479 ./b2 \
480         -d2 --toolset=gcc \
481         variant=release \
482         debug-symbols=on \
483         inlining=on \
484         link=static,shared \
485         threading=multi
486
487 %if %{with python3}
488 echo "using python : %{py3_ver}m : %{py3_prefix} : %{py3_incdir} ;" >> project-config.jam
489 ./b2 \
490         --with-python python=%{py3_ver}m \
491         -a -d2 --toolset=gcc \
492         variant=release \
493         debug-symbols=on \
494         inlining=on \
495         link=static,shared \
496         threading=multi
497 %endif
498
499 %if %{with python2}
500 echo "using python : %{py_ver} : %{py_prefix} : %{py_incdir} ;" >> project-config.jam
501 ./b2 \
502         --with-python python=%{py_ver} \
503         -a -d2 --toolset=gcc \
504         variant=release \
505         debug-symbols=on \
506         inlining=on \
507         link=static,shared \
508         threading=multi
509 %endif
510
511 %install
512 rm -rf $RPM_BUILD_ROOT
513 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
514
515 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
516
517 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
518 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
519 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
520
521 # documentation
522 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
523
524 # as the documentation doesn't completely reside in a directory of its
525 # own, we need to find out ourselves... this looks for HTML files and
526 # then collects everything linked from those.  this is certainly quite
527 # unoptimized wrt mkdir calls, but does it really matter?
528 installdocs() {
529 for i in $(find -type f -name '*.htm*'); do
530         # bjam docu is included in the boost-jam RPM
531         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
532                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
533                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
534                         sub rewrite_link
535                         {
536                                 my $link = shift;
537                                 # rewrite links from boost/* to %{_includedir}/boost/* and
538                                 # ignore external links as well as document-internal ones.
539                                 # HTML files are also ignored as they get installed anyway.
540                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
541                                 {
542                                         (my $file = $link) =~ s/\#.*//;
543                                         print "$file\n";
544                                 }
545                                 $link;
546                         }
547                         open IN, @ARGV[0];
548                         open OUT, ">@ARGV[1]";
549                         my $in_link;
550                         while (<IN>)
551                         {
552                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
553                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
554                                 print OUT;
555                                 $in_link = /href|src=\s*$/;
556                         }
557 EOT`; do
558                         TARGET=${i%/*}/$LINKED
559                         # ignore non-existant linked files
560                         if test -f $TARGET; then
561                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
562                         fi
563                 done
564         fi
565 done
566 }; installdocs
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %post   -p /sbin/ldconfig
572 %postun -p /sbin/ldconfig
573
574 %post   chrono -p /sbin/ldconfig
575 %postun chrono -p /sbin/ldconfig
576
577 %post   context -p /sbin/ldconfig
578 %postun context -p /sbin/ldconfig
579
580 %post   date_time -p /sbin/ldconfig
581 %postun date_time -p /sbin/ldconfig
582
583 %post   filesystem -p /sbin/ldconfig
584 %postun filesystem -p /sbin/ldconfig
585
586 %post   graph -p /sbin/ldconfig
587 %postun graph -p /sbin/ldconfig
588
589 %post   locale -p /sbin/ldconfig
590 %postun locale -p /sbin/ldconfig
591
592 %post   python -p /sbin/ldconfig
593 %postun python -p /sbin/ldconfig
594
595 %post   python3 -p /sbin/ldconfig
596 %postun python3 -p /sbin/ldconfig
597
598 %post   program_options -p /sbin/ldconfig
599 %postun program_options -p /sbin/ldconfig
600
601 %post   regex -p /sbin/ldconfig
602 %postun regex -p /sbin/ldconfig
603
604 %post   signals -p /sbin/ldconfig
605 %postun signals -p /sbin/ldconfig
606
607 %post   system -p /sbin/ldconfig
608 %postun system -p /sbin/ldconfig
609
610 %post   test -p /sbin/ldconfig
611 %postun test -p /sbin/ldconfig
612
613 %post   thread -p /sbin/ldconfig
614 %postun thread -p /sbin/ldconfig
615
616 %post   timer -p /sbin/ldconfig
617 %postun timer -p /sbin/ldconfig
618
619 %post   wave -p /sbin/ldconfig
620 %postun wave -p /sbin/ldconfig
621
622 %files
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
625 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
626 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
627 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
628 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
629 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
630 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
631 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so.*.*.*
632 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
633
634 %files devel
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/libboost_atomic.so
637 %attr(755,root,root) %{_libdir}/libboost_chrono.so
638 %attr(755,root,root) %{_libdir}/libboost_container.so
639 %attr(755,root,root) %{_libdir}/libboost_context.so
640 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
641 %attr(755,root,root) %{_libdir}/libboost_date_time.so
642 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
643 %attr(755,root,root) %{_libdir}/libboost_graph.so
644 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
645 %attr(755,root,root) %{_libdir}/libboost_locale.so
646 %attr(755,root,root) %{_libdir}/libboost_log.so
647 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
648 %attr(755,root,root) %{_libdir}/libboost_math_*.so
649 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
650 %attr(755,root,root) %{_libdir}/libboost_program_options.so
651 %attr(755,root,root) %{_libdir}/libboost_regex.so
652 %attr(755,root,root) %{_libdir}/libboost_random.so
653 %attr(755,root,root) %{_libdir}/libboost_serialization.so
654 %attr(755,root,root) %{_libdir}/libboost_signals.so
655 %attr(755,root,root) %{_libdir}/libboost_system.so
656 %attr(755,root,root) %{_libdir}/libboost_thread.so
657 %attr(755,root,root) %{_libdir}/libboost_timer.so
658 %attr(755,root,root) %{_libdir}/libboost_type_erasure.so
659 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
660 %attr(755,root,root) %{_libdir}/libboost_wave.so
661 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
662 %{_includedir}/boost
663 %exclude %{_includedir}/boost/python
664 %exclude %{_includedir}/boost/python.hpp
665
666 %files static
667 %defattr(644,root,root,755)
668 %{_libdir}/libboost_atomic.a
669 %{_libdir}/libboost_chrono.a
670 %{_libdir}/libboost_container.a
671 %{_libdir}/libboost_context.a
672 %{_libdir}/libboost_coroutine.a
673 %{_libdir}/libboost_date_time.a
674 %{_libdir}/libboost_exception.a
675 %{_libdir}/libboost_filesystem.a
676 %{_libdir}/libboost_graph.a
677 %{_libdir}/libboost_iostreams.a
678 %{_libdir}/libboost_locale.a
679 %{_libdir}/libboost_log.a
680 %{_libdir}/libboost_log_setup.a
681 %{_libdir}/libboost_math_*.a
682 %{_libdir}/libboost_prg_exec_monitor.a
683 %{_libdir}/libboost_program_options.a
684 %{_libdir}/libboost_random.a
685 %{_libdir}/libboost_regex.a
686 %{_libdir}/libboost_serialization.a
687 %{_libdir}/libboost_signals.a
688 %{_libdir}/libboost_system.a
689 %{_libdir}/libboost_test_exec_monitor.a
690 %{_libdir}/libboost_timer.a
691 %{_libdir}/libboost_thread.a
692 %{_libdir}/libboost_type_erasure.a
693 %{_libdir}/libboost_unit_test_framework.a
694 %{_libdir}/libboost_wave.a
695 %{_libdir}/libboost_wserialization.a
696
697 %if %{with python2} || %{with python3}
698 %files python-devel-common
699 %defattr(644,root,root,755)
700 %{_includedir}/boost/python
701 %{_includedir}/boost/python.hpp
702 %endif
703
704 %if %{with python2}
705 %files python
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
708
709 %files python-devel
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/libboost_python.so
712
713 %files python-static
714 %defattr(644,root,root,755)
715 %{_libdir}/libboost_python.a
716 %endif
717
718 %if %{with python3}
719 %files python3
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/libboost_python3.so.*.*.*
722
723 %files python3-devel
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/libboost_python3.so
726
727 %files python3-static
728 %defattr(644,root,root,755)
729 %{_libdir}/libboost_python3.a
730 %endif
731
732 %files chrono
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
735
736 %files context
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
739
740 %files date_time
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
743
744 %files filesystem
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
747
748 %files graph
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
751
752 %files locale
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
755
756 %files log
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
759 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
760
761 %files program_options
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
764
765 %files regex
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
768
769 %files signals
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
772
773 %files system
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
776
777 %files test
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
780 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
781
782 %files thread
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
785
786 %files timer
787 %defattr(644,root,root,755)
788 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
789
790 %files wave
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
793
794 %files doc
795 %defattr(644,root,root,755)
796 %{_docdir}/%{name}-%{version}
This page took 0.561036 seconds and 3 git commands to generate.