]> git.pld-linux.org Git - packages/boost.git/blame - boost.spec
- pl for -chrono, -locale, -timer
[packages/boost.git] / boost.spec
CommitLineData
c6874538 1#
bde731a5 2# TODO:
09e2803f
PS
3# - think about building MPI.
4# - split shared libs from core package into -iostreams/-serialization.
bde731a5 5#
c6874538 6# Conditional build:
65d4777a 7%bcond_without python # without boost-python support
c6874538 8#
8b623265 9%define fver %(echo %{version} | tr . _)
c6874538 10Summary: The Boost C++ Libraries
aa63c3d9 11Summary(pl.UTF-8): Biblioteki C++ "Boost"
49f48a3b 12Name: boost
17ef6e53 13Version: 1.50.0
51d8ea0b 14Release: 1
db639b8e 15License: Boost Software License and others
c6874538 16Group: Libraries
8b623265 17Source0: http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
17ef6e53 18# Source0-md5: 52dd00be775e689f55a987baebccc462
8b623265 19Patch0: %{name}-link.patch
49f48a3b 20URL: http://www.boost.org/
afbf1450 21BuildRequires: bzip2-devel
09e2803f 22BuildRequires: expat-devel
7c12a8f9 23BuildRequires: libicu-devel
49f48a3b 24BuildRequires: libstdc++-devel
30964b71 25BuildRequires: perl-base
6725319f 26%{?with_python:BuildRequires: python-devel >= 2.2}
dbf04d57 27BuildRequires: rpm-pythonprov
afbf1450 28BuildRequires: zlib-devel
c6874538 29BuildConflicts: gcc = 5:3.3.1
49f48a3b 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
c6874538 31
32%description
33The Boost web site provides free peer-reviewed portable C++ source
34libraries. The emphasis is on libraries which work well with the C++
35Standard Library. One goal is to establish "existing practice" and
36provide reference implementations so that the Boost libraries are
37suitable for eventual standardization. Some of the libraries have
38already been proposed for inclusion in the C++ Standards Committee's
39upcoming C++ Standard Library Technical Report.
40
4c35df9e 41%description -l pl.UTF-8
49f48a3b 42Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
4c35df9e
JR
43kodem źródłowym. Nacisk położono na biblioteki, które dobrze
44współpracują ze standardową biblioteką C++. Celem jest ustanowienie
45"istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
46"Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
47już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
2b583775 48Raporcie Technicznym Biblioteki Standardowej C++.
c6874538 49
49f48a3b 50%package devel
000cd675 51Summary: Boost C++ development headers
aa63c3d9 52Summary(pl.UTF-8): Pliki nagłówkowe bibliotek C++ Boost
49f48a3b 53Group: Development/Libraries
000cd675 54Requires: %{name} = %{version}-%{release}
09e2803f
PS
55Requires: %{name}-date_time = %{version}-%{release}
56Requires: %{name}-filesystem = %{version}-%{release}
57Requires: %{name}-graph = %{version}-%{release}
58Requires: %{name}-program_options = %{version}-%{release}
59Requires: %{name}-regex = %{version}-%{release}
60Requires: %{name}-signals = %{version}-%{release}
69912bfb 61Requires: %{name}-system = %{version}-%{release}
09e2803f
PS
62Requires: %{name}-test = %{version}-%{release}
63Requires: %{name}-thread = %{version}-%{release}
64Requires: %{name}-wave = %{version}-%{release}
49f48a3b 65Requires: libstdc++-devel
09e2803f
PS
66Obsoletes: boost-any-devel
67Obsoletes: boost-array-devel
875f51e3 68Obsoletes: boost-asio
09e2803f 69Obsoletes: boost-bind-devel
05b0e240 70Obsoletes: boost-call_traits-devel
09e2803f 71Obsoletes: boost-compatibility-devel
470f1aae 72Obsoletes: boost-compose-devel
09e2803f 73Obsoletes: boost-compressed_pair-devel
89fd45a2
JB
74Obsoletes: boost-concept_check-devel
75Obsoletes: boost-conversion-devel
09e2803f
PS
76Obsoletes: boost-crc-devel
77Obsoletes: boost-date_time-devel
78Obsoletes: boost-filesystem-devel
79Obsoletes: boost-graph-devel
80Obsoletes: boost-mem_fn-devel
89fd45a2
JB
81Obsoletes: boost-mpl-devel
82Obsoletes: boost-preprocessor-devel
09e2803f 83Obsoletes: boost-program_options-devel
7c797e1a 84Obsoletes: boost-ref-devel
09e2803f
PS
85Obsoletes: boost-regex-devel
86Obsoletes: boost-signals-devel
87Obsoletes: boost-spirit-devel
88Obsoletes: boost-statechart-devel
89fd45a2 89Obsoletes: boost-static_assert-devel
09e2803f
PS
90Obsoletes: boost-test-devel
91Obsoletes: boost-thread-devel
92Obsoletes: boost-tr1-devel
89fd45a2 93Obsoletes: boost-type_traits-devel
09e2803f
PS
94Obsoletes: boost-typeof-devel
95Obsoletes: boost-uBLAS-devel
89fd45a2 96Obsoletes: boost-utility-devel
09e2803f
PS
97Obsoletes: boost-wave-devel
98Obsoletes: boost-xpressive-devel
49f48a3b
JB
99
100%description devel
000cd675 101Header files for the Boost C++ libraries.
49f48a3b 102
4c35df9e
JR
103%description devel -l pl.UTF-8
104Pliki nagłówkowe bibliotek C++ Boost.
000cd675
JB
105
106%package static
107Summary: Static version of base Boost C++ libraries
aa63c3d9 108Summary(pl.UTF-8): Statyczne wersje podstawowych bibliotek C++ Boost
000cd675
JB
109Group: Development/Libraries
110Requires: %{name}-devel = %{version}-%{release}
09e2803f 111Obsoletes: boost-static < 1.33
000cd675
JB
112
113%description static
114Static version of base Boost C++ libraries.
115
4c35df9e 116%description static -l pl.UTF-8
000cd675 117Statyczne wersje podstawowych bibliotek C++ Boost.
49f48a3b 118
c6874538 119%package python
120Summary: Boost.Python library
aa63c3d9 121Summary(pl.UTF-8): biblioteka Boost.Python
c6874538 122Group: Libraries
6725319f 123%pyrequires_eq python
c6874538 124
125%description python
126Use the Boost Python Library to quickly and easily export a C++
127library to Python such that the Python interface is very similar to
128the C++ interface. It is designed to be minimally intrusive on your
129C++ design. In most cases, you should not have to alter your C++
130classes in any way in order to use them with Boost.Python. The system
131should simply ``reflect'' your C++ classes and functions into Python.
132
4c35df9e
JR
133%description python -l pl.UTF-8
134Biblioteka Boost Python służy do szybkiego i prostego eksportu
135biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
136podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
137narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
138większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
139żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
66ac0d93 140klasy C++ i funkcje do Pythona.
c6874538 141
142%package python-devel
143Summary: Boost.Python development headers
aa63c3d9 144Summary(pl.UTF-8): Pliki nagłówkowe dla Boost.Python
49f48a3b
JB
145Group: Development/Libraries
146Requires: %{name}-devel = %{version}-%{release}
6725319f 147Requires: %{name}-python = %{version}-%{release}
c6874538 148
149%description python-devel
66ac0d93 150Headers for the Boost.Python library.
c6874538 151
4c35df9e
JR
152%description python-devel -l pl.UTF-8
153Pliki nagłówkowe dla biblioteki Boost.Python.
c6874538 154
6725319f
JB
155%package python-static
156Summary: Static version of Boost.Python library
aa63c3d9 157Summary(pl.UTF-8): Statyczna wersja biblioteki Boost.Python
6725319f
JB
158Group: Development/Libraries
159Requires: %{name}-python-devel = %{version}-%{release}
160
161%description python-static
162Static version of Boost.Python library.
163
4c35df9e 164%description python-static -l pl.UTF-8
6725319f
JB
165Statyczna wersja biblioteki Boost.Python.
166
17e8d8c2
ŁK
167%package chrono
168Summary: Useful time utilities
d7f6b47a 169Summary(pl.UTF-8): Przydatne funkcje związane z czasem
17e8d8c2
ŁK
170Group: Libraries
171Obsoletes: boost < 1.33
172
173%description chrono
174Useful time utilities.
175
d7f6b47a
JB
176%description chrono -l pl.UTF-8
177Przydatne funkcje związane z czasem.
178
02c23151 179%package date_time
d143171f 180Summary: Date-Time library
aa63c3d9 181Summary(pl.UTF-8): Biblioteka daty-czasu
02c23151 182Group: Libraries
000cd675 183Obsoletes: boost < 1.33
02c23151 184
185%description date_time
186A set of date-time libraries.
187
4c35df9e
JR
188%description date_time -l pl.UTF-8
189Zbiór bibliotek daty-czasu.
02c23151 190
31026e88 191%package filesystem
192Summary: Portable paths, iteration over directories, and other useful filesystem operations
aa63c3d9 193Summary(pl.UTF-8): Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
31026e88 194Group: Libraries
69912bfb 195Requires: %{name}-system = %{version}-%{release}
000cd675 196Obsoletes: boost < 1.33
31026e88 197
198%description filesystem
04846599
JB
199The boost::filesystem library provides portable facilities to query
200and manipulate paths, files, and directories.
31026e88 201
4c35df9e
JR
202%description filesystem -l pl.UTF-8
203Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
204operacjach na ścieżkach, plikach i katalogach.
31026e88 205
06ed6468
AM
206%package graph
207Summary: General purpose, generic C++ library for graph data structures and graph algorithms
208Summary(pl.UTF-8): Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
209Group: Libraries
210
211%description graph
212The boost::graph library provides portable facilities to operate on
213graph data structures using graph algorithms.
214
215%description graph -l pl.UTF-8
216Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
217strukturach danych typu graf za pomocą algorytmów związanych z
218grafami.
219
17e8d8c2
ŁK
220%package locale
221Summary: Provide localization and Unicode handling tools for C++
d7f6b47a 222Summary(pl.UTF-8): Narzędzia do obsługi lokalizacji i Unikodu w C++
17e8d8c2
ŁK
223Group: Libraries
224
225%description locale
226Provide localization and Unicode handling tools for C++.
227
d7f6b47a
JB
228%description locale -l pl.UTF-8
229Narzędzia do obsługi lokalizacji i Unikodu w C++.
230
99f4684a 231%package program_options
232Summary: Access to program options, via conventional methods such as command line and config file
aa63c3d9 233Summary(pl.UTF-8): Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
99f4684a 234Group: Libraries
235
236%description program_options
237The program_options library allows program developers to obtain
238program options, that is (name, value) pairs from the user, via
239conventional methods such as command line and config file.
240
4c35df9e
JR
241%description program_options -l pl.UTF-8
242Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
243programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
244jak linia poleceń, czy plik konfiguracyjny.
99f4684a 245
09e2803f
PS
246%package regex
247Summary: Boost C++ regular expressions library
248Summary(pl.UTF-8): Biblioteka wyrażeń regularnych Boost C++
249Group: Libraries
99f4684a 250
09e2803f
PS
251%description regex
252Shared library for Boost C++ regular expressions.
99f4684a 253
09e2803f 254%description regex -l pl.UTF-8
d7f6b47a 255Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
99f4684a 256
db639b8e 257%package signals
75f9f612 258Summary: Signals & slots callback implementation
aa63c3d9 259Summary(pl.UTF-8): Implementacja sygnałów i slotów
db639b8e 260Group: Libraries
000cd675 261Obsoletes: boost < 1.33
db639b8e 262
263%description signals
264The boost::signals library is an implementation of a signals and slots
265system.
266
4c35df9e
JR
267%description signals -l pl.UTF-8
268Biblioteka boost::signals jest implementacją systemu sygnałów i
269slotów.
db639b8e 270
09e2803f
PS
271%package system
272Summary: Support for getting system specific error codes
273Summary(pl.UTF-8): Wsparcie dla pobierania specyficznych dla systemu kodów błędów
274Group: Libraries
06ed6468 275
09e2803f
PS
276%description system
277The Boost System library provides simple, light-weight error_code
278objects that encapsulate system-specific error code values, yet also
279provide access to more abstract and portable error conditions objects.
0651a785 280
2b583775
JB
281%description system -l pl.UTF-8
282Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
283obudowujące wartości kodów błędów specyficznych dla systemu, dając
284jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
285błędów.
286
c0536c7f 287%package test
09e2803f 288Summary: Support for program testing and execution monitoring
aa63c3d9 289Summary(pl.UTF-8): Wsparcie dla testowania i monitorowania programu
c0536c7f 290Group: Libraries
000cd675 291Obsoletes: boost < 1.33
c0536c7f 292
293%description test
294Support for simple program testing, full unit testing, and for program
295execution monitoring.
296
4c35df9e
JR
297%description test -l pl.UTF-8
298Wsparcie dla prostego testowania programu, pełnego testowania i
c0536c7f 299monitorowania wykonania programu.
300
17e8d8c2
ŁK
301%package timer
302Summary: Event timer, progress timer, and progress display classes
d7f6b47a 303Summary(pl.UTF-8): Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
17e8d8c2
ŁK
304Group: Libraries
305Obsoletes: boost < 1.33
306
307%description timer
308Event timer, progress timer, and progress display classes.
309
d7f6b47a
JB
310%description timer -l pl.UTF-8
311Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
312
02c23151 313%package thread
d143171f 314Summary: Portable C++ threads library
aa63c3d9 315Summary(pl.UTF-8): Przenośna biblioteka wątków C++
02c23151 316Group: Libraries
000cd675 317Obsoletes: boost < 1.33
02c23151 318
319%description thread
e4ddb7d1 320Portable C++ threads library - shared library.
02c23151 321
4c35df9e
JR
322%description thread -l pl.UTF-8
323Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
02c23151 324
06ed6468
AM
325%package wave
326Summary: Boost.Wave - a standard compliant C++ preprocessor library
327Summary(pl.UTF-8): Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
328Group: Development/Libraries
06ed6468
AM
329
330%description wave
331Boost.Wave - a standard compliant C++ preprocessor library.
332
333%description wave -l pl.UTF-8
334Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
335
c6874538 336%package doc
337Summary: Boost C++ Library documentation
aa63c3d9 338Summary(pl.UTF-8): Dokumentacja dla biblioteki Boost C++
49f48a3b 339Group: Documentation
b0977fb8 340Requires: %{name}-devel = %{version}-%{release}
c6874538 341
342%description doc
66ac0d93 343Documentation for the Boost C++ Library.
c6874538 344
4c35df9e 345%description doc -l pl.UTF-8
66ac0d93 346Dokumentacja dla biblioteki Boost C++.
c6874538 347
348%prep
8b623265 349%setup -q -n %{name}_%{fver}
09e2803f 350%patch0 -p1
c6874538 351
9b1806d5
PS
352# - don't know how to pass it through (b)jam -s (no way?)
353# due to oversophisticated build flags system.
354# - pass -fPIC due to <shared-linkable> removal.
0c1a0872 355%{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/v2/tools/gcc.jam
09e2803f
PS
356
357# cleanup -g switch to avoid override debuginfocflags.
358%{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/v2/tools/gcc.jam
359# link against shared expat library.
360%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
502f5d36 361
09e2803f
PS
362cat << EOF > tools/build/v2/user-config.jam
363using gcc : %(%{__cxx} -dumpversion) : %{__cxx} ;
364EOF
365
c6874538 366%build
49f48a3b 367%if %{with python}
7c12a8f9 368PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
c6874538 369PYTHON_ROOT=%{_prefix}
370%else
371PYTHON_ROOT=
372PYTHON_VERSION=
373%endif
09e2803f
PS
374EXPAT_INCLUDE=%{_includedir} \
375EXPAT_LIBPATH=%{_libdir} \
376ICU_PATH=%{_prefix} \
17e8d8c2
ŁK
377./bootstrap.sh --prefix=%{_prefix}
378./b2 \
9b1806d5 379 -d2 --toolset=gcc \
09e2803f 380 variant=release debug-symbols=on inlining=on link=static,shared threading=multi
9b1806d5 381
c6874538 382%install
383rm -rf $RPM_BUILD_ROOT
30964b71 384install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
c6874538 385
30964b71 386cp -rf boost $RPM_BUILD_ROOT%{_includedir}
c6874538 387
8b623265
JB
388install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
389install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
390cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
fa767695 391
c6874538 392# documentation
393install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
c6874538 394
395# as the documentation doesn't completely reside in a directory of its
396# own, we need to find out ourselves... this looks for HTML files and
397# then collects everything linked from those. this is certainly quite
398# unoptimized wrt mkdir calls, but does it really matter?
7c12a8f9
ER
399installdocs() {
400for i in $(find -type f -name '*.htm*'); do
c6874538 401 # bjam docu is included in the boost-jam RPM
402 if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
7c12a8f9 403 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
30964b71 404 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
c6874538 405 sub rewrite_link
406 {
407 my $link = shift;
408 # rewrite links from boost/* to %{_includedir}/boost/* and
409 # ignore external links as well as document-internal ones.
410 # HTML files are also ignored as they get installed anyway.
411 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
412 {
413 (my $file = $link) =~ s/\#.*//;
414 print "$file\n";
415 }
416 $link;
417 }
418 open IN, @ARGV[0];
419 open OUT, ">@ARGV[1]";
66ac0d93 420 my $in_link;
c6874538 421 while (<IN>)
422 {
66ac0d93 423 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
c6874538 424 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
425 print OUT;
d143171f 426 $in_link = /href|src=\s*$/;
c6874538 427 }
428EOT`; do
7c12a8f9 429 TARGET=${i%/*}/$LINKED
c6874538 430 # ignore non-existant linked files
431 if test -f $TARGET; then
7c12a8f9 432 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
c6874538 433 fi
434 done
435 fi
436done
7c12a8f9 437}; installdocs
c6874538 438
439%clean
440rm -rf $RPM_BUILD_ROOT
441
000cd675
JB
442%post -p /sbin/ldconfig
443%postun -p /sbin/ldconfig
444
17e8d8c2
ŁK
445%post chrono -p /sbin/ldconfig
446%postun chrono -p /sbin/ldconfig
447
3d8dd501
JB
448%post date_time -p /sbin/ldconfig
449%postun date_time -p /sbin/ldconfig
450
04846599
JB
451%post filesystem -p /sbin/ldconfig
452%postun filesystem -p /sbin/ldconfig
453
06ed6468
AM
454%post graph -p /sbin/ldconfig
455%postun graph -p /sbin/ldconfig
456
17e8d8c2
ŁK
457%post locale -p /sbin/ldconfig
458%postun locale -p /sbin/ldconfig
459
09e2803f
PS
460%post python -p /sbin/ldconfig
461%postun python -p /sbin/ldconfig
462
463%post program_options -p /sbin/ldconfig
464%postun program_options -p /sbin/ldconfig
c6874538 465
09e2803f
PS
466%post regex -p /sbin/ldconfig
467%postun regex -p /sbin/ldconfig
290ca6f4 468
09e2803f
PS
469%post signals -p /sbin/ldconfig
470%postun signals -p /sbin/ldconfig
c6874538 471
09e2803f
PS
472%post system -p /sbin/ldconfig
473%postun system -p /sbin/ldconfig
3d8dd501 474
09e2803f
PS
475%post test -p /sbin/ldconfig
476%postun test -p /sbin/ldconfig
c0536c7f 477
17e8d8c2
ŁK
478%post timer -p /sbin/ldconfig
479%postun timer -p /sbin/ldconfig
480
09e2803f
PS
481%post thread -p /sbin/ldconfig
482%postun thread -p /sbin/ldconfig
3d8dd501 483
d7f6b47a
JB
484%post wave -p /sbin/ldconfig
485%postun wave -p /sbin/ldconfig
486
000cd675
JB
487%files
488%defattr(644,root,root,755)
8b623265 489%attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
e019306a 490%attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
8b623265
JB
491%attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
492%attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
493%attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
000cd675 494
30964b71
JB
495%files devel
496%defattr(644,root,root,755)
17e8d8c2 497%attr(755,root,root) %{_libdir}/libboost_chrono.so
8b623265
JB
498%attr(755,root,root) %{_libdir}/libboost_date_time.so
499%attr(755,root,root) %{_libdir}/libboost_filesystem.so
500%attr(755,root,root) %{_libdir}/libboost_graph.so
501%attr(755,root,root) %{_libdir}/libboost_iostreams.so
17e8d8c2 502%attr(755,root,root) %{_libdir}/libboost_locale.so
e019306a 503%attr(755,root,root) %{_libdir}/libboost_math_*.so
8b623265
JB
504%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
505%attr(755,root,root) %{_libdir}/libboost_program_options.so
506%attr(755,root,root) %{_libdir}/libboost_regex.so
507%attr(755,root,root) %{_libdir}/libboost_random.so
508%attr(755,root,root) %{_libdir}/libboost_serialization.so
509%attr(755,root,root) %{_libdir}/libboost_signals.so
510%attr(755,root,root) %{_libdir}/libboost_system.so
511%attr(755,root,root) %{_libdir}/libboost_thread.so
17e8d8c2 512%attr(755,root,root) %{_libdir}/libboost_timer.so
8b623265
JB
513%attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
514%attr(755,root,root) %{_libdir}/libboost_wave.so
515%attr(755,root,root) %{_libdir}/libboost_wserialization.so
516%{_includedir}/boost
517%exclude %{_includedir}/boost/python
518%exclude %{_includedir}/boost/python.hpp
99f4684a 519
000cd675
JB
520%files static
521%defattr(644,root,root,755)
17e8d8c2 522%{_libdir}/libboost_chrono.a
8b623265 523%{_libdir}/libboost_date_time.a
17e8d8c2 524%{_libdir}/libboost_exception.a
8b623265
JB
525%{_libdir}/libboost_filesystem.a
526%{_libdir}/libboost_graph.a
527%{_libdir}/libboost_iostreams.a
17e8d8c2 528%{_libdir}/libboost_locale.a
e019306a 529%{_libdir}/libboost_math_*.a
8b623265
JB
530%{_libdir}/libboost_prg_exec_monitor.a
531%{_libdir}/libboost_program_options.a
532%{_libdir}/libboost_random.a
533%{_libdir}/libboost_regex.a
534%{_libdir}/libboost_serialization.a
535%{_libdir}/libboost_signals.a
536%{_libdir}/libboost_system.a
537%{_libdir}/libboost_test_exec_monitor.a
17e8d8c2 538%{_libdir}/libboost_timer.a
8b623265
JB
539%{_libdir}/libboost_thread.a
540%{_libdir}/libboost_unit_test_framework.a
541%{_libdir}/libboost_wave.a
542%{_libdir}/libboost_wserialization.a
db639b8e 543
49f48a3b 544%if %{with python}
30964b71 545%files python
49f48a3b 546%defattr(644,root,root,755)
8b623265 547%attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
49f48a3b 548
30964b71 549%files python-devel
c6874538 550%defattr(644,root,root,755)
8b623265 551%attr(755,root,root) %{_libdir}/libboost_python.so
30964b71
JB
552%{_includedir}/boost/python
553%{_includedir}/boost/python.hpp
554
6725319f
JB
555%files python-static
556%defattr(644,root,root,755)
8b623265 557%{_libdir}/libboost_python.a
c6874538 558%endif
559
17e8d8c2
ŁK
560%files chrono
561%defattr(644,root,root,755)
562%attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
563
02c23151 564%files date_time
565%defattr(644,root,root,755)
8b623265 566%attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
02c23151 567
31026e88 568%files filesystem
569%defattr(644,root,root,755)
8b623265 570%attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
31026e88 571
06ed6468
AM
572%files graph
573%defattr(644,root,root,755)
8b623265 574%attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
06ed6468 575
17e8d8c2
ŁK
576%files locale
577%defattr(644,root,root,755)
578%attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
579
99f4684a 580%files program_options
581%defattr(644,root,root,755)
8b623265 582%attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
99f4684a 583
09e2803f 584%files regex
99f4684a 585%defattr(644,root,root,755)
8b623265 586%attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
99f4684a 587
db639b8e 588%files signals
589%defattr(644,root,root,755)
8b623265 590%attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
db639b8e 591
09e2803f 592%files system
db639b8e 593%defattr(644,root,root,755)
8b623265 594%attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
06ed6468 595
c0536c7f 596%files test
597%defattr(644,root,root,755)
8b623265
JB
598%attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
599%attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
c0536c7f 600
17e8d8c2
ŁK
601%files timer
602%defattr(644,root,root,755)
603%attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
604
02c23151 605%files thread
606%defattr(644,root,root,755)
8b623265 607%attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
02c23151 608
06ed6468
AM
609%files wave
610%defattr(644,root,root,755)
8b623265 611%attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
06ed6468 612
30964b71 613%files doc
fe815c68 614%defattr(644,root,root,755)
75f9f612 615%{_docdir}/%{name}-%{version}
This page took 1.237768 seconds and 4 git commands to generate.