]> git.pld-linux.org Git - packages/blueman.git/blob - blueman.spec
up to 2.2.4
[packages/blueman.git] / blueman.spec
1 # Conditional build:
2 %bcond_without  cinnamon        # build without nemo support
3 %bcond_without  gnome           # build without nautilus support
4 %bcond_without  mate            # build without caja support
5 %bcond_without  xfce            # build without Thunar support
6
7 Summary:        Blueman - bluetooth management utility for GNOME
8 Name:           blueman
9 Version:        2.2.4
10 Release:        1
11 License:        GPL v3+
12 Group:          X11/Applications
13 Source0:        https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  5e7284c47b8f1dace80e97c1e4d4319f
15 Patch0:         ayatana-indicator.patch
16 URL:            https://github.com/blueman-project/blueman
17 BuildRequires:  bluez-libs-devel >= 5.48
18 %{?with_mate:BuildRequires:     caja-python-devel}
19 %{?with_cinnamon:BuildRequires: cinnamon-nemo-python-devel}
20 BuildRequires:  gettext-tools >= 0.19.7
21 BuildRequires:  glib2-devel >= 1:2.32
22 BuildRequires:  libtool
23 %{?with_gnome:BuildRequires:    nautilus-python-devel}
24 BuildRequires:  pkgconfig >= 1:0.9.0
25 BuildRequires:  polkit-devel
26 BuildRequires:  python-pygobject3-common-devel >= 3.27.2
27 BuildRequires:  python3-Cython
28 BuildRequires:  python3-devel >= 1:3.6
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 2.011
31 BuildRequires:  systemd-units
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires(post,postun):  gtk-update-icon-cache
35 Requires(post,postun):  hicolor-icon-theme
36 Requires(post,preun,postun):    systemd-units >= 250.1
37 Requires:       bluez >= 5.48
38 Requires:       dbus >= 1.9.18
39 Requires:       glib2 >= 1:2.32
40 Requires:       gtk+3 >= 3.22
41 Requires:       pango
42 Requires:       python3 >= %py3_ver
43 Requires:       python3-pycairo
44 Requires:       python3-pygobject3 >= 3.27.2
45 Requires:       systemd-units >= 250.1
46 Suggests:       NetworkManager-libs
47 Suggests:       iproute2
48 Suggests:       libayatana-appindicator-gtk3
49 Suggests:       pulseaudio-bluetooth
50 Suggests:       pulseaudio-hal
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Blueman is a GTK+ bluetooth management utility for GNOME using bluez
55 dbus backend. The aim is to create a full featured graphical bluetooth
56 manager for Linux.
57
58 Features:
59
60 - Easy to use interface
61 - Storing Favourite devices
62 - Send files
63 - Browse files on devices
64 - List all seen devices
65 - View Local/Remote Device information
66 - View transfer speeds and link quality
67 - Configure local devices
68 - Manage Pairing (Bonding)
69 - Host/Connect to Personal Area Networks
70 - Bind services to /dev/rfcomm ports, for eg. connecting via gprs
71 - Connect and receive connections from: audio, network, input and
72   serial devices
73
74 %package caja
75 Summary:        Blueman plugin for Caja
76 Summary(pl.UTF-8):      Wtyczka Blueman-a dla managera plików Caja
77 Group:          X11/Applications
78 Requires:       %{name} = %{version}
79 Requires:       caja-python
80
81 %description caja
82 Blueman plugin for Caja.
83
84 %description caja -l pl.UTF-8
85 Wtyczka Blueman-a dla managera plików Caja.
86
87 %package nautilus
88 Summary:        Blueman plugin for Nautilus
89 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Nautilus-a
90 Group:          X11/Applications
91 Requires:       %{name} = %{version}
92 Requires:       nautilus-python
93
94 %description nautilus
95 Blueman plugin for Nautilus.
96
97 %description nautilus -l pl.UTF-8
98 Wtyczka Blueman-a dla Nautilus-a.
99
100 %package nemo
101 Summary:        Blueman plugin for Nemo
102 Summary(pl.UTF-8):      Wtyczka Blueman-a dla managera plików Nemo.
103 Group:          X11/Applications
104 Requires:       %{name} = %{version}
105 Requires:       cinnamon-nemo-python
106
107 %description nemo
108 Blueman plugin for Nautilus.
109
110 %description nemo -l pl.UTF-8
111 Wtyczka Blueman-a dla managera plików Nemo.
112
113 %package thunar
114 Summary:        Blueman plugin for Thunar
115 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Thunar-a
116 Group:          X11/Applications
117 Requires:       %{name} = %{version}
118
119 %description thunar
120 Blueman plugin for Thunar.
121
122 %description thunar -l pl.UTF-8
123 Wtyczka Blueman-a dla Thunar-a.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128
129 %build
130 %configure \
131         CYTHONEXEC=/usr/bin/cython3 \
132         NETWORKTOOLS=/sbin/ip \
133         --disable-runtime-deps-check \
134         --disable-schemas-compile \
135         --disable-static \
136         --enable-polkit \
137         %{__enable_disable mate caja-sendto} \
138         %{__enable_disable cinnamon nemo-sendto} \
139         %{__enable_disable gnome nautilus-sendto} \
140         %{__enable_disable xfce thunar-sendto} \
141         --enable-settings-integration
142
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
151 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/_blueman.la
152
153 # DO NOT RUN py_postclean - breaks plugins and everything
154
155 %find_lang %{name} --with-gnome
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post
161 %update_icon_cache hicolor
162 glib-compile-schemas %{_datadir}/glib-2.0/schemas
163 %service %{name}-mechanism restart
164 %systemd_post %{name}-mechanism.service
165 %systemd_user_post blueman-applet.service blueman-manager.service
166
167 %preun
168 if [ "$1" = "0" ]; then
169         %service -q %{name}-mechanism stop
170 fi
171 %systemd_preun %{name}-mechanism.service
172 %systemd_user_preun blueman-applet.service blueman-manager.service
173
174 %postun
175 %update_icon_cache hicolor
176 glib-compile-schemas %{_datadir}/glib-2.0/schemas
177 %systemd_reload
178
179 %files -f %{name}.lang
180 %defattr(644,root,root,755)
181 %doc README.md CHANGELOG.md COPYING FAQ
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
183 %attr(755,root,root) %{_bindir}/blueman-adapters
184 %attr(755,root,root) %{_bindir}/blueman-applet
185 %attr(755,root,root) %{_bindir}/blueman-manager
186 %attr(755,root,root) %{_bindir}/blueman-sendto
187 %attr(755,root,root) %{_bindir}/blueman-services
188 %attr(755,root,root) %{_bindir}/blueman-tray
189 %{_mandir}/man1/blueman-adapters.1*
190 %{_mandir}/man1/blueman-applet.1*
191 %{_mandir}/man1/blueman-manager.1*
192 %{_mandir}/man1/blueman-sendto.1*
193 %{_mandir}/man1/blueman-services.1*
194 %{_mandir}/man1/blueman-tray.1*
195 %attr(755,root,root) %{_libexecdir}/%{name}-mechanism
196 %attr(755,root,root) %{_libexecdir}/%{name}-rfcomm-watcher
197 %{_datadir}/%{name}
198 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
199 %{_desktopdir}/blueman-manager.desktop
200 %{_desktopdir}/blueman-adapters.desktop
201 %{_iconsdir}/hicolor/scalable/*/*.svg
202 %{_iconsdir}/hicolor/*/*/*.png
203 %{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
204 %{systemdunitdir}/blueman-mechanism.service
205 %{systemduserunitdir}/blueman-applet.service
206 %{systemduserunitdir}/blueman-manager.service
207 %{_datadir}/dbus-1/services/org.blueman.Applet.service
208 %{_datadir}/dbus-1/services/org.blueman.Manager.service
209 %{_datadir}/dbus-1/system.d/org.blueman.Mechanism.conf
210 %{_datadir}/polkit-1/actions/org.blueman.policy
211 %{_datadir}/polkit-1/rules.d/blueman.rules
212 %attr(755,root,root) %{py3_sitedir}/_blueman.so
213 %{py3_sitedir}/%{name}
214
215 %if %{with mate}
216 %files caja
217 %defattr(644,root,root,755)
218 %{_datadir}/caja-python/extensions/caja_blueman_sendto.py
219 %endif
220
221 %if %{with gnome}
222 %files nautilus
223 %defattr(644,root,root,755)
224 %{_datadir}/nautilus-python/extensions/nautilus_blueman_sendto.py
225 %endif
226
227 %if %{with cinnamon}
228 %files nemo
229 %defattr(644,root,root,755)
230 %{_datadir}/nemo-python/extensions/nemo_blueman_sendto.py
231 %endif
232
233 %if %{with xfce}
234 %files thunar
235 %defattr(644,root,root,755)
236 %{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
237 %endif
This page took 0.072539 seconds and 4 git commands to generate.