]> git.pld-linux.org Git - packages/blueman.git/blob - blueman.spec
patch to prefer maintained ayatana indicators; rel 2
[packages/blueman.git] / blueman.spec
1 # Conditional build:
2 %bcond_without  cinnamon        # build without nemo support
3 %bcond_without  gnome           # build without nautilus support
4 %bcond_without  mate            # build without caja support
5 %bcond_without  xfce            # build without Thunar support
6
7 Summary:        Blueman - bluetooth management utility for GNOME
8 Name:           blueman
9 Version:        2.2.3
10 Release:        2
11 License:        GPL v3+
12 Group:          X11/Applications
13 Source0:        https://github.com/blueman-project/blueman/releases/download/%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  ccdb860090a751312e841538606b4393
15 Patch0:         ayatana-indicator.patch
16 URL:            https://github.com/blueman-project/blueman
17 BuildRequires:  bluez-libs-devel >= 5.48
18 %{?with_mate:BuildRequires:     caja-python-devel}
19 %{?with_cinnamon:BuildRequires: cinnamon-nemo-python-devel}
20 BuildRequires:  gettext-tools >= 0.19.7
21 BuildRequires:  glib2-devel >= 1:2.32
22 BuildRequires:  libtool
23 %{?with_gnome:BuildRequires:    nautilus-python-devel}
24 BuildRequires:  pkgconfig >= 1:0.9.0
25 BuildRequires:  polkit-devel
26 BuildRequires:  python-pygobject3-common-devel >= 3.27.2
27 BuildRequires:  python3-Cython
28 BuildRequires:  python3-devel >= 1:3.6
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.644
31 BuildRequires:  systemd-units
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 Requires(post,postun):  gtk-update-icon-cache
35 Requires(post,postun):  hicolor-icon-theme
36 Requires(post,preun,postun):    systemd-units >= 38
37 Requires:       bluez >= 5.48
38 Requires:       dbus >= 1.9.18
39 Requires:       glib2 >= 1:2.32
40 Requires:       gtk+3 >= 3.22
41 Requires:       pango
42 Requires:       python3 >= %py3_ver
43 Requires:       python3-pycairo
44 Requires:       python3-pygobject3 >= 3.27.2
45 Suggests:       NetworkManager-libs
46 Suggests:       iproute2
47 Suggests:       libayatana-appindicator-gtk3
48 Suggests:       pulseaudio-bluetooth
49 Suggests:       pulseaudio-hal
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Blueman is a GTK+ bluetooth management utility for GNOME using bluez
54 dbus backend. The aim is to create a full featured graphical bluetooth
55 manager for Linux.
56
57 Features:
58
59 - Easy to use interface
60 - Storing Favourite devices
61 - Send files
62 - Browse files on devices
63 - List all seen devices
64 - View Local/Remote Device information
65 - View transfer speeds and link quality
66 - Configure local devices
67 - Manage Pairing (Bonding)
68 - Host/Connect to Personal Area Networks
69 - Bind services to /dev/rfcomm ports, for eg. connecting via gprs
70 - Connect and receive connections from: audio, network, input and
71   serial devices
72
73 %package caja
74 Summary:        Blueman plugin for Caja
75 Summary(pl.UTF-8):      Wtyczka Blueman-a dla managera plików Caja
76 Group:          X11/Applications
77 Requires:       %{name} = %{version}
78 Requires:       caja-python
79
80 %description caja
81 Blueman plugin for Caja.
82
83 %description caja -l pl.UTF-8
84 Wtyczka Blueman-a dla managera plików Caja.
85
86 %package nautilus
87 Summary:        Blueman plugin for Nautilus
88 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Nautilus-a
89 Group:          X11/Applications
90 Requires:       %{name} = %{version}
91 Requires:       nautilus-python
92
93 %description nautilus
94 Blueman plugin for Nautilus.
95
96 %description nautilus -l pl.UTF-8
97 Wtyczka Blueman-a dla Nautilus-a.
98
99 %package nemo
100 Summary:        Blueman plugin for Nemo
101 Summary(pl.UTF-8):      Wtyczka Blueman-a dla managera plików Nemo.
102 Group:          X11/Applications
103 Requires:       %{name} = %{version}
104 Requires:       cinnamon-nemo-python
105
106 %description nemo
107 Blueman plugin for Nautilus.
108
109 %description nemo -l pl.UTF-8
110 Wtyczka Blueman-a dla managera plików Nemo.
111
112 %package thunar
113 Summary:        Blueman plugin for Thunar
114 Summary(pl.UTF-8):      Wtyczka Blueman-a dla Thunar-a
115 Group:          X11/Applications
116 Requires:       %{name} = %{version}
117
118 %description thunar
119 Blueman plugin for Thunar.
120
121 %description thunar -l pl.UTF-8
122 Wtyczka Blueman-a dla Thunar-a.
123
124 %prep
125 %setup -q
126 %patch0 -p1
127
128 %build
129 %configure \
130         CYTHONEXEC=/usr/bin/cython3 \
131         NETWORKTOOLS=/sbin/ip \
132         --disable-runtime-deps-check \
133         --disable-schemas-compile \
134         --disable-static \
135         --enable-polkit \
136         %{__enable_disable mate caja-sendto} \
137         %{__enable_disable cinnamon nemo-sendto} \
138         %{__enable_disable gnome nautilus-sendto} \
139         %{__enable_disable xfce thunar-sendto} \
140         --enable-settings-integration
141
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT
148
149 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
150 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/_blueman.la
151
152 # DO NOT RUN py_postclean - breaks plugins and everything
153
154 %find_lang %{name} --with-gnome
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 %update_icon_cache hicolor
161 glib-compile-schemas %{_datadir}/glib-2.0/schemas
162 %service %{name}-mechanism restart
163 %systemd_post %{name}-mechanism.service
164
165 %preun
166 if [ "$1" = "0" ]; then
167         %service -q %{name}-mechanism stop
168 fi
169 %systemd_preun %{name}-mechanism.service
170
171 %postun
172 %update_icon_cache hicolor
173 glib-compile-schemas %{_datadir}/glib-2.0/schemas
174 %systemd_reload
175
176 %files -f %{name}.lang
177 %defattr(644,root,root,755)
178 %doc README.md CHANGELOG.md COPYING FAQ
179 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/autostart/blueman.desktop
180 %attr(755,root,root) %{_bindir}/blueman-adapters
181 %attr(755,root,root) %{_bindir}/blueman-applet
182 %attr(755,root,root) %{_bindir}/blueman-manager
183 %attr(755,root,root) %{_bindir}/blueman-sendto
184 %attr(755,root,root) %{_bindir}/blueman-services
185 %attr(755,root,root) %{_bindir}/blueman-tray
186 %{_mandir}/man1/blueman-adapters.1*
187 %{_mandir}/man1/blueman-applet.1*
188 %{_mandir}/man1/blueman-manager.1*
189 %{_mandir}/man1/blueman-sendto.1*
190 %{_mandir}/man1/blueman-services.1*
191 %{_mandir}/man1/blueman-tray.1*
192 %attr(755,root,root) %{_libexecdir}/%{name}-mechanism
193 %attr(755,root,root) %{_libexecdir}/%{name}-rfcomm-watcher
194 %{_datadir}/%{name}
195 %{_datadir}/dbus-1/system-services/org.blueman.Mechanism.service
196 %{_desktopdir}/blueman-manager.desktop
197 %{_desktopdir}/blueman-adapters.desktop
198 %{_iconsdir}/hicolor/scalable/*/*.svg
199 %{_iconsdir}/hicolor/*/*/*.png
200 %{_datadir}/glib-2.0/schemas/org.blueman.gschema.xml
201 %{systemdunitdir}/blueman-mechanism.service
202 %{systemduserunitdir}/blueman-applet.service
203 %{systemduserunitdir}/blueman-manager.service
204 %{_datadir}/dbus-1/services/org.blueman.Applet.service
205 %{_datadir}/dbus-1/services/org.blueman.Manager.service
206 %{_datadir}/dbus-1/system.d/org.blueman.Mechanism.conf
207 %{_datadir}/polkit-1/actions/org.blueman.policy
208 %{_datadir}/polkit-1/rules.d/blueman.rules
209 %attr(755,root,root) %{py3_sitedir}/_blueman.so
210 %{py3_sitedir}/%{name}
211
212 %if %{with mate}
213 %files caja
214 %defattr(644,root,root,755)
215 %{_datadir}/caja-python/extensions/caja_blueman_sendto.py
216 %endif
217
218 %if %{with gnome}
219 %files nautilus
220 %defattr(644,root,root,755)
221 %{_datadir}/nautilus-python/extensions/nautilus_blueman_sendto.py
222 %endif
223
224 %if %{with cinnamon}
225 %files nemo
226 %defattr(644,root,root,755)
227 %{_datadir}/nemo-python/extensions/nemo_blueman_sendto.py
228 %endif
229
230 %if %{with xfce}
231 %files thunar
232 %defattr(644,root,root,755)
233 %{_datadir}/Thunar/sendto/thunar-sendto-blueman.desktop
234 %endif
This page took 0.133371 seconds and 3 git commands to generate.