]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- enable openvdb (10.x is supported now); updated todo list
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - DRACO (requires WITH_PYTHON_INSTALL?)
4 # - OSL, Cycles
5 # - Alembic
6 # - USD
7 # - OpenImageDenoise
8 # - OpenSubdiv
9 # - OptiX >= 7.3.0
10 # - NanoVDB
11 #
12 # Conditional build:
13 %bcond_without  openvdb # OpenVDB support
14
15 Summary:        3D modeling, rendering, animation and game creation package
16 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
17 Name:           blender
18 Version:        3.3.10
19 Release:        1
20 License:        GPL v2+
21 Group:          X11/Applications/Graphics
22 Source0:        https://download.blender.org/source/%{name}-%{version}.tar.xz
23 # Source0-md5:  a190dbfc5dfd490d737ee64ba68ce79c
24 Patch0:         %{name}-2.76-droid.patch
25 Patch1:         format-security.patch
26 Patch3:         gcc13.patch
27 URL:            https://www.blender.org/
28 BuildRequires:  OpenAL-devel
29 BuildRequires:  OpenCOLLADA-devel
30 BuildRequires:  OpenColorIO-devel >= 2.0.0
31 BuildRequires:  OpenEXR-devel
32 BuildRequires:  OpenGL-devel
33 BuildRequires:  OpenGL-GLU-devel
34 BuildRequires:  OpenImageIO-devel
35 BuildRequires:  OpenXR-devel
36 BuildRequires:  SDL2-devel
37 BuildRequires:  boost-devel
38 BuildRequires:  cmake >= 3.10
39 BuildRequires:  embree-devel >= 3.8.0
40 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
41 BuildRequires:  fftw3-devel >= 3
42 BuildRequires:  freealut-devel
43 BuildRequires:  freetype-devel >= 2
44 BuildRequires:  ftgl-devel
45 BuildRequires:  gcc >= 5:3.4.0
46 BuildRequires:  gettext-tools
47 BuildRequires:  glew-devel
48 BuildRequires:  gmp-devel
49 BuildRequires:  jack-audio-connection-kit-devel
50 BuildRequires:  jemalloc-devel
51 BuildRequires:  libgomp-devel
52 BuildRequires:  libharu-devel
53 BuildRequires:  libjpeg-devel
54 BuildRequires:  libpng-devel
55 BuildRequires:  libsndfile-devel
56 BuildRequires:  libspnav-devel
57 BuildRequires:  libstdc++-devel
58 BuildRequires:  libtiff-devel
59 BuildRequires:  libvorbis-devel
60 BuildRequires:  libwebp-devel
61 BuildRequires:  libxml2-devel >= 2.0
62 BuildRequires:  openjpeg2-devel
63 %{?with_openvdb:BuildRequires:  openvdb-devel}
64 BuildRequires:  openssl-devel >= 0.9.7d
65 BuildRequires:  pcre-devel
66 BuildRequires:  potrace-devel
67 BuildRequires:  pugixml-devel
68 BuildRequires:  pulseaudio-devel
69 BuildRequires:  python3 >= 1:3.10
70 BuildRequires:  python3-devel >= 1:3.10
71 BuildRequires:  python3-numpy-devel
72 BuildRequires:  rpm-pythonprov
73 BuildRequires:  rpmbuild(macros) >= 1.605
74 BuildRequires:  sed >= 4.0
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  tbb-devel
77 BuildRequires:  xorg-lib-libX11-devel
78 BuildRequires:  xorg-lib-libXi-devel
79 BuildRequires:  xz
80 BuildRequires:  zlib-devel
81 BuildRequires:  zstd-devel
82 Requires(post,postun):  desktop-file-utils
83 Requires:       OpenGL
84 Requires:       freetype
85 Requires:       python3-modules >= 1:3.10
86 ExclusiveArch:  %{x8664}
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
90
91 %description
92 Blender is a free and fully functional 3D modeling, rendering,
93 animation and game creation package for Unix, Windows and BeOS
94 systems.
95
96 %description -l pl.UTF-8
97 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
98 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch3 -p1
105
106 # not executable
107 %{__sed} -i -e '/^#!\/usr\/bin\/env python/d' release/scripts/addons/sun_position/geo.py
108
109 # /usr/bin/env python3
110 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
111         release/scripts/addons/io_curve_svg/svg_util_test.py \
112         release/scripts/addons/io_scene_fbx/fbx2json.py \
113         release/scripts/addons/io_scene_fbx/json2fbx.py \
114         release/scripts/modules/bl_i18n_utils/merge_po.py \
115         release/scripts/modules/bl_i18n_utils/utils_rtl.py \
116         release/scripts/modules/blend_render_info.py
117
118 %build
119 install -d build
120 cd build
121 %cmake \
122         -DBOOST_ROOT=%{_prefix} \
123         -DBUILD_SHARED_LIBS:BOOL=OFF \
124         -DCMAKE_SKIP_RPATH:BOOL=ON \
125         -DPYTHON_VERSION:STRING=%{py3_ver} \
126         -DWITH_CODEC_FFMPEG:BOOL=ON \
127         -DWITH_CODEC_SNDFILE:BOOL=ON \
128         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
129         -DWITH_CYCLES:BOOL=ON \
130         -DWITH_FFTW3:BOOL=ON \
131         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
132         -DWITH_INPUT_NDOF:BOOL=ON \
133         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
134         -DWITH_JACK:BOOL=ON \
135         -DWITH_JACK_DYNLOAD:BOOL=ON \
136         -DWITH_MEM_JEMALLOC:BOOL=ON \
137         -DWITH_MOD_OCEANSIM:BOOL=ON \
138         -DWITH_OPENCOLLADA:BOOL=ON \
139         -DWITH_OPENCOLORIO:BOOL=ON \
140         %{!?with_openvdb:-DWITH_OPENVDB:BOOL=OFF} \
141         -DWITH_PYTHON:BOOL=ON \
142         -DWITH_PYTHON_INSTALL:BOOL=OFF \
143         -DWITH_PYTHON_SAFETY:BOOL=ON \
144         -DWITH_SDL:BOOL=ON \
145         -DWITH_SDL_DYNLOAD:BOOL=ON \
146         -DWITH_SYSTEM_GLEW:BOOL=ON \
147         ..
148
149 %{__make} V=1
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
154
155 %{__make} -C build install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 ./doc/manpage/blender.1.py \
159         --blender $RPM_BUILD_ROOT%{_bindir}/blender \
160         --output $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
161
162 #%find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 %update_desktop_database_post
169
170 %postun
171 %update_desktop_database_postun
172
173 %files
174 %defattr(644,root,root,755)
175 # -f %{name}.lang
176 %doc doc/license/bf-members.txt doc/guides/*.txt
177 %attr(755,root,root) %{_bindir}/blender
178 %attr(755,root,root) %{_bindir}/blender-thumbnailer
179 %attr(755,root,root) %{_datadir}/%{name}
180 %{_desktopdir}/blender.desktop
181 %{_iconsdir}/hicolor/scalable/apps/blender.svg
182 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
183 %{_mandir}/man1/blender.1*
This page took 0.110076 seconds and 4 git commands to generate.