]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
- release 1
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - enable OpenAL support
4 # - libsolid/libqhull/libode BR ?
5 # - package python scripts
6 Summary:        3D modeling, rendering, animation and game creation package
7 Summary(pl):    Pakiet do tworzenia animacji 3D oraz gier
8 Name:           blender
9 Version:        2.42a
10 Release:        1
11 License:        GPL
12 Group:          X11/Applications/Graphics
13 Source0:        http://download.blender.org/source/%{name}-%{version}.tar.gz
14 # Source0-md5:  3d60b7ebe0dea47da12744fe2462d96c
15 Source1:        %{name}.desktop
16 Source2:        %{name}.png
17 Source4:        %{name}-wrapper
18 Source5:        %{name}.manpage
19 Patch0:         %{name}-po_and_locale_names.patch
20 Patch1:         %{name}-noxml-yafray.patch
21 Patch2:         %{name}-python-fix.patch
22 Patch3:         %{name}-cast.patch
23 URL:            http://www.blender.org/
24 BuildRequires:  OpenEXR-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL-devel
27 BuildRequires:  freealut-devel
28 BuildRequires:  freetype-devel
29 BuildRequires:  ftgl-devel
30 BuildRequires:  gettext-devel
31 #BuildRequires: esound-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtiff-devel
36 BuildRequires:  libtool
37 BuildRequires:  libvorbis-devel
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  python-devel >= 1:2.3
40 BuildRequires:  scons
41 BuildRequires:  sed >= 4.0
42 #BuildRequires: smpeg-devel
43 BuildRequires:  zlib-devel
44 Requires:       OpenGL
45 Requires:       freetype
46 Requires:       python-modules
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
50
51 %description
52 Blender is a free and fully functional 3D modeling, rendering,
53 animation and game creation package for Unix, Windows and BeOS
54 systems.
55
56 %description -l pl
57 Blender to darmowy i w pe³ni funkcjonalny pakiet do tworzenia animacji
58 3D oraz gier, dostêpny dla systemów Unix, Windows i BeOS.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 %patch3 -p1
66 mv -f po/pt_{br,BR}.po
67
68 rm -f missing
69 rm -f user-config.py
70
71 RPMCFLAGS="\"`echo %{rpmcflags}|sed 's/ /\",\"/g'`\""
72 RPMLDFLAGS="\"`echo %{rpmldflags}|sed 's/ /\",\"/g'`\""
73
74 cat > user-config.py <<END
75 CCFLAGS           = [$RPMCFLAGS]
76 CXXFLAGS          = [$RPMCFLAGS]
77 LDFLAGS           = [$RPMLDFLAGS]
78 TARGET_CC         = '%{__cc}'
79 TARGET_CXX        = '%{__cxx}'
80
81 BF_PYTHON_VERSION = '%{py_ver}'
82
83 LCGDIR            = 'lib/linux2'
84 BF_BUILDDIR       = 'build/linux2'
85 BF_INSTALLDIR     = 'install/linux2'
86 END
87
88 %build
89 scons
90 %{__make} -C po OCGDIR=..
91
92 install -d release/plugins/include
93 install source/blender/blenpluginapi/*.h release/plugins/include
94 chmod +x release/plugins/bmake
95 %{__make} -C release/plugins/
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_datadir},%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
100         $RPM_BUILD_ROOT%{_datadir}/blender/bpydata
101
102 install ./install/linux2/blender $RPM_BUILD_ROOT%{_bindir}/blender-bin
103 install %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/blender
104 #install blenderplayer $RPM_BUILD_ROOT%{_bindir}
105 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
106 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
107 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
108 install -d $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
109 install ./release/plugins/sequence/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/sequence
110 install ./release/plugins/texture/*.so $RPM_BUILD_ROOT%{_libdir}/blender/plugins/texture
111 install -d $RPM_BUILD_ROOT%{_datadir}/blender
112 cp -aR ./release/scripts $RPM_BUILD_ROOT%{_datadir}/blender
113 install ./release/VERSION $RPM_BUILD_ROOT%{_datadir}/blender
114 install ./bin/.blender/.Blanguages $RPM_BUILD_ROOT%{_datadir}/blender
115 install ./bin/.blender/.bfont.ttf $RPM_BUILD_ROOT%{_datadir}/blender
116 cp -a bin/.blender/locale $RPM_BUILD_ROOT%{_datadir}/blender
117 install -d $RPM_BUILD_ROOT%{_mandir}/man1
118 install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc README doc/bf-members.txt doc/python-dev-guide.txt doc/oldbugs.txt doc/interface_API.txt
126 %doc release/text/{blender.html,release*.txt}
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_datadir}/%{name}
129 %attr(755,root,root) %{_libdir}/%{name}
130 %{_desktopdir}/*.desktop
131 %{_pixmapsdir}/*.png
132 %{_mandir}/man1/*
This page took 0.053347 seconds and 3 git commands to generate.