]> git.pld-linux.org Git - packages/blackbox.git/blob - blackbox.spec
- fix build
[packages/blackbox.git] / blackbox.spec
1 #
2 # TODO: review/update patches
3 #
4 # Conditional build:
5 %bcond_with     epistrophy      # enables using epistorophy key grabber
6 %bcond_with     gnome2          # build with support for GNOME2 wm-properties
7 #
8 Summary:        Very small and fast window manger for the X Window
9 Summary(pl.UTF-8):      Mały i szybki zarządca okien dla X Window
10 Summary(de.UTF-8):      Blackbox ist ein Windowmanager
11 Name:           blackbox
12 Version:        0.70.1
13 Release:        3.1
14 License:        BSD-like
15 Group:          X11/Window Managers
16 Source0:        http://dl.sourceforge.net/blackboxwm/%{name}-%{version}.tar.gz
17 # Source0-md5:  2d173b95ca5e64ef478c6a5d2deee9df
18 Source1:        %{name}.desktop
19 Source3:        %{name}.1
20 Source4:        bsetroot.1
21 Source5:        %{name}-README.PLD
22 Source6:        %{name}-xsession.desktop
23 Patch0:         %{name}-am_fixes.patch
24 Patch1:         %{name}-pipe.patch
25 Patch3:         %{name}-epistrophy.patch
26 Patch4:         %{name}-etc_dir.patch
27 Patch5:         %{name}-nls-codesets.patch
28 Patch6:         %{name}-assert.patch
29 Patch7:         %{name}-lib64.patch
30 Patch8:         %{name}-headers.patch
31 URL:            http://blackboxwm.sourceforge.net/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 %{?with_epistrophy:Requires:    epistrophy}
35 BuildRequires:  rpm >= 4.0.2-48
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  xorg-lib-libX11-devel
38 BuildRequires:  xorg-lib-libXft-devel
39 Obsoletes:      fluxbox
40 Conflicts:      filesystem < 3.0-20
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _sysconfdir     /etc/X11/%{name}
44 %define         _wmpropsdir     /usr/share/gnome/wm-properties
45
46 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
47 %if %{_gcc_ver} == 2
48 %define         __cxx           "%{__cc}"
49 %endif
50
51 %description
52 Blackbox is a window manager for the X Window environment, which is
53 almost completely compliant with ICCCM specified operation policies.
54 It features nice and fast interface with multiple workspaces and
55 simple menus. Fast built-in graphics code that can render solids,
56 gradients and bevels is used to draw window decorations. Remaining
57 small in size, blackbox preserves memory and CPU.
58
59 %description -l pl.UTF-8
60 Blackbox jest zarządcą okien dla X Window spełniającym prawie
61 wszystkie zalecenia ICCM. Jego zaletą jest estetyczny i szybki
62 interfejs z wieloma pulpitami i prostym menu. Wbudowano weń także
63 algorytm rysowania dekoracji okien, które mogą być jednokolorowe,
64 gradientowe lub trójwymiarowe. Blackbox oszczędza pamięć i czas CPU.
65
66 %description -l de.UTF-8
67 Blackbox ist ein Windowmanager für offene Betriebssystem wie z.B.
68 Linux oder freie BSD-Varianten. Er erfreut sich einer großen
69 Fangemeinde, da er sehr ressourcenschonend und voll konfigurierbar
70 ist.
71
72 %prep
73 %setup -q
74 #%patch0 -p1
75 #%patch1 -p1
76 %{?with_epistrophy:%patch3 -p1}
77 #%patch4 -p1
78 #%patch5 -p1
79 #%patch6 -p1
80 %if "%{_lib}" == "lib64"
81 %patch7 -p0
82 %endif
83 %patch8 -p1
84
85 %{__sed} -i 's,_XUTIL_H_,_X11&,' lib/Util.hh
86
87 %build
88 rm -f missing
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93 %configure
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d \
99         $RPM_BUILD_ROOT{%{_wmpropsdir},%{_mandir}/pl/man1,%{_sysconfdir}} \
100         $RPM_BUILD_ROOT%{_datadir}/xsessions
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{?with_gnome2:install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}}
106 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
107 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/pl/man1
108 cp %{SOURCE5} README.PLD
109 install %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS README* ChangeLog LICENSE TODO
117 %attr(755,root,root) %{_bindir}/*
118 %dir %{_sysconfdir}
119 %dir %{_datadir}/blackbox
120 %{_datadir}/blackbox/styles
121 %{_datadir}/xsessions/%{name}.desktop
122 %{?with_gnome2:%{_wmpropsdir}/blackbox.desktop}
123 %{_mandir}/man1/*
124 %lang(pl) %{_mandir}/pl/man1/*
125 %{_datadir}/blackbox/menu
This page took 0.050051 seconds and 3 git commands to generate.