]> git.pld-linux.org Git - packages/blackbox.git/blame - blackbox.spec
- fix build
[packages/blackbox.git] / blackbox.spec
CommitLineData
26294186 1#
39488c48 2# TODO: review/update patches
3#
26294186 4# Conditional build:
646073cd 5%bcond_with epistrophy # enables using epistorophy key grabber
19448645 6%bcond_with gnome2 # build with support for GNOME2 wm-properties
26294186 7#
e3ab4b11 8Summary: Very small and fast window manger for the X Window
06cfb4f9
ER
9Summary(pl.UTF-8): Mały i szybki zarządca okien dla X Window
10Summary(de.UTF-8): Blackbox ist ein Windowmanager
c636f561 11Name: blackbox
39488c48 12Version: 0.70.1
ccc4181b 13Release: 3.1
26294186 14License: BSD-like
c636f561 15Group: X11/Window Managers
f9dd7778 16Source0: http://dl.sourceforge.net/blackboxwm/%{name}-%{version}.tar.gz
39488c48 17# Source0-md5: 2d173b95ca5e64ef478c6a5d2deee9df
76da209e 18Source1: %{name}.desktop
bdb11c69 19Source3: %{name}.1
20Source4: bsetroot.1
57ddee75 21Source5: %{name}-README.PLD
d03b1cd4 22Source6: %{name}-xsession.desktop
b0597b68 23Patch0: %{name}-am_fixes.patch
4b489e6f 24Patch1: %{name}-pipe.patch
8bb824c5 25Patch3: %{name}-epistrophy.patch
5731932c 26Patch4: %{name}-etc_dir.patch
26294186
JB
27Patch5: %{name}-nls-codesets.patch
28Patch6: %{name}-assert.patch
d224a78c 29Patch7: %{name}-lib64.patch
eb324947 30Patch8: %{name}-headers.patch
2250cf3c 31URL: http://blackboxwm.sourceforge.net/
41cb92eb 32BuildRequires: autoconf
33BuildRequires: automake
646073cd 34%{?with_epistrophy:Requires: epistrophy}
5e83988c 35BuildRequires: rpm >= 4.0.2-48
eb324947 36BuildRequires: sed >= 4.0
5e83988c 37BuildRequires: xorg-lib-libX11-devel
38BuildRequires: xorg-lib-libXft-devel
dbbba856 39Obsoletes: fluxbox
a4fa63a9 40Conflicts: filesystem < 3.0-20
a0119d34 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
eec1e3c5 42
13f3130c 43%define _sysconfdir /etc/X11/%{name}
a4fa63a9 44%define _wmpropsdir /usr/share/gnome/wm-properties
950c8bca 45
f2b93712 46%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
53ed1b7f 47%if %{_gcc_ver} == 2
0f3df1f5 48%define __cxx "%{__cc}"
49%endif
fe6df007 50
eec1e3c5 51%description
587c8800 52Blackbox is a window manager for the X Window environment, which is
53almost completely compliant with ICCCM specified operation policies.
54It features nice and fast interface with multiple workspaces and
55simple menus. Fast built-in graphics code that can render solids,
56gradients and bevels is used to draw window decorations. Remaining
57small in size, blackbox preserves memory and CPU.
eec1e3c5 58
5fcca84d
JR
59%description -l pl.UTF-8
60Blackbox jest zarządcą okien dla X Window spełniającym prawie
61wszystkie zalecenia ICCM. Jego zaletą jest estetyczny i szybki
62interfejs z wieloma pulpitami i prostym menu. Wbudowano weń także
63algorytm rysowania dekoracji okien, które mogą być jednokolorowe,
64gradientowe lub trójwymiarowe. Blackbox oszczędza pamięć i czas CPU.
eec1e3c5 65
5fcca84d
JR
66%description -l de.UTF-8
67Blackbox ist ein Windowmanager für offene Betriebssystem wie z.B.
68Linux oder freie BSD-Varianten. Er erfreut sich einer großen
a4c6b696 69Fangemeinde, da er sehr ressourcenschonend und voll konfigurierbar
70ist.
71
eec1e3c5 72%prep
455acc11 73%setup -q
b88995d7 74#%patch0 -p1
75#%patch1 -p1
646073cd 76%{?with_epistrophy:%patch3 -p1}
b88995d7 77#%patch4 -p1
78#%patch5 -p1
79#%patch6 -p1
ccc4181b 80%if "%{_lib}" == "lib64"
39488c48 81%patch7 -p0
82%endif
eb324947 83%patch8 -p1
84
85%{__sed} -i 's,_XUTIL_H_,_X11&,' lib/Util.hh
eec1e3c5 86
87%build
dd279a53 88rm -f missing
5e83988c 89%{__libtoolize}
dd279a53 90%{__aclocal}
8cfbfe17 91%{__autoconf}
92%{__automake}
e3ab4b11 93%configure
fe6df007 94%{__make}
eec1e3c5 95
eec1e3c5 96%install
97rm -rf $RPM_BUILD_ROOT
d03b1cd4 98install -d \
99 $RPM_BUILD_ROOT{%{_wmpropsdir},%{_mandir}/pl/man1,%{_sysconfdir}} \
100 $RPM_BUILD_ROOT%{_datadir}/xsessions
e3ab4b11 101
8783bb35
PG
102%{__make} install \
103 DESTDIR=$RPM_BUILD_ROOT
e3ab4b11 104
19448645 105%{?with_gnome2:install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}}
bdb11c69 106install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
107install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/pl/man1
57ddee75 108cp %{SOURCE5} README.PLD
d03b1cd4 109install %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
57ddee75 110
a04a05ef 111%clean
112rm -rf $RPM_BUILD_ROOT
113
eec1e3c5 114%files
b62d2e08 115%defattr(644,root,root,755)
26294186 116%doc AUTHORS README* ChangeLog LICENSE TODO
c717dcb3 117%attr(755,root,root) %{_bindir}/*
13f3130c 118%dir %{_sysconfdir}
76da209e 119%dir %{_datadir}/blackbox
ea4de25b 120%{_datadir}/blackbox/styles
d03b1cd4 121%{_datadir}/xsessions/%{name}.desktop
19448645 122%{?with_gnome2:%{_wmpropsdir}/blackbox.desktop}
b0597b68 123%{_mandir}/man1/*
6afa71cb 124%lang(pl) %{_mandir}/pl/man1/*
b88995d7 125%{_datadir}/blackbox/menu
This page took 0.112551 seconds and 4 git commands to generate.