]> git.pld-linux.org Git - packages/bitbake.git/blob - bitbake.spec
- updated to 1.8.8
[packages/bitbake.git] / bitbake.spec
1 Summary:        BitBake build tool
2 Summary(pl.UTF-8):      BitBake - narzędzie do budowania
3 Name:           bitbake
4 Version:        1.8.8
5 Release:        1
6 License:        GPL
7 Group:          Development
8 Source0:        http://download.berlios.de/bitbake/%{name}-%{version}.tar.gz
9 # Source0-md5:  58d92e3507af3e8b02cfddf8ee5f5a09
10 URL:            http://developer.berlios.de/projects/bitbake/
11 BuildRequires:  python-devel >= 1:2.5
12 BuildRequires:  sed >= 4.0
13 %pyrequires_eq  python
14 Requires:       bash
15 Requires:       python-modules
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 BitBake is a simple tool for the execution of tasks. It is derived
21 from Portage, which is the package management system used by the
22 Gentoo Linux distribution. It is most commonly used to build packages,
23 as it can easily use its rudimentary inheritance to abstract common
24 operations, such as fetching sources, unpacking them, patching them,
25 compiling them, and so on. It is the basis of the OpenEmbedded
26 project, which is being used for OpenZaurus, Familiar, and a number of
27 other Linux distributions.
28
29 %description -l pl.UTF-8
30 BitBake to proste narzędzie do wykonywania zadań. Wywodzi się z
31 Portage, które jest systemem zarządzania pakietami używanym w
32 dystrybucji Linuksa Gentoo. Najczęściej jest używane do budowania
33 pakietów, jako że może łatwo używać swojej elementarnej dziedziczności
34 do abstrahowania wspólnych operacji, takich jak pobieranie źródeł,
35 rozpakowywanie ich, łatanie, kompilowanie i tak dalej. Jest podstawą
36 projektu OpenEmbedded, używanego przez projekty OpenZaurus, Familiar i
37 wiele innych dystrybucji Linuksa.
38
39 %prep
40 %setup -q
41 sed -i  -e 's@#!/bin/sh[[:space:]]@#!/bin/bash @'       \
42         -e 's@%s%ssh[[:space:]]@%s%sbash @'     lib/bb/build.py
43
44 %build
45 python setup.py build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_sysconfdir}
50
51 python setup.py install \
52         --prefix=%{_prefix} \
53         --root=$RPM_BUILD_ROOT
54
55 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
56 ln -s %{_sysconfdir}/%{name} $RPM_BUILD_ROOT%{_datadir}/%{name}/conf
57
58 %clean
59 rm -rf ${RPM_BUILD_ROOT}
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_bindir}/*
64 %{_sysconfdir}/%{name}
65 %{_datadir}/%{name}
66 %dir %{py_sitescriptdir}/bb
67 %{py_sitescriptdir}/bb/*py[co]
68 %dir %{py_sitescriptdir}/bb/fetch
69 %{py_sitescriptdir}/bb/fetch/*py[co]
70 %dir %{py_sitescriptdir}/bb/parse
71 %{py_sitescriptdir}/bb/parse/*py[co]
72 %dir %{py_sitescriptdir}/bb/parse/parse_py
73 %{py_sitescriptdir}/bb/parse/parse_py/*py[co]
This page took 0.050968 seconds and 3 git commands to generate.