]> git.pld-linux.org Git - packages/bitbake.git/blob - bitbake.spec
- release 2
[packages/bitbake.git] / bitbake.spec
1 Summary:        BitBake build tool
2 Summary(pl.UTF-8):      BitBake - narzędzie do budowania
3 Name:           bitbake
4 Version:        1.8.18
5 Release:        2
6 License:        GPL
7 Group:          Development
8 Source0:        http://download.berlios.de/bitbake/%{name}-%{version}.tar.gz
9 # Source0-md5:  f772ca3121103ab3500c7f1609a96271
10 URL:            http://developer.berlios.de/projects/bitbake/
11 BuildRequires:  python-devel >= 1:2.5
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  sed >= 4.0
14 %pyrequires_eq  python
15 Requires:       bash
16 Requires:       python-modules
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 BitBake is a simple tool for the execution of tasks. It is derived
22 from Portage, which is the package management system used by the
23 Gentoo Linux distribution. It is most commonly used to build packages,
24 as it can easily use its rudimentary inheritance to abstract common
25 operations, such as fetching sources, unpacking them, patching them,
26 compiling them, and so on. It is the basis of the OpenEmbedded
27 project, which is being used for OpenZaurus, Familiar, and a number of
28 other Linux distributions.
29
30 %description -l pl.UTF-8
31 BitBake to proste narzędzie do wykonywania zadań. Wywodzi się z
32 Portage, które jest systemem zarządzania pakietami używanym w
33 dystrybucji Linuksa Gentoo. Najczęściej jest używane do budowania
34 pakietów, jako że może łatwo używać swojej elementarnej dziedziczności
35 do abstrahowania wspólnych operacji, takich jak pobieranie źródeł,
36 rozpakowywanie ich, łatanie, kompilowanie i tak dalej. Jest podstawą
37 projektu OpenEmbedded, używanego przez projekty OpenZaurus, Familiar i
38 wiele innych dystrybucji Linuksa.
39
40 %prep
41 %setup -q
42 sed -i  -e 's@#!/bin/sh[[:space:]]@#!/bin/bash @'       \
43         -e 's@%s%ssh[[:space:]]@%s%sbash @'     lib/bb/build.py
44
45 %build
46 python setup.py build
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_sysconfdir}
51
52 python setup.py install \
53         --prefix=%{_prefix} \
54         --root=$RPM_BUILD_ROOT
55
56 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
57 ln -s %{_sysconfdir}/%{name} $RPM_BUILD_ROOT%{_datadir}/%{name}/conf
58
59 %clean
60 rm -rf ${RPM_BUILD_ROOT}
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/*
65 %{_sysconfdir}/%{name}
66 %{_datadir}/%{name}
67 %dir %{py_sitescriptdir}/bb
68 %{py_sitescriptdir}/bb/*py[co]
69 %dir %{py_sitescriptdir}/bb/fetch
70 %{py_sitescriptdir}/bb/fetch/*py[co]
71 %dir %{py_sitescriptdir}/bb/parse
72 %{py_sitescriptdir}/bb/parse/*py[co]
73 %dir %{py_sitescriptdir}/bb/parse/parse_py
74 %{py_sitescriptdir}/bb/parse/parse_py/*py[co]
This page took 0.187386 seconds and 3 git commands to generate.