]> git.pld-linux.org Git - packages/bicyclerepair.git/blob - bicyclerepair.spec
- klasyka..
[packages/bicyclerepair.git] / bicyclerepair.spec
1
2 #
3 # todo:
4 # - emacs, idle and vim subpackages
5 #
6
7 # Conditional build:
8 %bcond_without tests    # disables testing
9 #
10 %include        /usr/lib/rpm/macros.python
11 Summary:        Python Refactoring Browser
12 Name:           bicyclerepair
13 Version:        0.9
14 %define beta    BETA4
15 Release:        0.%{beta}.1
16 License:        unknown
17 Group:          Development/Languages/Python
18 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}-%{beta}.tar.gz
19 # Source0-md5:  635287697aa7f3bb580267e9df203f89
20 URL:            http://bicyclerepair.sourceforge.net/
21 BuildRequires:  python-modules >= 2.2.1
22 BuildRequires:  rpm-pythonprov
23 %pyrequires_eq  python-modules
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Bicycle Repair Man is the Python Refactoring Browser, helping
29 Pythonistas everywhere glide over the gory details of refactoring
30 their code. Watch him extract jumbled code into well ordered classes.
31 Gasp, as he renames all occurrences of a method. Thank You, Bicycle
32 Repair Man!
33
34 %description -l pl
35 Bicycle Repair Man ("Mechanik Rowerowy") to przegl±darka
36 przebudowuj±ca dla Pythona, pomagaj±ca pythonistom wszêdzie szybowaæ
37 ponad morderczymi szczegó³ami przebudowywania swojego kodu. Patrz, jak
38 przemienia pomieszany kod na dobrze uporz±dkowane klasy. Oddychaj
39 ciê¿ko, kiedy zmienia wszystkie wyst±pienia metody. Dziêkujemy Ci,
40 Mechaniku Rowerowy!
41
42 %prep
43 %setup -q -n %{name}-%{version}-%{beta}
44
45 %build
46 python setup.py build
47
48 %{?with_tests:python -O testall.py -v}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 python setup.py install \
54         --optimize=2 \
55         --root=$RPM_BUILD_ROOT
56
57 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.py -exec rm -f {} \;
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS COPYING ChangeLog DESIGN NEWS README*
65 %doc ide-integration/bike.vim
66 #%attr(755,root,root) %{_bindir}/*
67 %{py_sitedir}/*
This page took 0.054134 seconds and 3 git commands to generate.