]> git.pld-linux.org Git - packages/bicyclerepair.git/blob - bicyclerepair.spec
BR: rpmbuild(macros) >= 1.710
[packages/bicyclerepair.git] / bicyclerepair.spec
1
2 #
3 # todo:
4 # - emacs, idle and vim subpackages
5 #
6
7 # Conditional build:
8 %bcond_without  tests   # disables testing
9 #
10 Summary:        Python Refactoring Browser
11 Summary(pl.UTF-8):      Przeglądarka do refaktoryzacji kodu w Pythonie
12 Name:           bicyclerepair
13 Version:        0.9
14 Release:        1
15 License:        BSD-like
16 Group:          Development/Languages/Python
17 Source0:        http://dl.sourceforge.net/bicyclerepair/%{name}-%{version}.tar.gz
18 # Source0-md5:  f825f48384febefacf0717738e909321
19 URL:            http://bicyclerepair.sourceforge.net/
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 BuildRequires:  python-modules >= 2.2.1
22 %pyrequires_eq  python-modules
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Bicycle Repair Man is the Python Refactoring Browser, helping
28 Pythonistas everywhere glide over the gory details of refactoring
29 their code. Watch him extract jumbled code into well ordered classes.
30 Gasp, as he renames all occurrences of a method. Thank You, Bicycle
31 Repair Man!
32
33 %description -l pl.UTF-8
34 Bicycle Repair Man ("Mechanik Rowerowy") to narzędzie do refaktoryzacji
35 kodu źródłowego napisanego w języku Python, pozwalające programistom na
36 uniknięcie morderczej pracy związanej z ulepszaniem swojego kodu. 
37
38 Patrz, jak brzydki kod przekształca się w piękne klasy. Tchu zabraknie Ci
39 ze zdziwienia, gdy zacznie zmieniać wszystkie wystąpienia metody.
40 Dziękujemy Ci, Mechaniku Rowerowy!
41
42 %prep
43 %setup -q
44
45 %build
46 %py_build
47
48 %{?with_tests:python -O testall.py -v}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %py_install
54
55 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm -f {} \;
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS COPYING ChangeLog NEWS README*
63 %doc ide-integration/bike.vim
64 %{py_sitescriptdir}/*
This page took 0.085208 seconds and 4 git commands to generate.