]> git.pld-linux.org Git - packages/bicyclerepair.git/blob - bicyclerepair.spec
- bcond_with(out) is followed by one \t, then bcond's name.
[packages/bicyclerepair.git] / bicyclerepair.spec
1
2 #
3 # todo:
4 # - emacs, idle and vim subpackages
5 #
6
7 # Conditional build:
8 %bcond_without  tests   # disables testing
9 #
10 Summary:        Python Refactoring Browser
11 Summary(pl):    Przegl±darka do refaktoryzacji kodu w Pythonie
12 Name:           bicyclerepair
13 Version:        0.9
14 Release:        1
15 License:        BSD-like
16 Group:          Development/Languages/Python
17 Source0:        http://dl.sourceforge.net/bicyclerepair/%{name}-%{version}.tar.gz
18 # Source0-md5:  f825f48384febefacf0717738e909321
19 URL:            http://bicyclerepair.sourceforge.net/
20 BuildRequires:  python-modules >= 2.2.1
21 %pyrequires_eq  python-modules
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Bicycle Repair Man is the Python Refactoring Browser, helping
27 Pythonistas everywhere glide over the gory details of refactoring
28 their code. Watch him extract jumbled code into well ordered classes.
29 Gasp, as he renames all occurrences of a method. Thank You, Bicycle
30 Repair Man!
31
32 %description -l pl
33 Bicycle Repair Man ("Mechanik Rowerowy") to narzêdzie do refaktoryzacji
34 kodu ¼ród³owego napisanego w jêzyku Python, pozwalaj±ce programistom na
35 unikniêcie morderczej pracy zwi±zanej z ulepszaniem swojego kodu. 
36
37 Patrz, jak brzydki kod przekszta³ca siê w piêkne klasy. Tchu zabraknie Ci
38 ze zdziwienia, gdy zacznie zmieniaæ wszystkie wyst±pienia metody.
39 Dziêkujemy Ci, Mechaniku Rowerowy!
40
41 %prep
42 %setup -q
43
44 %build
45 python setup.py build
46
47 %{?with_tests:python -O testall.py -v}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 python setup.py install \
53         --optimize=2 \
54         --root=$RPM_BUILD_ROOT
55
56 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm -f {} \;
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS COPYING ChangeLog NEWS README*
64 %doc ide-integration/bike.vim
65 %{py_sitescriptdir}/*
This page took 0.060573 seconds and 3 git commands to generate.