]> git.pld-linux.org Git - packages/belle-sip.git/blob - belle-sip.spec
- release 3 (by relup.sh)
[packages/belle-sip.git] / belle-sip.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_with     tests           # enable tests
5 #
6 Summary:        SIP (RFC3261) object-oriented implementation in C
7 Summary(pl.UTF-8):      Implementacja SIP (RFC3261) w C
8 Name:           belle-sip
9 Version:        1.3.0
10 Release:        3
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
14 # Source0-md5:  ae9e8be12f62552a5376edd66b0265d9
15 Patch0:         antlr_jar.patch
16 Patch1:         use_after_free.patch
17 URL:            http://www.linphone.org/
18 %{?with_tests:BuildRequires:    CUnit >= 2.0}
19 BuildRequires:  autoconf >= 2.63
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  java-antlr3 >= 3.2
22 BuildRequires:  jre
23 BuildRequires:  libantlr3c-devel >= 3.2
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  polarssl-devel >= 1.2
27 BuildRequires:  pkgconfig
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Belle-sip is a SIP (RFC3261) implementation written in C, with an
32 object oriented API.
33
34 %description -l pl.UTF-8
35 Belle-sip to implementacja SIP (RFC3261) napisana w C z API
36 zorientowanym obiektowo.
37
38 %package devel
39 Summary:        Header files for %{name} library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{name} library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki %{name}.
49
50 %package static
51 Summary:        Static %{name} library
52 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static %{name} library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka %{name}.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66
67 %build
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 %configure \
74         CFLAGS="%{rpmcflags} -Wno-error=pragmas" \
75         --disable-silent-rules \
76         %{!?with_static_libs:--disable-static}
77
78 %{__make}
79
80 %{?with_tests:%{__make} test}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbellesip.la
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS NEWS README
99 %attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libbellesip.so
105 %{_includedir}/%{name}
106 %{_pkgconfigdir}/%{name}.pc
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libbellesip.a
112 %endif
This page took 0.096088 seconds and 3 git commands to generate.