]> git.pld-linux.org Git - packages/belle-sip.git/blob - belle-sip.spec
new package
[packages/belle-sip.git] / belle-sip.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_with     tests           # enable tests
5 #
6 Summary:        SIP (RFC3261) object-oriented implementation in C
7 Summary(pl.UTF-8):      Implementacja SIP (RFC3261) w C
8 Name:           belle-sip
9 Version:        1.3.0
10 Release:        0.1
11 License:        GPL v2
12 Group:          Libraries
13 Source0:        http://download-mirror.savannah.gnu.org/releases/linphone/belle-sip/%{name}-%{version}.tar.gz
14 # Source0-md5:  ae9e8be12f62552a5376edd66b0265d9
15 Patch0:         antlr_jar.patch
16 URL:            http://www.linphone.org/
17 %{?with_tests:BuildRequires:    CUnit >= 2.0}
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  java
21 BuildRequires:  java-antlr3 >= 3.2
22 BuildRequires:  libantlr3c-devel >= 3.2
23 BuildRequires:  libtool
24 BuildRequires:  polarssl-devel >= 1.2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Belle-sip is a SIP (RFC3261) implementation written in C, with an
29 object oriente d API.
30
31 %package devel
32 Summary:        Header files for %{name} library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for %{name} library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki %{name}.
42
43 %package static
44 Summary:        Static %{name} library
45 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static %{name} library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka %{name}.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         CFLAGS="%{rpmcflags} -Wno-error=pragmas" \
67         %{!?with_static_libs:--disable-static}
68
69 %{__make} V=1
70
71 %{?with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install V=1 \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 rm $RPM_BUILD_ROOT%{_libdir}/libbellesip.la
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS NEWS README
90 %attr(755,root,root) %{_libdir}/libbellesip.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libbellesip.so.0
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libbellesip.so
96 %{_includedir}/%{name}
97 %{_pkgconfigdir}/%{name}.pc
98
99 %if %{with static_libs}
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/libbellesip.a
103 %endif
This page took 0.118283 seconds and 3 git commands to generate.