]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- 0.16.12, added errno patch
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl):    Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.12
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
9 # Source0-md5:  623480d77b685b1e7c762df04ad5e154
10 Patch0:         Dev86src-noroot.patch
11 Patch1:         Dev86src-nobcc.patch
12 Patch2:         Dev86src-opt.patch
13 Patch3:         Dev86src-errno.patch
14 URL:            http://www.cix.co.uk/~mayday/
15 Requires:       bin86
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 ExclusiveArch:  %{ix86}
18
19 # don't try to strip Linux-8086 objects
20 %define         no_install_post_strip   1
21
22 %description
23 Bcc is a simple C compiler that produces 8086 assembler, in addition
24 compiler compile time options allow 80386 or 6809 versions. The
25 compiler understands traditional K&R C with just the restriction that
26 bit fields are mapped to one of the other integer types.
27
28 %description -l pl
29 Bcc jest prostym kompilatorem C tworz±cym pliki asemblerowe 8086,
30 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
31 rozumie tradycyjne C K&R z takim ograniczeniem, ¿e pola bitowe
32 s± odwzorowywane do jednego z innych typów ca³kowitych.
33
34 %prep
35 %setup -q -n dev86-%{version}
36 %patch0 -p1
37 %patch1 -p1
38 %patch2 -p1
39 %patch3 -p1
40
41 %build
42 CC="%{__cc}" \
43 %{__make} all other \
44         OPT="%{rpmcflags}" <<!FooBar!
45 5
46 quit
47 !FooBar!
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install-all \
53         DIST=$RPM_BUILD_ROOT
54
55 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
56 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
57
58 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
59 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
60
61 # move header files out of %{_includedir} and into %{_libdir}/bcc/include
62 mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
63
64 # move man pages where they belong
65 install -d $RPM_BUILD_ROOT%{_mandir}
66 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
67 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
68 # these are separated in bin86 package
69 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
70
71 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
72 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
73
74 mv -f bootblocks/README README.bootblocks
75 mv -f copt/README README.copt
76 mv -f dis88/README README.dis88
77 mv -f elksemu/README README.elksemu
78 mv -f unproto/README README.unproto
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changes Contributors README*
86 %attr(755,root,root) %{_bindir}/bcc
87 %attr(755,root,root) %{_bindir}/ar86
88 %attr(755,root,root) %{_bindir}/as86_encap
89 %attr(755,root,root) %{_bindir}/dis86
90 %attr(755,root,root) %{_bindir}/objdump86
91 %attr(755,root,root) %{_bindir}/nm86
92 %attr(755,root,root) %{_bindir}/size86
93 %{_libdir}/liberror.txt
94 %dir %{_libdir}/bcc
95 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
96 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
97 %attr(755,root,root) %{_libdir}/bcc/copt
98 %attr(755,root,root) %{_libdir}/bcc/unproto
99 %{_libdir}/bcc/i86
100 %{_libdir}/bcc/i386
101 %{_libdir}/bcc/include
102 %{_libdir}/bcc/kinclude
103 %attr(755,root,root) %{_bindir}/elksemu
104 %{_mandir}/man1/*
This page took 0.083129 seconds and 3 git commands to generate.