]> git.pld-linux.org Git - packages/bcc.git/commitdiff
- 0.16.12, added errno patch
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 8 Aug 2003 22:12:13 +0000 (22:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Dev86src-errno.patch -> 1.1
    bcc.spec -> 1.21

Dev86src-errno.patch [new file with mode: 0644]
bcc.spec

diff --git a/Dev86src-errno.patch b/Dev86src-errno.patch
new file mode 100644 (file)
index 0000000..9517ee2
--- /dev/null
@@ -0,0 +1,27 @@
+--- dev86-0.16.12/ar/ar.c.orig 2002-03-26 08:24:53.000000000 +0100
++++ dev86-0.16.12/ar/ar.c      2003-08-08 22:31:48.000000000 +0200
+@@ -31,6 +31,7 @@
+ #include <sys/stat.h>
+ #include "ar.h"
+ #include "rel_aout.h"
++#include <errno.h>
+ #ifdef __BCC__
+ #define HAVE_RENAME
+@@ -44,8 +45,6 @@
+ #undef  HAVE_FSYNC
+ #endif
+-extern int errno;
+-
+ #ifdef        __GNUC__
+ # ifndef alloca
+ #  define     alloca  __builtin_alloca
+@@ -67,7 +66,6 @@
+ /* Locking is normally disabled because fcntl hangs on the Sun
+    and it isn't supported properly across NFS anyway.  */
+ #ifdef LOCKS
+-#include <errno.h>
+ #endif
+ /* This structure is used internally to represent the info
index 709bd626251d2d4efa82099809c8a01cd3e0710b..378ad819c998b0097ae02bc1ab34ec642edfdc22 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -1,15 +1,16 @@
 Summary:       Bruce's C compiler
 Summary(pl):   Kompilator C Bruce'a
 Name:          bcc
-Version:       0.16.11
+Version:       0.16.12
 Release:       1
 License:       GPL
 Group:         Development/Languages
 Source0:       http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
-# Source0-md5: 7139cf3f48a3836672cf229162bf36b8
+# Source0-md5: 623480d77b685b1e7c762df04ad5e154
 Patch0:                Dev86src-noroot.patch
 Patch1:                Dev86src-nobcc.patch
 Patch2:                Dev86src-opt.patch
+Patch3:                Dev86src-errno.patch
 URL:           http://www.cix.co.uk/~mayday/
 Requires:      bin86
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -35,9 +36,12 @@ s
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
-CC="%{__cc}" %{__make} all other OPT="%{rpmcflags}" <<!FooBar!
+CC="%{__cc}" \
+%{__make} all other \
+       OPT="%{rpmcflags}" <<!FooBar!
 5
 quit
 !FooBar!
@@ -49,7 +53,6 @@ rm -rf $RPM_BUILD_ROOT
        DIST=$RPM_BUILD_ROOT
 
 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
-#rm -rf $RPM_BUILD_ROOT/lib/
 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
 
 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
This page took 0.119709 seconds and 4 git commands to generate.