]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to 4.1.7 auto/th/bash-4_1_7-1 auto/ti/bash-4_1_7-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 17 May 2010 11:30:54 +0000 (11:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash.spec -> 1.208
    bash41-006 -> 1.1
    bash41-007 -> 1.1

bash.spec
bash41-006 [new file with mode: 0644]
bash41-007 [new file with mode: 0644]

index 3cd9233206613b72faaece5a13467e21e88463c4..5d6bb3cab90888a40066166093bcf0613a02cbc7 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,7 +5,7 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             4.1
-%define                patchlevel      5
+%define                patchlevel      7
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
diff --git a/bash41-006 b/bash41-006
new file mode 100644 (file)
index 0000000..d6553b8
--- /dev/null
@@ -0,0 +1,76 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-006
+
+Bug-Reported-by:       Mike Frysinger <vapier@gentoo.org>
+Bug-Reference-ID:      <201003210155.56618.vapier@gentoo.org>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-03/msg00063.html
+
+Bug-Description:
+
+Bash did not correctly print/reproduce here documents attached to commands
+inside compound commands such as for and while.  This affected the
+execution of such commands inside a shell function when the function
+definition is saved and later restored using `.' or `eval'.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/print_cmd.c    2009-09-16 15:32:26.000000000 -0400
+--- print_cmd.c        2010-03-22 21:15:30.000000000 -0400
+***************
+*** 114,117 ****
+--- 114,123 ----
+  #define CHECK_XTRACE_FP      xtrace_fp = (xtrace_fp ? xtrace_fp : stderr)
+  
++ #define PRINT_DEFERRED_HEREDOCS(x) \
++   do { \
++     if (deferred_heredocs) \
++       print_deferred_heredocs (x); \
++   } while (0)
++ 
+  /* Non-zero means the stuff being printed is inside of a function def. */
+  static int inside_function_def;
+***************
+*** 561,571 ****
+  {
+    print_for_command_head (for_command);
+- 
+    cprintf (";");
+    newline ("do\n");
+    indentation += indentation_amount;
+    make_command_string_internal (for_command->action);
+    semicolon ();
+    indentation -= indentation_amount;
+    newline ("done");
+  }
+--- 566,578 ----
+  {
+    print_for_command_head (for_command);
+    cprintf (";");
+    newline ("do\n");
++ 
+    indentation += indentation_amount;
+    make_command_string_internal (for_command->action);
++   PRINT_DEFERRED_HEREDOCS ("");
+    semicolon ();
+    indentation -= indentation_amount;
++ 
+    newline ("done");
+  }
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 5
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 6
+  
+  #endif /* _PATCHLEVEL_H_ */
diff --git a/bash41-007 b/bash41-007
new file mode 100644 (file)
index 0000000..07b4796
--- /dev/null
@@ -0,0 +1,47 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-007
+
+Bug-Reported-by:       Rob Robason <rob@robason.net>
+Bug-Reference-ID:      <1269513145.22336.9.camel@home.robason.homelinux.net>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-03/msg00089.html
+
+Bug-Description:
+
+A typo caused bash to not honor a precision specification in a printf
+format.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/builtins/printf.def    2010-01-18 10:50:22.000000000 -0500
+--- builtins/printf.def        2010-03-25 09:40:56.000000000 -0400
+***************
+*** 118,122 ****
+        nw = vflag ? vbprintf (f, fieldwidth, func) : printf (f, fieldwidth, func); \
+      else if (have_precision) \
+!       nw = vflag ? vbprintf (f, precision, func) : printf (f, fieldwidth, func); \
+      else \
+        nw = vflag ? vbprintf (f, func) : printf (f, func); \
+--- 118,122 ----
+        nw = vflag ? vbprintf (f, fieldwidth, func) : printf (f, fieldwidth, func); \
+      else if (have_precision) \
+!       nw = vflag ? vbprintf (f, precision, func) : printf (f, precision, func); \
+      else \
+        nw = vflag ? vbprintf (f, func) : printf (f, func); \
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 6
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 7
+  
+  #endif /* _PATCHLEVEL_H_ */
This page took 0.165102 seconds and 4 git commands to generate.