]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to patchlevel 5 auto/th/bash-4_1_5-1 auto/ti/bash-4_1_5-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 28 Apr 2010 06:40:49 +0000 (06:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash.spec -> 1.207
    bash41-003 -> 1.1
    bash41-004 -> 1.1
    bash41-005 -> 1.1

bash.spec
bash41-003 [new file with mode: 0644]
bash41-004 [new file with mode: 0644]
bash41-005 [new file with mode: 0644]

index 4bd54772d568b32bafe7fa21fe307efe9adabf78..3cd9233206613b72faaece5a13467e21e88463c4 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,8 +5,8 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             4.1
-%define                patchlevel      2
-%define                rel             3
+%define                patchlevel      5
+%define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
diff --git a/bash41-003 b/bash41-003
new file mode 100644 (file)
index 0000000..479fdcd
--- /dev/null
@@ -0,0 +1,48 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-003
+
+Bug-Reported-by:       coyote@wariat.org.pl
+Bug-Reference-ID:      <4b64a1f8.06e2660a.60af.4bfb@mx.google.com>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-01/msg00135.html
+
+Bug-Description:
+
+If command completion is attempted on a word with a quoted globbing
+character (e.g., `*' or `?'), bash can reference a NULL pointer and
+dump core.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/bashline.c     2009-10-24 14:10:19.000000000 -0400
+--- bashline.c 2010-01-30 21:53:49.000000000 -0500
+***************
+*** 1681,1685 ****
+       characters in the common prefix are bad) will ever be returned on
+       regular completion. */
+!   if (glob_pattern_p (hint))
+      {
+        if (state == 0)
+--- 1681,1685 ----
+       characters in the common prefix are bad) will ever be returned on
+       regular completion. */
+!   if (globpat)
+      {
+        if (state == 0)
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 2
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 3
+  
+  #endif /* _PATCHLEVEL_H_ */
diff --git a/bash41-004 b/bash41-004
new file mode 100644 (file)
index 0000000..33f79bb
--- /dev/null
@@ -0,0 +1,47 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-004
+
+Bug-Reported-by:       Crestez Dan Leonard <cdleonard@gmail.com>
+Bug-Reference-ID:      <1265592839.30682.21.camel@deskbox>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-02/msg00034.html
+
+Bug-Description:
+
+When running in Posix mode and executing a shell function without local
+variables, bash will not propagate a variable in a special builtin's temporary
+environment to have global scope.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/variables.c    2009-11-03 14:13:58.000000000 -0500
+--- variables.c        2010-02-08 17:36:18.000000000 -0500
+***************
+*** 3809,3812 ****
+--- 3809,3817 ----
+    if (tempvar_p (var) && (posixly_correct || (var->attributes & att_propagate)))
+      {
++       /* Make sure we have a hash table to store the variable in while it is
++       being propagated down to the global variables table.  Create one if
++       we have to */
++       if ((vc_isfuncenv (shell_variables) || vc_istempenv (shell_variables)) && shell_variables->table == 0)
++      shell_variables->table = hash_create (0);
+        /* XXX - should we set v->context here? */
+        v = bind_variable_internal (var->name, value_cell (var), shell_variables->table, 0, 0);
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 3
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 4
+  
+  #endif /* _PATCHLEVEL_H_ */
diff --git a/bash41-005 b/bash41-005
new file mode 100644 (file)
index 0000000..8a2fec8
--- /dev/null
@@ -0,0 +1,56 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-005
+
+Bug-Reported-by:       werner@suse.de
+Bug-Reference-ID:      <201002251238.o1PCcYcg016893@boole.suse.de>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-02/msg00132.html
+
+Bug-Description:
+
+When the `read' builtin times out after the timeout specified with -t is
+exceeded, it does not reset the flags that tell signal handlers to process
+signals immediately instead of deferring their handling.  This can result
+in unsafe functions being called from signal handlers, which can cause bash
+to hang or dump core.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/builtins/read.def      2009-10-08 11:35:46.000000000 -0400
+--- builtins/read.def  2010-03-17 17:35:39.000000000 -0400
+***************
+*** 616,621 ****
+      zsyncfd (fd);
+  
+-   interrupt_immediately--;
+-   terminate_immediately--;
+    discard_unwind_frame ("read_builtin");
+  
+--- 616,619 ----
+***************
+*** 624,627 ****
+--- 622,628 ----
+  assign_vars:
+  
++   interrupt_immediately--;
++   terminate_immediately--;
++ 
+  #if defined (ARRAY_VARS)
+    /* If -a was given, take the string read, break it into a list of words,
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 4
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 5
+  
+  #endif /* _PATCHLEVEL_H_ */
This page took 0.071025 seconds and 4 git commands to generate.