]> git.pld-linux.org Git - packages/bamf.git/blob - bamf.spec
- unconditional noarch subpackages
[packages/bamf.git] / bamf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        Application matching framework
6 Name:           bamf
7 Version:        0.2.104
8 Release:        6
9 # Library bits are LGPLv2 or LGPLv3 (but not open-ended LGPLv2+);
10 # non-lib bits are GPLv3.
11 # pbrobinson points out that three files in the lib are actually
12 # marked GPL in headers, making library GPL, though we think this
13 # may not be upstream's intention. For now, marking library as
14 # GPL.
15 # License:      LGPLv2 or LGPLv3
16 License:        GPL v2 or GPL v3
17 Group:          Libraries
18 URL:            https://launchpad.net/bamf
19 Source0:        http://launchpad.net/bamf/0.2/%{version}/+download/%{name}-%{version}.tar.gz
20 # Source0-md5:  4271cd5979483f7e3a9bffc42fed6383
21 Patch0:         %{name}-build.patch
22 BuildRequires:  dbus-glib-devel
23 BuildRequires:  gobject-introspection-devel
24 BuildRequires:  gtk+2-devel
25 BuildRequires:  gtk+3-devel
26 BuildRequires:  gtk-doc
27 BuildRequires:  libgtop-devel
28 BuildRequires:  libwnck-devel
29 BuildRequires:  libwnck2-devel
30 BuildRequires:  pkgconfig
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 BAMF removes the headache of applications matching into a simple DBus
35 daemon and C wrapper library. Currently features application matching
36 at amazing levels of accuracy (covering nearly every corner case).
37 This package contains the bamf library built against GTK+ 2.
38
39 %package devel
40 Summary:        Development files for %{name}
41 License:        GPL v2 or GPL v3
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 The %{name}-devel package contains libraries and header files for
47 developing applications that use %{name}.
48
49 %package daemon
50 Summary:        Application matching framework
51 License:        GPL v3
52 Group:          Libraries
53
54 %description daemon
55 BAMF removes the headache of applications matching into a simple DBus
56 daemon and C wrapper library. Currently features application matching
57 at amazing levels of accuracy (covering nearly every corner case).
58 This package contains the bamf daemon and supporting data.
59
60 %package -n %{name}3
61 Summary:        Application matching framework (GTK+ 3 build)
62 Group:          Libraries
63
64 %description -n %{name}3
65 BAMF removes the headache of applications matching into a simple DBus
66 daemon and C wrapper library. Currently features application matching
67 at amazing levels of accuracy (covering nearly every corner case).
68 This package contains the bamf library built against GTK+ 3.
69
70 %package -n %{name}3-devel
71 Summary:        Development files for %{name} (GTK+ 3 build)
72 License:        GPL v2 or GPL v3
73 Group:          Development/Libraries
74 Requires:       %{name}3 = %{version}-%{release}
75
76 %description -n %{name}3-devel
77 The %{name}3-devel package contains libraries and header files for
78 developing applications that use %{name} (GTK+ 3 build).
79
80 %package apidocs
81 Summary:        %{name} API documentation
82 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
83 Group:          Documentation
84 %if "%{_rpmversion}" >= "5"
85 BuildArch:      noarch
86 %endif
87
88 %description apidocs
89 API and internal documentation for %{name} library.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 # ../.././src/bamf-legacy-window.c: In function 'bamf_legacy_window_get_class_name':
97 # ../.././src/bamf-legacy-window.c:144:3: error: 'wnck_class_group_get_res_class' is deprecated (declared at /usr/include/libwnck-3.0/libwnck/class-group.h:89): Use 'wnck_class_group_get_id' instead [-Werror=deprecated-declarations]
98 CFLAGS="%{rpmcflags} -Wno-error=deprecated-declarations"
99
100 install -d build-gtk3 build-gtk2
101 cd build-gtk2
102 ../%configure \
103         --disable-static \
104         --with-gtk=2 \
105         --with-html-dir=%{_gtkdocdir} \
106         --enable-gtk-doc
107 %{__make}
108
109 cd ../build-gtk3
110 ../%configure \
111         --disable-static \
112         --with-gtk=3 \
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 %{__make} install -C build-gtk2 \
119         DESTDIR=$RPM_BUILD_ROOT
120 %{__make} install -C build-gtk3 \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbamf.la
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbamf3.la
125
126 #find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %post   -n %{name}3 -p /sbin/ldconfig
135 %postun -n %{name}3 -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libbamf.so.*.*.*
140 %ghost %{_libdir}/libbamf.so.0
141
142 %files -n       %{name}3
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libbamf3.so.*.*.*
145 %ghost %{_libdir}/libbamf3.so.0
146
147 %files devel
148 %defattr(644,root,root,755)
149 %{_includedir}/libbamf
150 %{_libdir}/libbamf.so
151 %{_pkgconfigdir}/libbamf.pc
152 # Installation of these was disabled in the 0.2.72 release commit,
153 # with no explanation - http://bazaar.launchpad.net/~unity-team/bamf/trunk/revision/374
154 #%{_libdir}/girepository-1.0/Bamf*.typelib
155 #%{_datadir}/gir-1.0/Bamf*.gir
156 #%{_datadir}/vala/vapi/Bamf*.vapi
157
158 %files -n       %{name}3-devel
159 %defattr(644,root,root,755)
160 %{_includedir}/libbamf3
161 %{_libdir}/libbamf3.so
162 %{_pkgconfigdir}/libbamf3.pc
163
164 %files daemon
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/bamfdaemon
167 %{_datadir}/dbus-1/services/org.ayatana.bamf.service
168
169 %if %{with apidocs}
170 %files apidocs
171 %defattr(644,root,root,755)
172 %{_gtkdocdir}/libbamf
173 %endif
This page took 0.060087 seconds and 3 git commands to generate.