]> git.pld-linux.org Git - packages/bamf.git/blob - bamf.spec
noarch apidocs
[packages/bamf.git] / bamf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        Application matching framework
6 Name:           bamf
7 Version:        0.2.104
8 Release:        3
9 # Library bits are LGPLv2 or LGPLv3 (but not open-ended LGPLv2+);
10 # non-lib bits are GPLv3.
11 # pbrobinson points out that three files in the lib are actually
12 # marked GPL in headers, making library GPL, though we think this
13 # may not be upstream's intention. For now, marking library as
14 # GPL.
15 # License:      LGPLv2 or LGPLv3
16 License:        GPL v2 or GPL v3
17 Group:          Libraries
18 URL:            https://launchpad.net/bamf
19 Source0:        http://launchpad.net/bamf/0.2/%{version}/+download/%{name}-%{version}.tar.gz
20 # Source0-md5:  4271cd5979483f7e3a9bffc42fed6383
21 BuildRequires:  dbus-glib-devel
22 BuildRequires:  gobject-introspection-devel
23 BuildRequires:  gtk+2-devel
24 BuildRequires:  gtk+3-devel
25 BuildRequires:  gtk-doc
26 BuildRequires:  libgtop-devel
27 BuildRequires:  libwnck-devel
28 BuildRequires:  libwnck2-devel
29 BuildRequires:  pkgconfig
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 BAMF removes the headache of applications matching into a simple DBus
34 daemon and C wrapper library. Currently features application matching
35 at amazing levels of accuracy (covering nearly every corner case).
36 This package contains the bamf library built against GTK+ 2.
37
38 %package devel
39 Summary:        Development files for %{name}
40 License:        GPL v2 or GPL v3
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 The %{name}-devel package contains libraries and header files for
46 developing applications that use %{name}.
47
48 %package daemon
49 Summary:        Application matching framework
50 License:        GPL v3
51 Group:          Libraries
52
53 %description daemon
54 BAMF removes the headache of applications matching into a simple DBus
55 daemon and C wrapper library. Currently features application matching
56 at amazing levels of accuracy (covering nearly every corner case).
57 This package contains the bamf daemon and supporting data.
58
59 %package -n %{name}3
60 Summary:        Application matching framework (GTK+ 3 build)
61 Group:          Libraries
62
63 %description -n %{name}3
64 BAMF removes the headache of applications matching into a simple DBus
65 daemon and C wrapper library. Currently features application matching
66 at amazing levels of accuracy (covering nearly every corner case).
67 This package contains the bamf library built against GTK+ 3.
68
69 %package -n %{name}3-devel
70 Summary:        Development files for %{name} (GTK+ 3 build)
71 License:        GPL v2 or GPL v3
72 Group:          Development/Libraries
73 Requires:       %{name}3 = %{version}-%{release}
74
75 %description -n %{name}3-devel
76 The %{name}3-devel package contains libraries and header files for
77 developing applications that use %{name} (GTK+ 3 build).
78
79 %package apidocs
80 Summary:        %{name} API documentation
81 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
82 Group:          Documentation
83 %if "%{_rpmversion}" >= "5"
84 BuildArch:      noarch
85 %endif
86
87 %description apidocs
88 API and internal documentation for %{name} library.
89
90 %prep
91 %setup -q
92
93 %build
94 # ../.././src/bamf-legacy-window.c: In function 'bamf_legacy_window_get_class_name':
95 # ../.././src/bamf-legacy-window.c:144:3: error: 'wnck_class_group_get_res_class' is deprecated (declared at /usr/include/libwnck-3.0/libwnck/class-group.h:89): Use 'wnck_class_group_get_id' instead [-Werror=deprecated-declarations]
96 CFLAGS="%{rpmcflags} -Wno-error=deprecated-declarations"
97
98 install -d build-gtk3 build-gtk2
99 cd build-gtk2
100 ../%configure \
101         --disable-static \
102         --with-gtk=2 \
103         --with-html-dir=%{_gtkdocdir} \
104         --enable-gtk-doc
105 %{__make}
106
107 cd ../build-gtk3
108 ../%configure \
109         --disable-static \
110         --with-gtk=3 \
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 %{__make} install -C build-gtk2 \
117         DESTDIR=$RPM_BUILD_ROOT
118 %{__make} install -C build-gtk3 \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbamf.la
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbamf3.la
123
124 #find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post   -n %{name}3 -p /sbin/ldconfig
133 %postun -n %{name}3 -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libbamf.so.*.*.*
138 %ghost %{_libdir}/libbamf.so.0
139
140 %files -n       %{name}3
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libbamf3.so.*.*.*
143 %ghost %{_libdir}/libbamf3.so.0
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_includedir}/libbamf
148 %{_libdir}/libbamf.so
149 %{_pkgconfigdir}/libbamf.pc
150 # Installation of these was disabled in the 0.2.72 release commit,
151 # with no explanation - http://bazaar.launchpad.net/~unity-team/bamf/trunk/revision/374
152 #%{_libdir}/girepository-1.0/Bamf*.typelib
153 #%{_datadir}/gir-1.0/Bamf*.gir
154 #%{_datadir}/vala/vapi/Bamf*.vapi
155
156 %files -n       %{name}3-devel
157 %defattr(644,root,root,755)
158 %{_includedir}/libbamf3
159 %{_libdir}/libbamf3.so
160 %{_pkgconfigdir}/libbamf3.pc
161
162 %files daemon
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/bamfdaemon
165 %{_datadir}/dbus-1/services/org.ayatana.bamf.service
166
167 %if %{with apidocs}
168 %files apidocs
169 %defattr(644,root,root,755)
170 %{_gtkdocdir}/libbamf
171 %endif
This page took 0.104787 seconds and 3 git commands to generate.