]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
- updated to 0.1.1.20031001
[packages/bakefile.git] / bakefile.spec
1
2 %include        /usr/lib/rpm/macros.python
3
4 Summary:        Native makefiles generator
5 Name:           bakefile
6 Version:        0.1.1
7 %define         snap 20031001
8 Release:        0.%{snap}.1
9 License:        GPL v2+
10 Group:          Applications/Text
11 Source0:        http://bakefile.sourceforge.net/snapshot/bakefile-%{version}.%{snap}.tar.gz
12 # Source0-md5:  1a98d7da01d6a65f5daa888c88f3c400
13 Patch0:         %{name}-empy.patch
14 URL:            http://bakefile.sourceforge.net/
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-modules
17 Requires:       python-libxml2
18 Requires:       empy >= 3.1
19 Requires:       python-optik >= 1.2
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Bakefile is cross-platform, cross-compiler native makefiles generator. It takes
24 compiler-independent description of build tasks as input and generate native
25 makefile (autoconf's Makefile.in, Visual C++ project, bcc makefile etc.).
26
27 %prep
28 %setup -q -n %{name}-%{version}.%{snap}
29 %patch0 -p1
30
31 %build
32 %configure
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
37
38 %{__make} \
39         DESTDIR=$RPM_BUILD_ROOT \
40         install
41
42 # use system available modules
43 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/src/{empy,optik}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README THANKS doc/html
51 %attr(755,root,root) %{_bindir}/*
52 %{_aclocaldir}/*.m4
53 %dir %{_datadir}/%{name}
54 %{_datadir}/%{name}/output
55 %{_datadir}/%{name}/rules
56 %dir %{_datadir}/%{name}/src
57 %{_datadir}/%{name}/src/*.py[oc]
58 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile.py
59 %attr(755,root,root) %{_datadir}/%{name}/src/bakefile_gen.py
60 %{_mandir}/man1/bakefile.1*
This page took 0.061066 seconds and 4 git commands to generate.