]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
- up to 0.2.12
[packages/bakefile.git] / bakefile.spec
1 # NOTE: for 1.x versions see DEVEL branch; it's not compatible with 0.x, and (according to web site) still work in progress.
2 Summary:        Native makefiles generator
3 Summary(pl.UTF-8):      Generator natywnych plików typu Makefile
4 Name:           bakefile
5 Version:        0.2.12
6 Release:        1
7 License:        MIT
8 Group:          Development/Building
9 #SourceDownload: https://github.com/vslavik/bakefile/releases
10 Source0:        https://github.com/vslavik/bakefile/releases/download/v%{version}.1/%{name}-%{version}.tar.gz
11 # Source0-md5:  a735ce2c1ca1b86adbcb2fdb06ade802
12 Patch0:         %{name}-empy.patch
13 URL:            http://bakefile.org/
14 BuildRequires:  autoconf >= 2.53
15 BuildRequires:  automake >= 1.6
16 BuildRequires:  libtool
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  rpm-pythonprov
19 %pyrequires_eq  python-modules
20 Requires:       empy >= 3.1
21 Requires:       python-libxml2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Bakefile is cross-platform, cross-compiler native makefiles generator.
26 It takes compiler-independent description of build tasks as input and
27 generate native makefile (autoconf's Makefile.in, Visual C++ project,
28 bcc makefile etc.).
29
30 %description -l pl.UTF-8
31 Bakefile to generator natywnych plików typu Makefile dla wielu
32 platform i kompilatorów. Przyjmuje na wejściu niezależny od
33 kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
34 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' \
41         src/bakefile.py \
42         src/bakefile_gen.py
43
44 %build
45 %{__libtoolize}
46 %{__aclocal} -I admin
47 %{__autoconf}
48 %{__automake}
49 %configure
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 # use system available modules
58 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
59
60 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
61 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc AUTHORS COPYING NEWS README THANKS doc/html
69 %attr(755,root,root) %{_bindir}/bakefile
70 %attr(755,root,root) %{_bindir}/bakefile_gen
71 %attr(755,root,root) %{_bindir}/bakefilize
72 %{_datadir}/%{name}
73 %dir %{_libdir}/%{name}
74 %{_libdir}/%{name}/*.py[co]
75 %attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
76 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
77 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
78 %{_aclocaldir}/bakefile*.m4
79 %{_mandir}/man1/bakefile.1*
80 %{_mandir}/man1/bakefile_gen.1*
81 %{_mandir}/man1/bakefilize.1*
This page took 0.051426 seconds and 4 git commands to generate.