]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
fde1c692f7701213a09f1cdc9742385e0bf0ca80
[packages/bakefile.git] / bakefile.spec
1 Summary:        Native makefiles generator
2 Summary(pl.UTF-8):      Generator natywnych plików typu Makefile
3 Name:           bakefile
4 Version:        0.2.10
5 Release:        1
6 License:        MIT
7 Group:          Development/Building
8 #SourceDownload: https://github.com/vslavik/bakefile/releases
9 Source0:        https://github.com/vslavik/bakefile/releases/download/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  f980cdd36268b5d2b23602d454bdf0a4
11 Patch0:         %{name}-empy.patch
12 URL:            http://bakefile.org/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1.6
15 BuildRequires:  libtool
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python-modules
19 Requires:       empy >= 3.1
20 Requires:       python-libxml2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Bakefile is cross-platform, cross-compiler native makefiles generator.
25 It takes compiler-independent description of build tasks as input and
26 generate native makefile (autoconf's Makefile.in, Visual C++ project,
27 bcc makefile etc.).
28
29 %description -l pl.UTF-8
30 Bakefile to generator natywnych plików typu Makefile dla wielu
31 platform i kompilatorów. Przyjmuje na wejściu niezależny od
32 kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
33 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
34
35 %prep
36 %setup -q
37 %patch0 -p1
38
39 %build
40 %{__libtoolize}
41 %{__aclocal} -I admin
42 %{__autoconf}
43 %{__automake}
44 %configure
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 # use system available modules
53 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
54
55 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
56 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS COPYING NEWS README THANKS doc/html
64 %attr(755,root,root) %{_bindir}/bakefile
65 %attr(755,root,root) %{_bindir}/bakefile_gen
66 %attr(755,root,root) %{_bindir}/bakefilize
67 %{_datadir}/%{name}
68 %dir %{_libdir}/%{name}
69 %{_libdir}/%{name}/*.py[oc]
70 %attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
71 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
72 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
73 %{_aclocaldir}/bakefile*.m4
74 %{_mandir}/man1/bakefile.1*
75 %{_mandir}/man1/bakefile_gen.1*
76 %{_mandir}/man1/bakefilize.1*
This page took 0.094143 seconds and 2 git commands to generate.