]> git.pld-linux.org Git - packages/bakefile.git/blob - bakefile.spec
2fcac687b70dbc90d7cb284b6e360b0bcb13e549
[packages/bakefile.git] / bakefile.spec
1 #
2 # TODO: unpackaged files
3 #
4 Summary:        Native makefiles generator
5 Summary(pl.UTF-8):      Generator natywnych plików typu Makefile
6 Name:           bakefile
7 Version:        0.2.9
8 Release:        0.1
9 License:        MIT
10 Group:          Development/Building
11 Source0:        http://downloads.sourceforge.net/bakefile/%{name}-%{version}.tar.gz
12 # Source0-md5:  b53813d155df1a45371abc8f781e6d88
13 Patch0:         %{name}-empy.patch
14 URL:            http://bakefile.sourceforge.net/
15 BuildRequires:  autoconf >= 2.53
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  libtool
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rpm-pythonprov
20 %pyrequires_eq  python-modules
21 Requires:       empy >= 3.1
22 Requires:       python-libxml2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Bakefile is cross-platform, cross-compiler native makefiles generator.
27 It takes compiler-independent description of build tasks as input and
28 generate native makefile (autoconf's Makefile.in, Visual C++ project,
29 bcc makefile etc.).
30
31 %description -l pl.UTF-8
32 Bakefile to generator natywnych plików typu Makefile dla wielu
33 platform i kompilatorów. Przyjmuje na wejściu niezależny od
34 kompilatora opis zadań budowania i tworzy natywny plik (Makefile.in
35 dla autoconfa, projekt dla Visual C++, makefile dla bcc itd.).
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 %{__libtoolize}
43 %{__aclocal} -I admin
44 %{__autoconf}
45 %{__automake}
46 %configure
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 # use system available modules
55 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/{empy,py25modules}
56
57 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
58 find $RPM_BUILD_ROOT%{_libdir}/%{name} -name '*.py' | grep -E -v '/bakefile(_gen)?\.py' | xargs %{__rm}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS COPYING NEWS README THANKS doc/html
66 %attr(755,root,root) %{_bindir}/bakefile
67 %attr(755,root,root) %{_bindir}/bakefile_gen
68 %attr(755,root,root) %{_bindir}/bakefilize
69 %{_datadir}/%{name}
70 %dir %{_libdir}/%{name}
71 %{_libdir}/%{name}/*.py[oc]
72 %attr(755,root,root) %{_libdir}/%{name}/_bkl_c.so
73 %attr(755,root,root) %{_libdir}/%{name}/bakefile.py
74 %attr(755,root,root) %{_libdir}/%{name}/bakefile_gen.py
75 %{_aclocaldir}/bakefile*.m4
76 %{_mandir}/man1/bakefile.1*
77 %{_mandir}/man1/bakefile_gen.1*
78 %{_mandir}/man1/bakefilize.1*
This page took 0.066882 seconds and 2 git commands to generate.