]> git.pld-linux.org Git - packages/babl.git/blob - babl.spec
- updated to 0.1.72; now uses meson
[packages/babl.git] / babl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_with     mmx             # MMX instructions
5 %bcond_with     sse             # SSE instructions
6 %bcond_with     sse2            # SSE2 instructions in CIE,two-table,ycbcr modules, sse2-* modules
7 # sse4.1, avx2, f16c are optional (in separate modules)
8 # sse2 is runtime-detected, but whole files are compiled with -msse2, so it's not optional
9 #
10 %ifarch pentium2 pentium3 pentium4 athlon %{x8664} x32
11 %define         with_mmx        1
12 %endif
13 %ifarch pentium3 pentium4 %{x8664} x32
14 %define         with_sse        1
15 %endif
16 %ifarch pentium4 %{x8664} x32
17 %define         with_sse2       1
18 %endif
19 Summary:        Library for pixel-format agnosticism
20 Summary(pl.UTF-8):      Biblioteka niezależności od formatu piksela
21 Name:           babl
22 Version:        0.1.72
23 Release:        1
24 License:        LGPL v3+
25 Group:          Libraries
26 Source0:        https://download.gimp.org/pub/babl/0.1/%{name}-%{version}.tar.xz
27 # Source0-md5:  4f2c317328d89242e552fcb5ef66a844
28 Patch0:         %{name}-modules.patch
29 URL:            http://www.gegl.org/babl/
30 BuildRequires:  meson >= 0.50.0
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  rpmbuild(macros) >= 1.736
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 %{?with_mmx:Requires:   cpuinfo(mmx)}
36 %{?with_sse:Requires:   cpuinfo(sse)}
37 %{?with_sse:Requires:   cpuinfo(sse2)}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Babl is a dynamic, any to any, pixel format conversion library. It
42 provides conversions between the myriad of buffer types images can be
43 stored in. Babl doesn't only help with existing pixel formats, but
44 also facilitates creation of new and uncommon ones.
45
46 %description -l pl.UTF-8
47 Babl to biblioteka dynamicznych przekształceń między dowolnymi
48 formatami pikseli. Udostępnia konwersje między wieloma różnymi typami
49 buforów obrazów. Babl nie tylko pomaga przy istniejących formatach
50 pikseli, ale także ułatwia tworzenie nowych i niestandardowych.
51
52 %package devel
53 Summary:        Header files for babl library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki babl
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Obsoletes:      vala-babl < 0.1.12
58
59 %description devel
60 Header files for babl library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki babl.
64
65 %package static
66 Summary:        Static babl library
67 Summary(pl.UTF-8):      Statyczna biblioteka babl
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static babl library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka babl.
76
77 %package -n vala-babl
78 Summary:        Vala API for babl library
79 Summary(pl.UTF-8):      API języka Vala dla biblioteki babl
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82 Requires:       vala
83
84 %description -n vala-babl
85 Vala API for babl library.
86
87 %description -n vala-babl -l pl.UTF-8
88 API języka Vala dla biblioteki babl.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %build
95 %meson build \
96         %{!?with_mmx:-Denable-mmx=false} \
97         %{!?with_sse:-Denable-sse=false} \
98         %{!?with_sse2:-Denable-sse2=false}
99
100 %ninja_build -C build
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %ninja_install -C build
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS MAINTAINERS NEWS TODO
116 %attr(755,root,root) %{_libdir}/libbabl-0.1.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libbabl-0.1.so.0
118 %{_libdir}/girepository-1.0/Babl-0.1.typelib
119 %dir %{_libdir}/babl-0.1
120 %attr(755,root,root) %{_libdir}/babl-0.1/*.so
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc docs/{*.html,*.css}
125 %attr(755,root,root) %{_libdir}/libbabl-0.1.so
126 %{_includedir}/babl-0.1
127 %{_datadir}/gir-1.0/Babl-0.1.gir
128 %{_pkgconfigdir}/babl.pc
129
130 %if %{with static_libs}
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libbabl-0.1.a
134 %endif
135
136 %if 0
137 %files -n vala-babl
138 %defattr(644,root,root,755)
139 %{_datadir}/vala/vapi/babl-0.1.vapi
140 %endif
This page took 0.265638 seconds and 4 git commands to generate.