]> git.pld-linux.org Git - packages/babl.git/blob - babl.spec
BR: pkgconfig
[packages/babl.git] / babl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Library for pixel-format agnosticism
6 Summary(pl.UTF-8):      Biblioteka niezależności od formatu piksela
7 Name:           babl
8 Version:        0.1.30
9 Release:        1
10 License:        LGPL v3+
11 Group:          Libraries
12 Source0:        https://download.gimp.org/pub/babl/0.1/%{name}-%{version}.tar.bz2
13 # Source0-md5:  fca6926a00130eeacc875cac5465c5e7
14 Patch0:         %{name}-as-needed.patch
15 URL:            http://www.gegl.org/babl/
16 BuildRequires:  autoconf >= 2.54
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  libtool >= 2:2.2
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Babl is a dynamic, any to any, pixel format conversion library. It
23 provides conversions between the myriad of buffer types images can be
24 stored in. Babl doesn't only help with existing pixel formats, but
25 also facilitates creation of new and uncommon ones.
26
27 %description -l pl.UTF-8
28 Babl to biblioteka dynamicznych przekształceń między dowolnymi
29 formatami pikseli. Udostępnia konwersje między wieloma różnymi typami
30 buforów obrazów. Babl nie tylko pomaga przy istniejących formatach
31 pikseli, ale także ułatwia tworzenie nowych i niestandardowych.
32
33 %package devel
34 Summary:        Header files for babl library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki babl
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for babl library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki babl.
44
45 %package static
46 Summary:        Static babl library
47 Summary(pl.UTF-8):      Statyczna biblioteka babl
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static babl library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka babl.
56
57 %package -n vala-babl
58 Summary:        Vala API for babl library
59 Summary(pl.UTF-8):      API języka Vala dla biblioteki babl
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62 Requires:       vala
63
64 %description -n vala-babl
65 Vala API for babl library.
66
67 %description -n vala-babl -l pl.UTF-8
68 API języka Vala dla biblioteki babl.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 %{__libtoolize}
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         --disable-silent-rules \
82         %{?with_static_libs:--enable-static}
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 # dlopened modules
92 %{__rm} $RPM_BUILD_ROOT%{_libdir}/babl-0.1/*.la
93 %if %{with static_libs}
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/babl-0.1/*.a
95 %endif
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS NEWS README TODO
106 %attr(755,root,root) %{_libdir}/libbabl-0.1.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libbabl-0.1.so.0
108 %dir %{_libdir}/babl-0.1
109 %attr(755,root,root) %{_libdir}/babl-0.1/*.so
110
111 %files devel
112 %defattr(644,root,root,755)
113 %doc docs/{*.html,*.css}
114 %attr(755,root,root) %{_libdir}/libbabl-0.1.so
115 %{_libdir}/libbabl-0.1.la
116 %{_includedir}/babl-0.1
117 %{_pkgconfigdir}/babl.pc
118
119 %if %{with static_libs}
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libbabl-0.1.a
123 %endif
124
125 %if 0
126 %files -n vala-babl
127 %defattr(644,root,root,755)
128 %{_datadir}/vala/vapi/babl-0.1.vapi
129 %endif
This page took 0.150935 seconds and 3 git commands to generate.