]> git.pld-linux.org Git - packages/babl.git/blob - babl.spec
7ca508edd1a42d4c48c5a8e1bcc6406d1e85a079
[packages/babl.git] / babl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_with     mmx             # MMX instructions
5 %bcond_with     sse             # SSE instructions
6 %bcond_with     sse2            # SSE2 instructions in CIE,two-table,ycbcr modules, sse2-* modules
7 # sse4.1, avx2, f16c are optional (in separate modules)
8 # sse2 is runtime-detected, but whole files are compiled with -msse2, so it's not optional
9 #
10 %ifarch pentium2 pentium3 pentium4 athlon %{x8664} x32
11 %define         with_mmx        1
12 %endif
13 %ifarch pentium3 pentium4 %{x8664} x32
14 %define         with_sse        1
15 %endif
16 %ifarch pentium4 %{x8664} x32
17 %define         with_sse2       1
18 %endif
19 Summary:        Library for pixel-format agnosticism
20 Summary(pl.UTF-8):      Biblioteka niezależności od formatu piksela
21 Name:           babl
22 Version:        0.1.86
23 Release:        1
24 License:        LGPL v3+
25 Group:          Libraries
26 Source0:        https://download.gimp.org/pub/babl/0.1/%{name}-%{version}.tar.xz
27 # Source0-md5:  a4aae9effaf94f17a82fbd534f62e8f2
28 URL:            https://www.gegl.org/babl/
29 BuildRequires:  gobject-introspection-devel >= 1.32.0
30 BuildRequires:  lcms2-devel >= 2.8
31 BuildRequires:  meson >= 0.54.0
32 BuildRequires:  ninja >= 1.5
33 BuildRequires:  python3 >= 1:3
34 BuildRequires:  rpm-build >= 4.6
35 BuildRequires:  rpmbuild(macros) >= 1.752
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  vala >= 2:0.20.0
38 BuildRequires:  xz
39 %{?with_mmx:Requires:   cpuinfo(mmx)}
40 %{?with_sse:Requires:   cpuinfo(sse)}
41 %{?with_sse:Requires:   cpuinfo(sse2)}
42 Requires:       lcms2 >= 2.8
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Babl is a dynamic, any to any, pixel format conversion library. It
47 provides conversions between the myriad of buffer types images can be
48 stored in. Babl doesn't only help with existing pixel formats, but
49 also facilitates creation of new and uncommon ones.
50
51 %description -l pl.UTF-8
52 Babl to biblioteka dynamicznych przekształceń między dowolnymi
53 formatami pikseli. Udostępnia konwersje między wieloma różnymi typami
54 buforów obrazów. Babl nie tylko pomaga przy istniejących formatach
55 pikseli, ale także ułatwia tworzenie nowych i niestandardowych.
56
57 %package devel
58 Summary:        Header files for babl library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki babl
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       lcms2-devel >= 2.8
63
64 %description devel
65 Header files for babl library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki babl.
69
70 %package static
71 Summary:        Static babl library
72 Summary(pl.UTF-8):      Statyczna biblioteka babl
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static babl library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka babl.
81
82 %package -n vala-babl
83 Summary:        Vala API for babl library
84 Summary(pl.UTF-8):      API języka Vala dla biblioteki babl
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       vala >= 2:0.20.0
88 BuildArch:      noarch
89
90 %description -n vala-babl
91 Vala API for babl library.
92
93 %description -n vala-babl -l pl.UTF-8
94 API języka Vala dla biblioteki babl.
95
96 %prep
97 %setup -q
98
99 %build
100 %meson build \
101         %{!?with_mmx:-Denable-mmx=false} \
102         %{!?with_sse:-Denable-sse=false} \
103         %{!?with_sse2:-Denable-sse2=false}
104
105 %ninja_build -C build
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %ninja_install -C build
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS MAINTAINERS NEWS TODO
121 %attr(755,root,root) %{_libdir}/libbabl-0.1.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libbabl-0.1.so.0
123 %{_libdir}/girepository-1.0/Babl-0.1.typelib
124 %dir %{_libdir}/babl-0.1
125 %attr(755,root,root) %{_libdir}/babl-0.1/*.so
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc docs/{*.html,*.css}
130 %attr(755,root,root) %{_libdir}/libbabl-0.1.so
131 %{_includedir}/babl-0.1
132 %{_datadir}/gir-1.0/Babl-0.1.gir
133 %{_pkgconfigdir}/babl.pc
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libbabl-0.1.a
139 %endif
140
141 %files -n vala-babl
142 %defattr(644,root,root,755)
143 %{_datadir}/vala/vapi/babl-0.1.deps
144 %{_datadir}/vala/vapi/babl-0.1.vapi
This page took 0.084096 seconds and 2 git commands to generate.