]> git.pld-linux.org Git - packages/babeltrace.git/blob - babeltrace.spec
- note on babeltrace 2.0.0 actually being babeltrace2
[packages/babeltrace.git] / babeltrace.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4 #
5 Summary:        Trace Format Babel Tower
6 Summary(pl.UTF-8):      Wieża Babel formatów narzędzi śledzących
7 Name:           babeltrace
8 # keep 1.x here, babeltrace2 is separate project (see babeltrace2.spec)
9 Version:        1.5.8
10 Release:        1
11 License:        MIT
12 Group:          Applications/System
13 Source0:        https://www.efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
14 # Source0-md5:  5c305d6f4be15bc3562c724f9b5206df
15 Patch0:         %{name}-python.patch
16 URL:            https://babeltrace.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  elfutils-devel >= 0.154
20 BuildRequires:  glib2-devel >= 1:2.22.0
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  libuuid-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  popt-devel
25 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.507
28 Requires:       elfutils >= 0.154
29 Requires:       glib2 >= 1:2.22.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This project provides trace read and write libraries, as well as a
34 trace converter. A plugin can be created for any trace format to allow
35 its conversion to/from another trace format.
36
37 %description -l pl.UTF-8
38 Ten projekt udostępnia biblioteki do odczytu i zapisu śladów, a także
39 konwerter śladów. Można tworzyć wtyczki dla dowolnego formatu śladów,
40 aby umożliwić konwersję do/z innego formatu.
41
42 %package devel
43 Summary:        Header files for Babeltrace libraries
44 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Babeltrace
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       elfutils-devel >= 0.154
48 Requires:       glib2-devel >= 1:2.22.0
49 Requires:       libuuid-devel
50 Requires:       popt-devel
51
52 %description devel
53 Header files for Babeltrace libraries.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe bibliotek Babeltrace.
57
58 %package static
59 Summary:        Static Babeltrace libraries
60 Summary(pl.UTF-8):      Statyczne biblioteki Babeltrace
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static Babeltrace libraries.
66
67 %description static -l pl.UTF-8
68 Statyczne biblioteki Babeltrace.
69
70 %package -n python3-babeltrace
71 Summary:        Python 3 binding to Babeltrace library
72 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki Babeltrace
73 Group:          Libraries/Python
74 Requires:       %{name} = %{version}-%{release}
75 Obsoletes:      python-babeltrace < 1.5.3
76
77 %description -n python3-babeltrace
78 Python 3 binding to Babeltrace library.
79
80 %description -n python3-babeltrace -l pl.UTF-8
81 Wiązanie Pythona 3 do biblioteki Babeltrace.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         %{?with_python:--enable-python-bindings} \
95         --disable-silent-rules
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 # lib*.la kept - no .pc files for individual libraries
105
106 # packaged as %doc
107 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/babeltrace
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc ChangeLog LICENSE README std-ext-lib.txt
118 %attr(755,root,root) %{_bindir}/babeltrace
119 %attr(755,root,root) %{_bindir}/babeltrace-log
120 %attr(755,root,root) %{_libdir}/libbabeltrace.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace.so.1
122 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf.so.1
124 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-metadata.so.1
126 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-text.so.1
128 %attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-dummy.so.1
130 %attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-lttng-live.so.1
132 %{_mandir}/man1/babeltrace.1*
133 %{_mandir}/man1/babeltrace-log.1*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %doc doc/{API,development}.txt
138 %attr(755,root,root) %{_libdir}/libbabeltrace.so
139 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so
140 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so
141 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so
142 %attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so
143 %attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so
144 %{_libdir}/libbabeltrace.la
145 %{_libdir}/libbabeltrace-ctf.la
146 %{_libdir}/libbabeltrace-ctf-metadata.la
147 %{_libdir}/libbabeltrace-ctf-text.la
148 %{_libdir}/libbabeltrace-dummy.la
149 %{_libdir}/libbabeltrace-lttng-live.la
150 %{_includedir}/babeltrace
151 %{_pkgconfigdir}/babeltrace.pc
152 %{_pkgconfigdir}/babeltrace-ctf.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libbabeltrace.a
157 %{_libdir}/libbabeltrace-ctf.a
158 %{_libdir}/libbabeltrace-ctf-metadata.a
159 %{_libdir}/libbabeltrace-ctf-text.a
160 %{_libdir}/libbabeltrace-dummy.a
161 %{_libdir}/libbabeltrace-lttng-live.a
162
163 %if %{with python}
164 %files -n python3-babeltrace
165 %defattr(644,root,root,755)
166 %dir %{py3_sitedir}/babeltrace
167 %attr(755,root,root) %{py3_sitedir}/babeltrace/_babeltrace.cpython-*.so
168 %{py3_sitedir}/babeltrace/*.py
169 %{py3_sitedir}/babeltrace/__pycache__
170 %{py3_sitedir}/babeltrace-%{version}-py*.egg-info
171 %endif
This page took 0.111645 seconds and 4 git commands to generate.