]> git.pld-linux.org Git - packages/babeltrace.git/blob - babeltrace.spec
- release 2 (by relup.sh)
[packages/babeltrace.git] / babeltrace.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python binding
4 #
5 Summary:        Trace Format Babel Tower
6 Summary(pl.UTF-8):      Wieża Babel formatów narzędzi śledzących
7 Name:           babeltrace
8 Version:        1.5.6
9 Release:        2
10 License:        MIT
11 Group:          Applications/System
12 Source0:        https://www.efficios.com/files/babeltrace/%{name}-%{version}.tar.bz2
13 # Source0-md5:  8ce610461e73f48b9c6beec9ba95dcc3
14 Patch0:         %{name}-python.patch
15 URL:            http://diamon.org/babeltrace/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 1:2.22.0
19 BuildRequires:  libtool >= 2:2
20 BuildRequires:  libuuid-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  popt-devel
23 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.219
26 Requires:       glib2 >= 1:2.22.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This project provides trace read and write libraries, as well as a
31 trace converter. A plugin can be created for any trace format to allow
32 its conversion to/from another trace format.
33
34 %description -l pl.UTF-8
35 Ten projekt udostępnia biblioteki do odczytu i zapisu śladów, a także
36 konwerter śladów. Można tworzyć wtyczki dla dowolnego formatu śladów,
37 aby umożliwić konwersję do/z innego formatu.
38
39 %package devel
40 Summary:        Header files for Babeltrace libraries
41 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Babeltrace
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       glib2-devel >= 1:2.22.0
45 Requires:       libuuid-devel
46 Requires:       popt-devel
47
48 %description devel
49 Header files for Babeltrace libraries.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe bibliotek Babeltrace.
53
54 %package static
55 Summary:        Static Babeltrace libraries
56 Summary(pl.UTF-8):      Statyczne biblioteki Babeltrace
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static Babeltrace libraries.
62
63 %description static -l pl.UTF-8
64 Statyczne biblioteki Babeltrace.
65
66 %package -n python3-babeltrace
67 Summary:        Python 3 binding to Babeltrace library
68 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki Babeltrace
69 Group:          Libraries/Python
70 Requires:       %{name} = %{version}-%{release}
71 Obsoletes:      python-babeltrace < 1.5.3
72
73 %description -n python3-babeltrace
74 Python 3 binding to Babeltrace library.
75
76 %description -n python3-babeltrace -l pl.UTF-8
77 Wiązanie Pythona 3 do biblioteki Babeltrace.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{?with_python:--enable-python-bindings} \
91         --disable-silent-rules
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 # lib*.la kept - no .pc files for individual libraries
101
102 # packaged as %doc
103 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/babeltrace
104
105 %if %{with python}
106 %py_postclean
107 %endif
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc ChangeLog LICENSE README std-ext-lib.txt
118 %attr(755,root,root) %{_bindir}/babeltrace
119 %attr(755,root,root) %{_bindir}/babeltrace-log
120 %attr(755,root,root) %{_libdir}/libbabeltrace.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace.so.1
122 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf.so.1
124 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-metadata.so.1
126 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-ctf-text.so.1
128 %attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-dummy.so.1
130 %attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libbabeltrace-lttng-live.so.1
132 %{_mandir}/man1/babeltrace.1*
133 %{_mandir}/man1/babeltrace-log.1*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %doc doc/{API,development}.txt
138 %attr(755,root,root) %{_libdir}/libbabeltrace.so
139 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf.so
140 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-metadata.so
141 %attr(755,root,root) %{_libdir}/libbabeltrace-ctf-text.so
142 %attr(755,root,root) %{_libdir}/libbabeltrace-dummy.so
143 %attr(755,root,root) %{_libdir}/libbabeltrace-lttng-live.so
144 %{_libdir}/libbabeltrace.la
145 %{_libdir}/libbabeltrace-ctf.la
146 %{_libdir}/libbabeltrace-ctf-metadata.la
147 %{_libdir}/libbabeltrace-ctf-text.la
148 %{_libdir}/libbabeltrace-dummy.la
149 %{_libdir}/libbabeltrace-lttng-live.la
150 %{_includedir}/babeltrace
151 %{_pkgconfigdir}/babeltrace.pc
152 %{_pkgconfigdir}/babeltrace-ctf.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libbabeltrace.a
157 %{_libdir}/libbabeltrace-ctf.a
158 %{_libdir}/libbabeltrace-ctf-metadata.a
159 %{_libdir}/libbabeltrace-ctf-text.a
160 %{_libdir}/libbabeltrace-dummy.a
161 %{_libdir}/libbabeltrace-lttng-live.a
162
163 %if %{with python}
164 %files -n python3-babeltrace
165 %defattr(644,root,root,755)
166 %dir %{py3_sitedir}/babeltrace
167 %attr(755,root,root) %{py3_sitedir}/babeltrace/_babeltrace.cpython-*.so
168 %{py3_sitedir}/babeltrace/*.py
169 %{py3_sitedir}/babeltrace/__pycache__
170 %{py3_sitedir}/babeltrace-%{version}-py*.egg-info
171 %endif
This page took 0.065534 seconds and 3 git commands to generate.