]> git.pld-linux.org Git - packages/avogadro.git/blob - avogadro.spec
- missing BRs
[packages/avogadro.git] / avogadro.spec
1
2 %define         qtver   4.7.0
3
4 Summary:        An advanced molecular editor for chemical purposes
5 Name:           avogadro
6 Version:        1.0.1
7 Release:        4
8 License:        GPL v2
9 Group:          Applications/Editors
10 Source0:        http://downloads.sourceforge.net/avogadro/%{name}-%{version}.tar.bz2
11 # Source0-md5:  0d5c391197101f0aab7be6b59f81e6fd
12 # fix build with sip 4.10
13 URL:            http://avogadro.openmolecules.net/
14 Patch0:         %{name}-python2.7.patch
15 Patch1:         %{name}-linguist.patch
16 Patch2:         %{name}-cmake.patch
17 Patch3:         %{name}-sipfix.patch
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtOpenGL-devel
20 BuildRequires:  boost-devel >= 1.35
21 BuildRequires:  boost-python-devel
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  desktop-file-utils
24 BuildRequires:  docbook-utils
25 BuildRequires:  eigen >= 1:2.0.12
26 BuildRequires:  glew-devel >= 1.5.0
27 BuildRequires:  python-numpy-devel
28 BuildRequires:  openbabel-devel >= 2.2.2
29 BuildRequires:  qt4-build >= %{qtver}
30 BuildRequires:  qt4-qmake >= %{qtver}
31 BuildRequires:  sip
32 Requires:       %{name}-libs = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 An advanced molecular editor designed for cross-platform use in
37 computational chemistry, molecular modeling, bioinformatics, materials
38 science, and related areas, which offers flexible rendering and a
39 powerful plugin architecture.
40
41 %package libs
42 Summary:        Shared libraries for Avogadro
43 Group:          Libraries
44
45 %description libs
46 This package contains the shared libraries for the molecular editor
47 Avogadro.
48
49 %package devel
50 Summary:        Development files for Avogadro
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{version}-%{release}
53
54 %description devel
55 This package contains files to develop applications using Avogadros
56 libraries.
57
58 %prep
59 %setup -q
60 %patch0 -p0
61 %patch1 -p0
62 %patch2 -p1
63 %patch3 -p0
64
65 %build
66 install -d build
67 cd build
68 %cmake \
69         -DENABLE_GLSL=ON \
70         -DENABLE_PYTHON=ON \
71         -DENABLE_UPDATE_CHECKER=OFF \
72         -DCMAKE_BUILD_TYPE=Release \
73         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
74         -DLIB_INSTALL_DIR=%{_libdir} \
75         ..
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %{__make} -C build install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %post libs -p /sbin/ldconfig
85 %postun libs -p /sbin/ldconfig
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ChangeLog COPYING
93 %attr(755,root,root) %{_bindir}/%{name}
94 %{_datadir}/%{name}
95 %{_pixmapsdir}/%{name}-icon.png
96 %{_desktopdir}/%{name}.desktop
97
98 %files devel
99 %defattr(644,root,root,755)
100 %{_datadir}/lib%{name}
101 %{_includedir}/%{name}
102 %{_libdir}/*.so
103
104 %files libs
105 %defattr(644,root,root,755)
106 %{_datadir}/python*/site-packages/Avogadro.so
107 %{_libdir}/%{name}
108 %attr(755,root,root) %{_libdir}/*.so.*
This page took 0.097107 seconds and 4 git commands to generate.