]> git.pld-linux.org Git - packages/autopano-sift-C.git/blame - autopano-sift-C.spec
- release 2 (by relup.sh)
[packages/autopano-sift-C.git] / autopano-sift-C.spec
CommitLineData
5acd426d
JB
1Summary: SIFT Feature Detection implementation
2Summary(pl.UTF-8): Implementacja algorytmu SIFT do wykrywania cech obrazu
3Name: autopano-sift-C
8e2f2340 4Version: 2.5.1
64efd0b5 5Release: 2
5acd426d
JB
6License: GPL v2, but SIFT algorithm may require license in some countries
7Group: Applications/Graphics
2d26cd0c 8Source0: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.gz
8e2f2340 9# Source0-md5: b9bade07e8c4f2ea383c22a082c260e0
49ae84e7 10Patch0: link.patch
5acd426d 11URL: http://wiki.panotools.org/Autopano-sift-C
2d26cd0c 12BuildRequires: cmake >= 2.4
5acd426d
JB
13BuildRequires: libjpeg-devel
14BuildRequires: libpano13-devel
15BuildRequires: libpng-devel
16BuildRequires: libtiff-devel
17BuildRequires: libstdc++-devel
18BuildRequires: libxml2-devel >= 2.0
19BuildRequires: pkgconfig
783ecf8a 20BuildRequires: rpmbuild(macros) >= 1.471
5acd426d
JB
21BuildRequires: sed >= 4.0
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25The SIFT algorithm provides the capability to identify key feature
26points within arbitrary images. It further extracts highly distinct
27information for each such point and allows to characterize the point
28invariant to a number of modifications to the image. It is invariant
29to contrast/brightness changes, to rotation, scaling and partially
30invariant to other kinds of transformations. The algorithm can be
31flexibly used to create input data for image matching, object
32identification and other computer vision related algorithms.
33
34autopano-sift-C is a C port of the C# software autopano-sift. It is
35somewhat faster and doesn't require a C# runtime. Additionally,
36autopano-sift-C has experimental modifications to perform feature
37identification in conformal image space, this helps with wide angle or
38fisheye Projection photographs.
39
40%description -l pl.UTF-8
41Algorytm SIFT daje możliwość określenia kluczowych punktów
42charakterystycznych na dowolnych zdjęciach. Następnie wydobywa
43informacje wyodrębniające dla każdego takiego punktu i pozwala
44scharakteryzować ten punkt niezależnie od liczby modyfikacji obrazu.
45Jest niezależny od zmian kontrastu/jasności, obrotów, skalowania i
46częściowo niezależny od innych rodzajów przekształceń. Algorytm może
47być elastycznie używany do tworzenia danych wejściowych do
48dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
49związanych z grafiką komputerową.
50
51autopano-sift-C to port C programu autopano-sift napisanego w C#.
52Jest nieco szybszy i nie wymaga środowiska uruchomieniowego C#.
53Ponadto zawiera nieco eksperymentalnych modyfikacji w celu
54przeprowadzania identyfikacji punktów w wiernokątnej przestrzeni
55obrazu, co pomaga przy zdjęciach obiektywami szerokokątnymi lub
56"rybim okiem".
57
58%prep
59%setup -q
49ae84e7 60%patch0 -p1
5acd426d 61
5acd426d
JB
62%build
63install -d build
64cd build
65# CMAKE_AR is a hack, cmake is unable to find it otherwise :/
66%cmake .. \
67 -DCMAKE_AR=/usr/bin/ar \
2d26cd0c
JB
68 -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:Release} \
69 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
70 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
5acd426d
JB
71 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
72 -DCMAKE_VERBOSE_MAKEFILE=ON \
1dc4f262 73%if "%{_lib}" == "lib64"
cdde2c4d 74 -DLIB_SUFFIX=64
5acd426d
JB
75%endif
76
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%{__make} -C build install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85# resolve conflict with autopano-sift
86mv $RPM_BUILD_ROOT%{_mandir}/man1/autopano{,-c}.1
87mv $RPM_BUILD_ROOT%{_mandir}/man1/generatekeys{,-c}.1
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
94%doc ChangeLog README README.1ST
95%attr(755,root,root) %{_bindir}/autopano
96%attr(755,root,root) %{_bindir}/autopano-c-complete.sh
97%attr(755,root,root) %{_bindir}/autopano-sift-c
98%attr(755,root,root) %{_bindir}/generatekeys
99%{_mandir}/man1/autopano-c.1*
100%{_mandir}/man1/autopano-c-complete.1*
101%{_mandir}/man1/generatekeys-c.1*
102%{_mandir}/man7/autopano-sift-c.7*
This page took 0.084697 seconds and 4 git commands to generate.