]> git.pld-linux.org Git - packages/autopano-sift-C.git/blame - autopano-sift-C.spec
- use Release build type (pass appropriate C_FLAGS and CXX_FLAGS to cmake - both...
[packages/autopano-sift-C.git] / autopano-sift-C.spec
CommitLineData
5acd426d
JB
1Summary: SIFT Feature Detection implementation
2Summary(pl.UTF-8): Implementacja algorytmu SIFT do wykrywania cech obrazu
3Name: autopano-sift-C
8e2f2340 4Version: 2.5.1
5acd426d
JB
5Release: 1
6License: GPL v2, but SIFT algorithm may require license in some countries
7Group: Applications/Graphics
2d26cd0c 8Source0: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.gz
8e2f2340 9# Source0-md5: b9bade07e8c4f2ea383c22a082c260e0
5acd426d 10URL: http://wiki.panotools.org/Autopano-sift-C
2d26cd0c 11BuildRequires: cmake >= 2.4
5acd426d
JB
12BuildRequires: libjpeg-devel
13BuildRequires: libpano13-devel
14BuildRequires: libpng-devel
15BuildRequires: libtiff-devel
16BuildRequires: libstdc++-devel
17BuildRequires: libxml2-devel >= 2.0
18BuildRequires: pkgconfig
783ecf8a 19BuildRequires: rpmbuild(macros) >= 1.471
5acd426d
JB
20BuildRequires: sed >= 4.0
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The SIFT algorithm provides the capability to identify key feature
25points within arbitrary images. It further extracts highly distinct
26information for each such point and allows to characterize the point
27invariant to a number of modifications to the image. It is invariant
28to contrast/brightness changes, to rotation, scaling and partially
29invariant to other kinds of transformations. The algorithm can be
30flexibly used to create input data for image matching, object
31identification and other computer vision related algorithms.
32
33autopano-sift-C is a C port of the C# software autopano-sift. It is
34somewhat faster and doesn't require a C# runtime. Additionally,
35autopano-sift-C has experimental modifications to perform feature
36identification in conformal image space, this helps with wide angle or
37fisheye Projection photographs.
38
39%description -l pl.UTF-8
40Algorytm SIFT daje możliwość określenia kluczowych punktów
41charakterystycznych na dowolnych zdjęciach. Następnie wydobywa
42informacje wyodrębniające dla każdego takiego punktu i pozwala
43scharakteryzować ten punkt niezależnie od liczby modyfikacji obrazu.
44Jest niezależny od zmian kontrastu/jasności, obrotów, skalowania i
45częściowo niezależny od innych rodzajów przekształceń. Algorytm może
46być elastycznie używany do tworzenia danych wejściowych do
47dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
48związanych z grafiką komputerową.
49
50autopano-sift-C to port C programu autopano-sift napisanego w C#.
51Jest nieco szybszy i nie wymaga środowiska uruchomieniowego C#.
52Ponadto zawiera nieco eksperymentalnych modyfikacji w celu
53przeprowadzania identyfikacji punktów w wiernokątnej przestrzeni
54obrazu, co pomaga przy zdjęciach obiektywami szerokokątnymi lub
55"rybim okiem".
56
57%prep
58%setup -q
59
5acd426d
JB
60%build
61install -d build
62cd build
63# CMAKE_AR is a hack, cmake is unable to find it otherwise :/
64%cmake .. \
65 -DCMAKE_AR=/usr/bin/ar \
2d26cd0c
JB
66 -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:Release} \
67 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
68 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
5acd426d
JB
69 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
70 -DCMAKE_VERBOSE_MAKEFILE=ON \
1dc4f262 71%if "%{_lib}" == "lib64"
cdde2c4d 72 -DLIB_SUFFIX=64
5acd426d
JB
73%endif
74
75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__make} -C build install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83# resolve conflict with autopano-sift
84mv $RPM_BUILD_ROOT%{_mandir}/man1/autopano{,-c}.1
85mv $RPM_BUILD_ROOT%{_mandir}/man1/generatekeys{,-c}.1
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
92%doc ChangeLog README README.1ST
93%attr(755,root,root) %{_bindir}/autopano
94%attr(755,root,root) %{_bindir}/autopano-c-complete.sh
95%attr(755,root,root) %{_bindir}/autopano-sift-c
96%attr(755,root,root) %{_bindir}/generatekeys
97%{_mandir}/man1/autopano-c.1*
98%{_mandir}/man1/autopano-c-complete.1*
99%{_mandir}/man1/generatekeys-c.1*
100%{_mandir}/man7/autopano-sift-c.7*
This page took 0.073927 seconds and 4 git commands to generate.