]> git.pld-linux.org Git - packages/autopano-sift-C.git/blame - autopano-sift-C.spec
- oops, typo
[packages/autopano-sift-C.git] / autopano-sift-C.spec
CommitLineData
5acd426d
JB
1Summary: SIFT Feature Detection implementation
2Summary(pl.UTF-8): Implementacja algorytmu SIFT do wykrywania cech obrazu
3Name: autopano-sift-C
4Version: 2.5.0
5Release: 1
6License: GPL v2, but SIFT algorithm may require license in some countries
7Group: Applications/Graphics
8Source0: http://dl.sourceforge.net/hugin/%{name}-%{version}.tar.gz
9# Source0-md5: d4e6bfab53fe227a36eec4c94c0bbfe6
10URL: http://wiki.panotools.org/Autopano-sift-C
11BuildRequires: cmake
12BuildRequires: libjpeg-devel
13BuildRequires: libpano13-devel
14BuildRequires: libpng-devel
15BuildRequires: libtiff-devel
16BuildRequires: libstdc++-devel
17BuildRequires: libxml2-devel >= 2.0
18BuildRequires: pkgconfig
19BuildRequires: sed >= 4.0
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23The SIFT algorithm provides the capability to identify key feature
24points within arbitrary images. It further extracts highly distinct
25information for each such point and allows to characterize the point
26invariant to a number of modifications to the image. It is invariant
27to contrast/brightness changes, to rotation, scaling and partially
28invariant to other kinds of transformations. The algorithm can be
29flexibly used to create input data for image matching, object
30identification and other computer vision related algorithms.
31
32autopano-sift-C is a C port of the C# software autopano-sift. It is
33somewhat faster and doesn't require a C# runtime. Additionally,
34autopano-sift-C has experimental modifications to perform feature
35identification in conformal image space, this helps with wide angle or
36fisheye Projection photographs.
37
38%description -l pl.UTF-8
39Algorytm SIFT daje możliwość określenia kluczowych punktów
40charakterystycznych na dowolnych zdjęciach. Następnie wydobywa
41informacje wyodrębniające dla każdego takiego punktu i pozwala
42scharakteryzować ten punkt niezależnie od liczby modyfikacji obrazu.
43Jest niezależny od zmian kontrastu/jasności, obrotów, skalowania i
44częściowo niezależny od innych rodzajów przekształceń. Algorytm może
45być elastycznie używany do tworzenia danych wejściowych do
46dopasowywania obrazów, identyfikowania obiektów i innych algorytmów
47związanych z grafiką komputerową.
48
49autopano-sift-C to port C programu autopano-sift napisanego w C#.
50Jest nieco szybszy i nie wymaga środowiska uruchomieniowego C#.
51Ponadto zawiera nieco eksperymentalnych modyfikacji w celu
52przeprowadzania identyfikacji punktów w wiernokątnej przestrzeni
53obrazu, co pomaga przy zdjęciach obiektywami szerokokątnymi lub
54"rybim okiem".
55
56%prep
57%setup -q
58
59# don't override our optflags with cmake-predefined values
60sed -i 's/NOT CMAKE_BUILD_TYPE/GFY/' CMakeLists.txt
61
62%build
63install -d build
64cd build
65# CMAKE_AR is a hack, cmake is unable to find it otherwise :/
66%cmake .. \
67 -DCMAKE_AR=/usr/bin/ar \
68 %{?debug:-DCMAKE_BUILD_TYPE=Debug} \
69 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
70 -DCMAKE_VERBOSE_MAKEFILE=ON \
71%if "%{_lib}" == "64"
cdde2c4d 72 -DLIB_SUFFIX=64
5acd426d
JB
73%endif
74
75%{__make}
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__make} -C build install \
81 DESTDIR=$RPM_BUILD_ROOT
82
83# resolve conflict with autopano-sift
84mv $RPM_BUILD_ROOT%{_mandir}/man1/autopano{,-c}.1
85mv $RPM_BUILD_ROOT%{_mandir}/man1/generatekeys{,-c}.1
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(644,root,root,755)
92%doc ChangeLog README README.1ST
93%attr(755,root,root) %{_bindir}/autopano
94%attr(755,root,root) %{_bindir}/autopano-c-complete.sh
95%attr(755,root,root) %{_bindir}/autopano-sift-c
96%attr(755,root,root) %{_bindir}/generatekeys
97%{_mandir}/man1/autopano-c.1*
98%{_mandir}/man1/autopano-c-complete.1*
99%{_mandir}/man1/generatekeys-c.1*
100%{_mandir}/man7/autopano-sift-c.7*
This page took 0.073704 seconds and 4 git commands to generate.