]> git.pld-linux.org Git - packages/autogen.git/blob - autogen.spec
- verbose files, fix scripts perms
[packages/autogen.git] / autogen.spec
1 Summary:        Automated program generator
2 Summary(pl.UTF-8):      Zautomatyzowany generator programów
3 Name:           autogen
4 Version:        5.18.4
5 Release:        2
6 License:        GPL v3+ (AutoGen), LGPL v2+ (genshell), LGPL v3+ or Modified BSD (AutoOpts library)
7 Group:          Development/Tools
8 Source0:        http://ftp.gnu.org/gnu/autogen/rel%{version}/%{name}-%{version}.tar.xz
9 # Source0-md5:  5171f4a7414adb85b7b25e8438791758
10 Patch0:         %{name}-notinstalled.patch
11 Patch1:         %{name}-info.patch
12 URL:            http://autogen.sourceforge.net/
13 BuildRequires:  guile-devel
14 BuildRequires:  libltdl-devel
15 BuildRequires:  libxml2-devel
16 BuildRequires:  tar >= 1:1.22
17 BuildRequires:  texinfo
18 BuildRequires:  xz
19 Requires:       %{name}-libs = %{version}-%{release}
20 Suggests:       %{name}-devel = %{version}-%{release}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 AutoGen is a tool designed for generating program files that contain
25 repetitive text with varied substitutions. Its goal is to simplify the
26 maintenance of programs that contain large amounts of repetitious
27 text. This is especially valuable if there are several blocks of such
28 text that must be kept synchronized in parallel tables.
29
30 %description -l pl.UTF-8
31 AutoGen to narzędzie zaprojektowane do generowania plików programów
32 zawierających powtarzający się tekst z różnymi podstawieniami. Celem
33 projektu jest uproszczenie zarządzania programów zawierających duże
34 ilości powtórzonego tekstu. Jest szczególnie wartościowy jeśli jest
35 kilka bloków takiego tekstu, które muszą być synchronizowane
36 równolegle.
37
38 %package libs
39 Summary:        Shared AutoOpts library
40 Summary(pl.UTF-8):      Biblioteka współdzielona AutoOpts
41 License:        LGPL v3+ or Modified BSD
42 Group:          Libraries
43 Conflicts:      autogen < 5.14
44
45 %description libs
46 Shared AutoOpts library.
47
48 %description libs -l pl.UTF-8
49 Biblioteka współdzielona AutoOpts.
50
51 %package devel
52 Summary:        Header files for AutoOpts library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AutoOpts
54 License:        LGPL v3+ or Modified BSD
55 Group:          Development/Libraries
56 Requires:       %{name}-libs = %{version}-%{release}
57
58 %description devel
59 Header files for AutoOpts library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki AutoOpts.
63
64 %package static
65 Summary:        Static AutoOpts library
66 Summary(pl.UTF-8):      Statyczna biblioteka AutoOpts
67 License:        LGPL v3+ or Modified BSD
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static AutoOpts library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka AutoOpts.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81
82 %build
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # .pc file is arch-dependent, so use arch-dependent pkgconfigdir
94 mv $RPM_BUILD_ROOT%{_datadir}/pkgconfig/autoopts.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
101
102 %postun
103 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
104
105 %post   libs -p /sbin/ldconfig
106 %postun libs -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README THANKS TODO
111 %attr(755,root,root) %{_bindir}/autogen
112 %attr(755,root,root) %{_bindir}/columns
113 %attr(755,root,root) %{_bindir}/getdefs
114 %attr(755,root,root) %{_bindir}/xml2ag
115 %dir %{_datadir}/%{name}
116 %{_datadir}/%{name}/*.def
117 %{_datadir}/%{name}/*.lic
118 %{_datadir}/%{name}/*.m4
119 %{_datadir}/%{name}/*.pm
120 %{_datadir}/%{name}/*.tlib
121 %{_datadir}/%{name}/*.tpl
122 %attr(755,root,root) %{_datadir}/%{name}/man2man
123 %attr(755,root,root) %{_datadir}/%{name}/man2mdoc
124 %attr(755,root,root) %{_datadir}/%{name}/man2texi
125 %attr(755,root,root) %{_datadir}/%{name}/mdoc2man
126 %attr(755,root,root) %{_datadir}/%{name}/mdoc2mdoc
127 %attr(755,root,root) %{_datadir}/%{name}/mdoc2texi
128 %attr(755,root,root) %{_datadir}/%{name}/texi2man
129 %attr(755,root,root) %{_datadir}/%{name}/texi2mdoc
130 %attr(755,root,root) %{_datadir}/%{name}/texi2texi
131 %{_infodir}/autogen.info*
132 %{_mandir}/man1/autogen.1*
133 %{_mandir}/man1/columns.1*
134 %{_mandir}/man1/getdefs.1*
135 %{_mandir}/man1/xml2ag.1*
136
137 %files libs
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libopts.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libopts.so.25
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/autoopts-config
145 %attr(755,root,root) %{_libdir}/libopts.so
146 %{_libdir}/libopts.la
147 %{_includedir}/autoopts
148 %{_aclocaldir}/autoopts.m4
149 %{_pkgconfigdir}/autoopts.pc
150 %{_mandir}/man1/autoopts-config.1*
151 %{_mandir}/man3/ao_string_tokenize.3*
152 %{_mandir}/man3/configFileLoad.3*
153 %{_mandir}/man3/option*.3*
154 %{_mandir}/man3/str*.3*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libopts.a
This page took 0.136452 seconds and 3 git commands to generate.