]> git.pld-linux.org Git - packages/attica.git/blob - attica.spec
- rel 2
[packages/attica.git] / attica.spec
1 #
2 # Conditional build:
3 #
4 %define         qt_ver          4.6.1
5 %define         snap            svn1060455
6
7 Summary:        Attica Library - implementation of Open Collaboration Services API for Qt
8 Summary(pl.UTF-8):      Attica Library - implementacja API Serwisów Otwartej Współpracy dla Qt
9 Name:           attica
10 Version:        0.1.2
11 Release:        2
12 License:        GPL
13 Group:          X11/Libraries
14 # svn co svn://anonsvn.kde.org/home/kde/trunk/kdesupport/attica/
15 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
16 Source0:        ftp://ftp.kde.org/pub/kde/stable/attica/%{name}-%{version}.tar.bz2
17 # Source0-md5:  8b4207dbc0a826d422632bdb9c50d51a
18 URL:            http://kde.org
19 BuildRequires:  QtCore-devel >= %{qt_ver}
20 BuildRequires:  QtGui-devel >= %{qt_ver}
21 BuildRequires:  QtNetwork-devel >= %{qt_ver}
22 BuildRequires:  QtXml-devel >= %{qt_ver}
23 BuildRequires:  automoc4 >= 0.9.84
24 BuildRequires:  cmake >= 2.6.1-2
25 BuildRequires:  qt4-build >= %{qt_ver}
26 BuildRequires:  qt4-qmake >= %{qt_ver}
27 BuildRequires:  rpmbuild(macros) >= 1.293
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Attica is a Qt library that implements the Open Collaboration Services API.
32 It grants easy access to the services such as querying information about persons and contents.
33
34 %description -l pl.UTF-8
35 Attica jest biblioteką Qt, która implementuje API Serwisów Otwartej Współpracy.
36 Pozwala na łatwy dostęp do serwisów takich jak zapytania o informacje o osobach i treściach.
37
38 %package devel
39 Summary:        Header files for attica library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki attica
41 Group:          Development/Libraries
42 Requires:      %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for attica library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki attica.
49
50 %prep
51 %setup -q
52
53 %build
54 install -d build
55 cd build
56 %cmake .. \
57         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
58         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
59 %if "%{_lib}" == "lib64"
60         -DLIB_SUFFIX=64
61 %endif
62
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} -C build install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p      /sbin/ldconfig
75 %postun -p      /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %ghost %{_libdir}/libattica.so.?
80 %attr(755,root,root) %{_libdir}/libattica.so.*.*.*
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libattica.so
85 %{_includedir}/attica
86 %{_libdir}/pkgconfig/libattica.pc
This page took 1.810198 seconds and 3 git commands to generate.