]> git.pld-linux.org Git - packages/at-spi.git/blob - at-spi.spec
- 1.20.0
[packages/at-spi.git] / at-spi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Assistive Technology Service Provider Interface
6 Summary(pl.UTF-8):      Interfejs pozwalający na korzystanie z urządzeń wspomagających
7 Name:           at-spi
8 Version:        1.20.0
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.20/%{name}-%{version}.tar.bz2
13 # Source0-md5:  fd1f916463f379b435399e2b2075742f
14 URL:            http://developer.gnome.org/projects/gap/
15 BuildRequires:  ORBit2-devel >= 2.14.8
16 BuildRequires:  atk-devel >= 1:1.20.0
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gail-devel >= 1.20.0
20 BuildRequires:  gnome-common >= 2.18.0
21 BuildRequires:  gtk+2-devel >= 2:2.10.14
22 BuildRequires:  gtk-doc >= 1.8
23 BuildRequires:  intltool >= 0.35.5
24 BuildRequires:  libbonobo-devel >= 2.18.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 BuildRequires:  rpm-build >= 4.1-10
29 BuildRequires:  xorg-lib-libXevie-devel
30 BuildRequires:  xorg-lib-libXft-devel >= 2.1
31 BuildRequires:  xorg-lib-libXtst-devel
32 Obsoletes:      libat-spi1
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 at-spi allows assistive technologies to access GTK-based applications.
37 Essentially it exposes the internals of applications for automation,
38 so tools such as screen readers, magnifiers, or even scripting
39 interfaces can query and interact with GUI controls.
40
41 %description -l pl.UTF-8
42 at-spi pozwala na korzystanie z urządzeń wspomagających w celu dostępu
43 do aplikacji bazujących na GTK. Przede wszystkim udostępnia wewnętrzne
44 interfejsy aplikacji dla automatyzacji, więc urządzenia takie jak
45 czytniki ekranu, lupy, czy nawet interfejsy skryptowe mogą odpytywać i
46 współpracować z kontrolkami interfejsu graficznego.
47
48 %package devel
49 Summary:        at-spi development files
50 Summary(pl.UTF-8):      Pliki programistyczne at-spi
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       ORBit2-devel >= 2.14.7
54 Requires:       atk-devel >= 1:1.18.0
55 Requires:       gail-devel >= 1.18.0
56 Requires:       gtk+2-devel >= 2:2.10.10
57 Requires:       libbonobo-devel >= 2.18.0
58 Obsoletes:      libat-spi1-devel
59
60 %description devel
61 at-spi development files.
62
63 %description devel -l pl.UTF-8
64 Pliki programistyczne at-spi.
65
66 %package static
67 Summary:        at-spi static library
68 Summary(pl.UTF-8):      Statyczna biblioteka at-spi
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 at-spi static library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka at-spi.
77
78 %package apidocs
79 Summary:        at-spi API documentation
80 Summary(pl.UTF-8):      Dokumentacja API at-spi
81 Group:          Documentation
82 Requires:       gtk-doc-common
83
84 %description apidocs
85 at-spi API documentation.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API at-spi.
89
90 %prep
91 %setup -q
92
93 %build
94 %{__glib_gettextize}
95 %{__intltoolize}
96 %{__libtoolize}
97 %{__aclocal}
98 %{__automake}
99 %{__autoconf}
100 %configure \
101         %{!?with_static_libs:--disable-static} \
102         --enable-gtk-doc \
103         --enable-static \
104         --with-html-dir=%{_gtkdocdir}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         HTML_DIR=%{_gtkdocdir}
113
114 # no static modules
115 rm -f $RPM_BUILD_ROOT%{_libdir}/{gtk-2.0/modules,orbit-2.0}/*.{la,a}
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/lib*.so.*.*
128 %attr(755,root,root) %{_libdir}/at-spi-registryd
129 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so
130 %attr(755,root,root) %{_libdir}/gtk-2.0/modules/lib*.so
131 %{_libdir}/bonobo/servers/*
132 %{_datadir}/idl/*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %{_includedir}/*
137 %attr(755,root,root) %{_libdir}/lib*.so
138 %{_libdir}/lib*.la
139 %{_pkgconfigdir}/*
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/*.a
145 %endif
146
147 %files apidocs
148 %defattr(644,root,root,755)
149 %{_gtkdocdir}/*
150 %{_docdir}/%{name}-%{version}
This page took 0.086005 seconds and 3 git commands to generate.