]> git.pld-linux.org Git - packages/apr.git/blob - apr.spec
- use fdflags not flags for consistency
[packages/apr.git] / apr.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform make test
4 #
5 Summary:        Apache Portable Runtime
6 Summary(pl.UTF-8):      Apache Portable Runtime - przenośna biblioteka uruchomieniowa
7 Name:           apr
8 Version:        1.3.3
9 Release:        12
10 Epoch:          1
11 License:        Apache v2.0
12 Group:          Libraries
13 Source0:        http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
14 # Source0-md5:  2090c21dee4f0eb1512604127dcd158f
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-metuxmpm.patch
17 Patch2:         %{name}-libtool.patch
18 Patch3:         %{name}-bug-46425.patch
19 URL:            http://apr.apache.org/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  glibc-devel >= 6:2.9
23 %if "%{pld_release}" != "ac"
24 BuildRequires:  libtool >= 2:2.2
25 %else
26 BuildRequires:  libtool
27 %endif
28 BuildRequires:  libuuid-devel
29 BuildRequires:  python
30 BuildRequires:  rpm >= 4.4.9-56
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  sed >= 4.0
33 %if "%{pld_release}" != "ac"
34 BuildRequires:  uname(release) >= 2.6
35 Requires:       uname(release) >= 2.6.13
36 %endif
37 # uuid.h misdetected from this one instead of libuuid-devel
38 BuildConflicts: ossp-uuid-devel < 1.6.2-6
39 Conflicts:      kernel24
40 Conflicts:      kernel24-smp
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _includedir     /usr/include/apr
44 %define         _datadir        /usr/share/apr
45
46 %description
47 The mission of the Apache Portable Runtime (APR) project is to create
48 and maintain software libraries that provide a predictable and
49 consistent interface to underlying platform-specific implementations.
50 The primary goal is to provide an API to which software developers may
51 code and be assured of predictable if not identical behaviour
52 regardless of the platform on which their software is built, relieving
53 them of the need to code special-case conditions to work around or
54 take advantage of platform-specific deficiencies or features.
55
56 %description -l pl.UTF-8
57 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
58 utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
59 interfejsu do leżących u podstaw implementacji zależnych od platformy.
60 Głównym celem jest dostarczenie API, którego mogą używać programiści
61 mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
62 identyczny, niezależnie od platformy na jakiej oprogramowanie jest
63 budowane oraz bez potrzeby kodowania specjalnych warunków do
64 obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
65 możliwości.
66
67 %package devel
68 Summary:        Header files and development documentation for apr
69 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty do apr
70 Group:          Development/Libraries
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72 Requires:       automake
73 %if "%{pld_release}" != "ac"
74 Requires:       libtool >= 2:2.2
75 %else
76 Requires:       libtool
77 %endif
78 Requires:       libuuid-devel
79 Requires:       python-modules
80
81 %description devel
82 Header files and development documentation for apr.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe i dokumentacja programisty do apr.
86
87 %package static
88 Summary:        Static apr library
89 Summary(pl.UTF-8):      Statyczna biblioteka apr
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
92
93 %description static
94 Static apr library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka apr.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104 %patch3 -p1
105
106 cat >> config.layout <<'EOF'
107 <Layout PLD>
108 sbindir:        %{_sbindir}
109 libexecdir:     %{_libdir}/apr
110 installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
111 localstatedir:  /var/run
112 runtimedir:     /var/run
113 libsuffix:      -${APR_MAJOR_VERSION}
114 </Layout>
115 EOF
116
117 %build
118 install /usr/share/automake/config.* build
119 %{__autoconf}
120
121 %configure \
122         --enable-layout=PLD \
123 %ifarch %{ix86} %{x8664}
124 %ifnarch i386
125         --enable-nonportable-atomics \
126 %endif
127 %endif
128         --enable-threads \
129         --with-devrandom=/dev/urandom
130 %{__make}
131
132 %{?with_tests:%{__make} -j1 test}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
141 install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
142 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
143 if [ -f /usr/share/libtool/config/ltmain.sh ]; then
144         ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
145 else
146         ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
147 fi
148 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
149 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
150
151 sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
152         $RPM_BUILD_ROOT%{_bindir}/apr-1-config
153 sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
154         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
155 sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc CHANGES docs/*.html
166 %attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/apr-1-config
172 %attr(755,root,root) %{_libdir}/libapr-1.so
173 %{_libdir}/libapr-1.la
174 %{_libdir}/apr.exp
175 %{_includedir}
176 %dir %{_datadir}
177 %dir %{_datadir}/build
178 %{_datadir}/build/*.mk
179 %{_datadir}/build/*.m4
180 %{_datadir}/build/*.awk
181 %attr(755,root,root) %{_datadir}/build/config.*
182 %attr(755,root,root) %{_datadir}/build/*.sh
183 %attr(755,root,root) %{_datadir}/build/libtool
184 %attr(755,root,root) %{_datadir}/build/gen-build.py
185 %{_datadir}/build-1
186 %{_pkgconfigdir}/apr-1.pc
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libapr-1.a
This page took 0.105801 seconds and 3 git commands to generate.