]> git.pld-linux.org Git - packages/apr.git/blame - apr.spec
- use fdflags not flags for consistency
[packages/apr.git] / apr.spec
CommitLineData
c4dbb403
JB
1#
2# Conditional build:
3%bcond_with tests # perform make test
4#
f3bf17ad 5Summary: Apache Portable Runtime
e51e866d 6Summary(pl.UTF-8): Apache Portable Runtime - przenośna biblioteka uruchomieniowa
f3bf17ad 7Name: apr
d9cfa95e 8Version: 1.3.3
71e8bb94 9Release: 12
f3bf17ad 10Epoch: 1
b34d84ea 11License: Apache v2.0
f3bf17ad 12Group: Libraries
55e3eaa9 13Source0: http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
d9cfa95e 14# Source0-md5: 2090c21dee4f0eb1512604127dcd158f
9e32e98f
JB
15Patch0: %{name}-link.patch
16Patch1: %{name}-metuxmpm.patch
e0b90f27 17Patch2: %{name}-libtool.patch
855204ca 18Patch3: %{name}-bug-46425.patch
f3bf17ad 19URL: http://apr.apache.org/
3c7d7510 20BuildRequires: autoconf >= 2.50
c7edcef5 21BuildRequires: automake
1c519bd4 22BuildRequires: glibc-devel >= 6:2.9
df8efb25 23%if "%{pld_release}" != "ac"
1b25cd0a 24BuildRequires: libtool >= 2:2.2
df8efb25
ER
25%else
26BuildRequires: libtool
27%endif
69f0f35f 28BuildRequires: libuuid-devel
9e32e98f 29BuildRequires: python
df8efb25 30BuildRequires: rpm >= 4.4.9-56
7bac6e65 31BuildRequires: rpm-pythonprov
df8efb25
ER
32BuildRequires: sed >= 4.0
33%if "%{pld_release}" != "ac"
1c519bd4 34BuildRequires: uname(release) >= 2.6
e6b13a24 35Requires: uname(release) >= 2.6.13
df8efb25 36%endif
97865247
AM
37# uuid.h misdetected from this one instead of libuuid-devel
38BuildConflicts: ossp-uuid-devel < 1.6.2-6
52336182
JB
39Conflicts: kernel24
40Conflicts: kernel24-smp
f3bf17ad
AM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%define _includedir /usr/include/apr
44%define _datadir /usr/share/apr
45
46%description
47The mission of the Apache Portable Runtime (APR) project is to create
48and maintain software libraries that provide a predictable and
49consistent interface to underlying platform-specific implementations.
50The primary goal is to provide an API to which software developers may
51code and be assured of predictable if not identical behaviour
52regardless of the platform on which their software is built, relieving
53them of the need to code special-case conditions to work around or
54take advantage of platform-specific deficiencies or features.
55
a79d9376 56%description -l pl.UTF-8
b4838f76 57Celem projektu APR (Apache Portable Runtime) jest stworzenie i
a79d9376
JR
58utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
59interfejsu do leżących u podstaw implementacji zależnych od platformy.
60Głównym celem jest dostarczenie API, którego mogą używać programiści
61mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
62identyczny, niezależnie od platformy na jakiej oprogramowanie jest
63budowane oraz bez potrzeby kodowania specjalnych warunków do
64obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
65możliwości.
b4838f76 66
f3bf17ad 67%package devel
b4838f76 68Summary: Header files and development documentation for apr
e51e866d 69Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja programisty do apr
f3bf17ad 70Group: Development/Libraries
b4838f76 71Requires: %{name} = %{epoch}:%{version}-%{release}
d53f5760 72Requires: automake
df8efb25 73%if "%{pld_release}" != "ac"
1b25cd0a 74Requires: libtool >= 2:2.2
df8efb25
ER
75%else
76Requires: libtool
77%endif
d9cfa95e 78Requires: libuuid-devel
7bac6e65 79Requires: python-modules
f3bf17ad
AM
80
81%description devel
b4838f76
JB
82Header files and development documentation for apr.
83
a79d9376
JR
84%description devel -l pl.UTF-8
85Pliki nagłówkowe i dokumentacja programisty do apr.
f3bf17ad
AM
86
87%package static
88Summary: Static apr library
e51e866d 89Summary(pl.UTF-8): Statyczna biblioteka apr
f3bf17ad 90Group: Development/Libraries
b4838f76 91Requires: %{name}-devel = %{epoch}:%{version}-%{release}
f3bf17ad
AM
92
93%description static
94Static apr library.
95
a79d9376 96%description static -l pl.UTF-8
b4838f76
JB
97Statyczna biblioteka apr.
98
f3bf17ad 99%prep
af4e4c47 100%setup -q
9e32e98f
JB
101%patch0 -p1
102%patch1 -p1
e0b90f27 103%patch2 -p1
7bcdeaec 104%patch3 -p1
f3bf17ad 105
13f3c811
JB
106cat >> config.layout <<'EOF'
107<Layout PLD>
108sbindir: %{_sbindir}
109libexecdir: %{_libdir}/apr
110installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
111localstatedir: /var/run
112runtimedir: /var/run
113libsuffix: -${APR_MAJOR_VERSION}
2523b113 114</Layout>
13f3c811
JB
115EOF
116
f3bf17ad 117%build
b34d84ea 118install /usr/share/automake/config.* build
cb4191bc 119%{__autoconf}
2523b113 120
f3bf17ad 121%configure \
13f3c811 122 --enable-layout=PLD \
3c7d7510 123%ifarch %{ix86} %{x8664}
02a2518a 124%ifnarch i386
125 --enable-nonportable-atomics \
126%endif
127%endif
13f3c811
JB
128 --enable-threads \
129 --with-devrandom=/dev/urandom
f3bf17ad
AM
130%{__make}
131
7bcdeaec
AM
132%{?with_tests:%{__make} -j1 test}
133
f3bf17ad
AM
134%install
135rm -rf $RPM_BUILD_ROOT
136
137%{__make} install \
138 DESTDIR=$RPM_BUILD_ROOT
139
9e32e98f 140mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
16773349 141install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
d53f5760 142ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
d522858e
ER
143if [ -f /usr/share/libtool/config/ltmain.sh ]; then
144 ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
145else
146 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
147fi
d53f5760 148ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
9e32e98f 149ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
8c18c9a9 150
16773349
ER
151sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
152 $RPM_BUILD_ROOT%{_bindir}/apr-1-config
153sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
9e32e98f 154 $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
16773349 155sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
f3bf17ad
AM
156
157%clean
158rm -rf $RPM_BUILD_ROOT
159
b4838f76
JB
160%post -p /sbin/ldconfig
161%postun -p /sbin/ldconfig
162
f3bf17ad
AM
163%files
164%defattr(644,root,root,755)
023f96c0 165%doc CHANGES docs/*.html
7a48bef9
JB
166%attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
167%attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
f3bf17ad
AM
168
169%files devel
170%defattr(644,root,root,755)
7a48bef9
JB
171%attr(755,root,root) %{_bindir}/apr-1-config
172%attr(755,root,root) %{_libdir}/libapr-1.so
173%{_libdir}/libapr-1.la
f3bf17ad
AM
174%{_libdir}/apr.exp
175%{_includedir}
176%dir %{_datadir}
9e32e98f
JB
177%dir %{_datadir}/build
178%{_datadir}/build/*.mk
179%{_datadir}/build/*.m4
180%{_datadir}/build/*.awk
181%attr(755,root,root) %{_datadir}/build/config.*
182%attr(755,root,root) %{_datadir}/build/*.sh
183%attr(755,root,root) %{_datadir}/build/libtool
16773349 184%attr(755,root,root) %{_datadir}/build/gen-build.py
9e32e98f 185%{_datadir}/build-1
af4e4c47 186%{_pkgconfigdir}/apr-1.pc
f3bf17ad
AM
187
188%files static
189%defattr(644,root,root,755)
7a48bef9 190%{_libdir}/libapr-1.a
This page took 0.098616 seconds and 4 git commands to generate.