]> git.pld-linux.org Git - packages/apr-compat.git/blob - apr-compat.spec
- drop obsolete files
[packages/apr-compat.git] / apr-compat.spec
1 # This spec is for kernels < 2.6.27 since apr.spec uses new features
2 Summary:        Apache Portable Runtime
3 Summary(pl.UTF-8):      Apache Portable Runtime - przenośna biblioteka uruchomieniowa
4 Name:           apr-compat
5 Version:        1.3.3
6 Release:        1
7 Epoch:          1
8 License:        Apache v2.0
9 Group:          Libraries
10 Source0:        http://www.apache.org/dist/apr/apr-%{version}.tar.bz2
11 # Source0-md5:  2090c21dee4f0eb1512604127dcd158f
12 Patch0:         apr-link.patch
13 Patch1:         apr-metuxmpm.patch
14 Patch2:         apr-libtool.patch
15 URL:            http://apr.apache.org/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  libuuid-devel
20 BuildRequires:  python
21 BuildRequires:  rpm >= 4.4.9-56
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  uname(release) >= 2.6
25 Requires:       uname(release) >= 2.6
26 Conflicts:      kernel24
27 Conflicts:      kernel24-smp
28 Provides:       apr = %{epoch}:%{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _includedir     /usr/include/apr
32 %define         _datadir        /usr/share/apr
33
34 %description
35 The mission of the Apache Portable Runtime (APR) project is to create
36 and maintain software libraries that provide a predictable and
37 consistent interface to underlying platform-specific implementations.
38 The primary goal is to provide an API to which software developers may
39 code and be assured of predictable if not identical behaviour
40 regardless of the platform on which their software is built, relieving
41 them of the need to code special-case conditions to work around or
42 take advantage of platform-specific deficiencies or features.
43
44 %description -l pl.UTF-8
45 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
46 utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
47 interfejsu do leżących u podstaw implementacji zależnych od platformy.
48 Głównym celem jest dostarczenie API, którego mogą używać programiści
49 mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
50 identyczny, niezależnie od platformy na jakiej oprogramowanie jest
51 budowane oraz bez potrzeby kodowania specjalnych warunków do
52 obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
53 możliwości.
54
55 %package devel
56 Summary:        Header files and development documentation for apr
57 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty do apr
58 Group:          Development/Libraries
59 Requires:       %{name} = %{epoch}:%{version}-%{release}
60 Requires:       automake
61 Requires:       libtool >= 2:2.2
62 Requires:       libuuid-devel
63 Requires:       python-modules
64 Provides:       apr-devel = %{epoch}:%{version}-%{release}
65
66 %description devel
67 Header files and development documentation for apr.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe i dokumentacja programisty do apr.
71
72 %package static
73 Summary:        Static apr library
74 Summary(pl.UTF-8):      Statyczna biblioteka apr
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
77 Provides:       apr-static = %{epoch}:%{version}-%{release}
78
79 %description static
80 Static apr library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka apr.
84
85 %prep
86 %setup -q -n apr-%{version}
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 cat >> config.layout <<'EOF'
92 <Layout PLD>
93 sbindir:        %{_sbindir}
94 libexecdir:     %{_libdir}/apr
95 installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
96 localstatedir:  /var/run
97 runtimedir:     /var/run
98 libsuffix:      -${APR_MAJOR_VERSION}
99 </Layout>
100 EOF
101
102 %build
103 install /usr/share/automake/config.* build
104 %{__autoconf}
105
106 %configure \
107         --enable-layout=PLD \
108 %ifarch %{ix86} %{x8664}
109 %ifnarch i386
110         --enable-nonportable-atomics \
111 %endif
112 %endif
113         --enable-threads \
114         --with-devrandom=/dev/urandom
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
124 install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
125 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
126 if [ -f /usr/share/libtool/config/ltmain.sh ]; then
127         ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
128 else
129         ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
130 fi
131 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
132 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
133
134 sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
135         $RPM_BUILD_ROOT%{_bindir}/apr-1-config
136 sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
137         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
138 sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc CHANGES docs/*.html
149 %attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/apr-1-config
155 %attr(755,root,root) %{_libdir}/libapr-1.so
156 %{_libdir}/libapr-1.la
157 %{_libdir}/apr.exp
158 %{_includedir}
159 %dir %{_datadir}
160 %dir %{_datadir}/build
161 %{_datadir}/build/*.mk
162 %{_datadir}/build/*.m4
163 %{_datadir}/build/*.awk
164 %attr(755,root,root) %{_datadir}/build/config.*
165 %attr(755,root,root) %{_datadir}/build/*.sh
166 %attr(755,root,root) %{_datadir}/build/libtool
167 %attr(755,root,root) %{_datadir}/build/gen-build.py
168 %{_datadir}/build-1
169 %{_pkgconfigdir}/apr-1.pc
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libapr-1.a
This page took 0.051659 seconds and 3 git commands to generate.