]> git.pld-linux.org Git - packages/apr-compat.git/blob - apr-compat.spec
- updated to 1.2.12
[packages/apr-compat.git] / apr-compat.spec
1 Summary:        Apache Portable Runtime
2 Summary(pl.UTF-8):      Apache Portable Runtime - przenośna biblioteka uruchomieniowa
3 Name:           apr
4 Version:        1.2.12
5 Release:        1
6 Epoch:          1
7 License:        Apache v2.0
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
10 # Source0-md5:  c5da94517e3918f0f2b2e0a05f56aa21
11 Patch0:         %{name}-link.patch
12 Patch1:         %{name}-metuxmpm.patch
13 Patch2:         %{name}-libtool.patch
14 URL:            http://apr.apache.org/
15 BuildRequires:  autoconf >= 2.13
16 BuildRequires:  automake
17 BuildRequires:  libtool >= 1.3.3
18 BuildRequires:  libuuid-devel
19 BuildRequires:  sed >= 4.0
20 BuildRequires:  python
21 BuildRequires:  uname(release) >= 2.6
22 Requires:       uname(release) >= 2.6
23 Conflicts:      kernel24
24 Conflicts:      kernel24-smp
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _includedir     /usr/include/apr
28 %define         _datadir        /usr/share/apr
29
30 %description
31 The mission of the Apache Portable Runtime (APR) project is to create
32 and maintain software libraries that provide a predictable and
33 consistent interface to underlying platform-specific implementations.
34 The primary goal is to provide an API to which software developers may
35 code and be assured of predictable if not identical behaviour
36 regardless of the platform on which their software is built, relieving
37 them of the need to code special-case conditions to work around or
38 take advantage of platform-specific deficiencies or features.
39
40 %description -l pl.UTF-8
41 Celem projektu APR (Apache Portable Runtime) jest stworzenie i
42 utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
43 interfejsu do leżących u podstaw implementacji zależnych od platformy.
44 Głównym celem jest dostarczenie API, którego mogą używać programiści
45 mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
46 identyczny, niezależnie od platformy na jakiej oprogramowanie jest
47 budowane oraz bez potrzeby kodowania specjalnych warunków do
48 obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
49 możliwości.
50
51 %package devel
52 Summary:        Header files and development documentation for apr
53 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programisty do apr
54 Group:          Development/Libraries
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56 Requires:       libuuid-devel
57 Requires:       automake
58 Requires:       libtool
59
60 %description devel
61 Header files and development documentation for apr.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe i dokumentacja programisty do apr.
65
66 %package static
67 Summary:        Static apr library
68 Summary(pl.UTF-8):      Statyczna biblioteka apr
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
71
72 %description static
73 Static apr library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka apr.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83
84 cat >> config.layout <<'EOF'
85 <Layout PLD>
86 sbindir:        %{_sbindir}
87 libexecdir:     %{_libdir}/apr
88 installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
89 localstatedir:  /var/run
90 runtimedir:     /var/run
91 libsuffix:      -${APR_MAJOR_VERSION}
92 </Layout PLD>
93 EOF
94
95 %build
96 install /usr/share/automake/config.* build
97 ./buildconf
98 %configure \
99         --enable-layout=PLD \
100 %ifarch %{ix86} %{i8664}
101 %ifnarch i386
102         --enable-nonportable-atomics \
103 %endif
104 %endif
105         --enable-threads \
106         --with-devrandom=/dev/urandom
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
116
117 mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
118 install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
119 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
120 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
121 ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
122 ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
123
124 sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
125         $RPM_BUILD_ROOT%{_bindir}/apr-1-config
126 sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
127         $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
128 sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc CHANGES docs/*.html
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/*
144 %attr(755,root,root) %{_libdir}/lib*.so
145 %{_libdir}/lib*.la
146 %{_libdir}/apr.exp
147 %{_includedir}
148 %dir %{_datadir}
149 %dir %{_datadir}/build
150 %{_datadir}/build/*.mk
151 %{_datadir}/build/*.m4
152 %{_datadir}/build/*.awk
153 %attr(755,root,root) %{_datadir}/build/config.*
154 %attr(755,root,root) %{_datadir}/build/*.sh
155 %attr(755,root,root) %{_datadir}/build/libtool
156 %attr(755,root,root) %{_datadir}/build/gen-build.py
157 %{_datadir}/build-1
158 %{_pkgconfigdir}/apr-1.pc
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
This page took 0.05583 seconds and 3 git commands to generate.