]> git.pld-linux.org Git - packages/apport.git/blob - apport.spec
- release 2 (fix qt dep)
[packages/apport.git] / apport.spec
1 Summary:        Read, write, and modify problem reports
2 Name:           apport
3 Version:        0.107
4 Release:        2
5 License:        GPL
6 Group:          Applications/System
7 Source0:        https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
8 # Source0-md5:  774dd4a28814b13bfbf5870abd5a65a8
9 Source1:        %{name}.init
10 Source2:        %{name}-backend-pld.py
11 Patch0:         %{name}-rpm-platform.patch
12 Patch1:         %{name}-rpm-deps.patch
13 URL:            https://wiki.ubuntu.com/Apport
14 BuildRequires:  gettext
15 BuildRequires:  intltool
16 BuildRequires:  python-devel >= 1:2.5
17 #BuildRequires: tetex-format-pdflatex
18 #BuildRequires: tetex-latex
19 # Need the ability to use pipes in /proc/sys/kernel/core_pattern
20 # seems only 2.6.24 allows command line params
21 Requires:       uname(release) >= 2.6.24
22 Requires(post,preun):   /sbin/chkconfig
23 Requires(post,preun):   /sbin/service
24 Requires(post,postun):  hicolor-icon-theme
25 Requires(post,postun):  shared-mime-info
26 Requires:       lsb-release
27 Requires:       python-rpm
28 Requires:       yum
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 apport automatically collects data from crashed processes and compiles
34 a problem report in /var/crash/.
35
36 This package also provides apport's python libraries and a command
37 line frontend for browsing and handling the crash reports.
38
39 See https://wiki.ubuntu.com/AutomatedProblemReports for more
40 information.
41
42 %package gtk
43 Summary:        GTK frontend for the apport crash report system
44 Group:          Applications/System
45 Requires:       procps
46 Requires:       python-pygtk-gtk
47 Requires:       python-pygtk-glade
48 Requires:       python-pyxdg
49
50 %description gtk
51 apport automatically collects data from crashed processes and compiles
52 a problem report in /var/crash/.
53
54 This package provides a GTK frontend for browsing and handling the
55 crash reports.
56
57 %package qt
58 Summary:        Qt4 frontend for the apport crash report system
59 Group:          Applications/System
60 Requires:       procps
61 Requires:       python-PyQt
62 Requires:       python-pyxdg
63
64 %description qt
65 apport automatically collects data from crashed processes and compiles
66 a problem report in /var/crash/.
67
68 This package provides a Qt4 frontend for browsing and handling the
69 crash reports.
70
71 %package retrace
72 Summary:        Tools for reprocessing Apport crash reports
73 Group:          Applications/System
74
75 %description retrace
76 apport-retrace recombines an Apport crash report (either a file or a
77 Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
78 stack traces.
79
80 This package also ships apport-chroot. This tool can create and manage
81 chroots for usage with apport-retrace. If the fakeroot and fakechroot
82 libraries are available (either by installing the packages or by
83 merely putting their libraries somewhere and setting two environment
84 variables), the entire process of retracing crashes in chroots can
85 happen with normal user privileges.
86
87 %prep
88 %setup -q -n ubuntu
89 %patch0 -p1
90 %patch1 -p1
91
92 %build
93 # only used by debian
94 rm apport/packaging.py
95 python setup.py build
96 %{__make} -C po
97 %{__make} -C gtk
98 %{__make} -C qt4
99 #%{__make} -C doc
100 # set up the packaging backend
101 cp backends/packaging_rpm.py apport
102 cp %SOURCE2 apport/packaging_pld.py
103 ln -s packaging_pld.py apport/packaging_impl.py
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 python setup.py install \
108         --optimize=2 \
109         --root=$RPM_BUILD_ROOT \
110         --install-scripts %{_datadir}/apport
111
112 %py_postclean
113
114 # Do the man pages
115 install -d $RPM_BUILD_ROOT%{_mandir}/man1
116 install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
117 # cron job
118 install -d $RPM_BUILD_ROOT/etc/cron.daily
119 install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
120 # create the dir for crash reports
121 install -d $RPM_BUILD_ROOT/var/crash
122 # install initscript
123 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
124 install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post
130 # Add proper symlinks in %{_sysconfdir}/rc*.d
131 /sbin/chkconfig --add apport
132 %update_mime_database
133 %update_icon_cache hicolor
134
135 %preun
136 if [ "$1" == "0" ]; then
137     %service apport stop > /dev/null
138     /sbin/chkconfig --del apport
139 fi
140
141 %postun
142 if [ "$1" -ge "1" ]; then
143     %service apport condrestart > /dev/null || :
144 fi
145 %update_mime_database
146 %update_icon_cache hicolor
147
148 %files
149 %defattr(644,root,root,755)
150 %dir /var/crash
151 %{_mandir}/man1/*
152 %{_iconsdir}/hicolor/*/apps/apport.svg
153 %{_datadir}/mime/packages/apport.xml
154 %{py_sitescriptdir}/apport-0.0.0-py*.egg-info
155 %dir %{_datadir}/apport
156 %attr(755,root,root) %{_datadir}/apport/apport
157 %attr(755,root,root) %{_datadir}/apport/apport-cli
158 %attr(755,root,root) %{_datadir}/apport/gcc_ice_hook
159 %attr(755,root,root) %{_datadir}/apport/apport-checkreports
160 %attr(755,root,root) %{_datadir}/apport/package_hook
161 %attr(755,root,root) %{_datadir}/apport/kernel_hook
162 %attr(755,root,root) %{_datadir}/apport/apport-unpack
163 %attr(755,root,root) %{_datadir}/apport/testsuite/
164 %dir %{_datadir}/apport/general-hooks/
165 %attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
166 %dir %{_datadir}/apport/package-hooks/
167 %attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
168 %{py_sitescriptdir}/apport_python_hook.py[co]
169 %{py_sitescriptdir}/problem_report*.py[co]
170 %dir %{py_sitescriptdir}/apport
171 %{py_sitescriptdir}/apport/*.py[co]
172 %dir %{py_sitescriptdir}/apport/crashdb_impl
173 %{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
174 %{_sysconfdir}/cron.daily/apport
175 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/apport
176 %dir %{_sysconfdir}/apport
177 %config %{_sysconfdir}/apport/crashdb.conf
178 %{_sysconfdir}/apport/blacklist.d
179
180 %files gtk
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_datadir}/apport/apport-gtk
183 %{_datadir}/apport/apport-gtk.glade
184
185 %files qt
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_datadir}/apport/apport-qt
188 %{_datadir}/apport/*.ui
189
190 %files retrace
191 %defattr(644,root,root,755)
192 %{_mandir}/man1/apport-retrace.1*
193 %attr(755,root,root) %{_datadir}/apport/apport-retrace
194 %attr(755,root,root) %{_datadir}/apport/apport-chroot
195 %attr(755,root,root) %{_datadir}/apport/dupdb-admin
This page took 0.093452 seconds and 3 git commands to generate.