]> git.pld-linux.org Git - packages/apport.git/blame - apport.spec
- release 2 (fix qt dep)
[packages/apport.git] / apport.spec
CommitLineData
7ce35e5c
PZ
1Summary: Read, write, and modify problem reports
2Name: apport
46774820 3Version: 0.107
a0ffb924 4Release: 2
7ce35e5c
PZ
5License: GPL
6Group: Applications/System
4f5ece38 7Source0: https://launchpad.net/ubuntu/hardy/+source/apport/%{version}/+files/%{name}_%{version}.tar.gz
46774820 8# Source0-md5: 774dd4a28814b13bfbf5870abd5a65a8
7ce35e5c 9Source1: %{name}.init
c8193fa4
PZ
10Source2: %{name}-backend-pld.py
11Patch0: %{name}-rpm-platform.patch
12Patch1: %{name}-rpm-deps.patch
7ce35e5c
PZ
13URL: https://wiki.ubuntu.com/Apport
14BuildRequires: gettext
15BuildRequires: intltool
16BuildRequires: python-devel >= 1:2.5
17#BuildRequires: tetex-format-pdflatex
18#BuildRequires: tetex-latex
19# Need the ability to use pipes in /proc/sys/kernel/core_pattern
20# seems only 2.6.24 allows command line params
21Requires: uname(release) >= 2.6.24
22Requires(post,preun): /sbin/chkconfig
23Requires(post,preun): /sbin/service
24Requires(post,postun): hicolor-icon-theme
25Requires(post,postun): shared-mime-info
56811d2d 26Requires: lsb-release
7ce35e5c
PZ
27Requires: python-rpm
28Requires: yum
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33apport automatically collects data from crashed processes and compiles
34a problem report in /var/crash/.
35
36This package also provides apport's python libraries and a command
37line frontend for browsing and handling the crash reports.
38
39See https://wiki.ubuntu.com/AutomatedProblemReports for more
40information.
41
42%package gtk
43Summary: GTK frontend for the apport crash report system
44Group: Applications/System
45Requires: procps
46Requires: python-pygtk-gtk
47Requires: python-pygtk-glade
48Requires: python-pyxdg
49
50%description gtk
51apport automatically collects data from crashed processes and compiles
52a problem report in /var/crash/.
53
54This package provides a GTK frontend for browsing and handling the
55crash reports.
56
57%package qt
58Summary: Qt4 frontend for the apport crash report system
59Group: Applications/System
60Requires: procps
a0ffb924 61Requires: python-PyQt
7ce35e5c
PZ
62Requires: python-pyxdg
63
64%description qt
65apport automatically collects data from crashed processes and compiles
66a problem report in /var/crash/.
67
68This package provides a Qt4 frontend for browsing and handling the
69crash reports.
70
71%package retrace
72Summary: Tools for reprocessing Apport crash reports
73Group: Applications/System
74
75%description retrace
76apport-retrace recombines an Apport crash report (either a file or a
77Launchpad bug) and debug symbol packages (.ddebs) into fully symbolic
78stack traces.
79
80This package also ships apport-chroot. This tool can create and manage
81chroots for usage with apport-retrace. If the fakeroot and fakechroot
82libraries are available (either by installing the packages or by
83merely putting their libraries somewhere and setting two environment
84variables), the entire process of retracing crashes in chroots can
85happen with normal user privileges.
86
87%prep
88%setup -q -n ubuntu
c8193fa4
PZ
89%patch0 -p1
90%patch1 -p1
7ce35e5c
PZ
91
92%build
c8193fa4
PZ
93# only used by debian
94rm apport/packaging.py
7ce35e5c
PZ
95python setup.py build
96%{__make} -C po
97%{__make} -C gtk
98%{__make} -C qt4
99#%{__make} -C doc
100# set up the packaging backend
c8193fa4
PZ
101cp backends/packaging_rpm.py apport
102cp %SOURCE2 apport/packaging_pld.py
103ln -s packaging_pld.py apport/packaging_impl.py
7ce35e5c
PZ
104
105%install
106rm -rf $RPM_BUILD_ROOT
107python setup.py install \
108 --optimize=2 \
109 --root=$RPM_BUILD_ROOT \
110 --install-scripts %{_datadir}/apport
111
112%py_postclean
113
114# Do the man pages
115install -d $RPM_BUILD_ROOT%{_mandir}/man1
116install man/apport-*.1 $RPM_BUILD_ROOT%{_mandir}/man1
117# cron job
118install -d $RPM_BUILD_ROOT/etc/cron.daily
119install debian/apport.cron.daily $RPM_BUILD_ROOT/etc/cron.daily/apport
120# create the dir for crash reports
121install -d $RPM_BUILD_ROOT/var/crash
122# install initscript
123install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
124install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/apport
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130# Add proper symlinks in %{_sysconfdir}/rc*.d
131/sbin/chkconfig --add apport
132%update_mime_database
133%update_icon_cache hicolor
134
135%preun
136if [ "$1" == "0" ]; then
137 %service apport stop > /dev/null
138 /sbin/chkconfig --del apport
139fi
140
141%postun
142if [ "$1" -ge "1" ]; then
143 %service apport condrestart > /dev/null || :
144fi
145%update_mime_database
146%update_icon_cache hicolor
147
148%files
149%defattr(644,root,root,755)
150%dir /var/crash
151%{_mandir}/man1/*
152%{_iconsdir}/hicolor/*/apps/apport.svg
153%{_datadir}/mime/packages/apport.xml
154%{py_sitescriptdir}/apport-0.0.0-py*.egg-info
155%dir %{_datadir}/apport
156%attr(755,root,root) %{_datadir}/apport/apport
157%attr(755,root,root) %{_datadir}/apport/apport-cli
158%attr(755,root,root) %{_datadir}/apport/gcc_ice_hook
159%attr(755,root,root) %{_datadir}/apport/apport-checkreports
160%attr(755,root,root) %{_datadir}/apport/package_hook
161%attr(755,root,root) %{_datadir}/apport/kernel_hook
162%attr(755,root,root) %{_datadir}/apport/apport-unpack
163%attr(755,root,root) %{_datadir}/apport/testsuite/
164%dir %{_datadir}/apport/general-hooks/
165%attr(755,root,root) %{_datadir}/apport/general-hooks/*.py
166%dir %{_datadir}/apport/package-hooks/
167%attr(755,root,root) %{_datadir}/apport/package-hooks/*.py
168%{py_sitescriptdir}/apport_python_hook.py[co]
169%{py_sitescriptdir}/problem_report*.py[co]
170%dir %{py_sitescriptdir}/apport
171%{py_sitescriptdir}/apport/*.py[co]
172%dir %{py_sitescriptdir}/apport/crashdb_impl
173%{py_sitescriptdir}/apport/crashdb_impl/*.py[co]
174%{_sysconfdir}/cron.daily/apport
175%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/apport
176%dir %{_sysconfdir}/apport
177%config %{_sysconfdir}/apport/crashdb.conf
178%{_sysconfdir}/apport/blacklist.d
179
180%files gtk
181%defattr(644,root,root,755)
182%attr(755,root,root) %{_datadir}/apport/apport-gtk
183%{_datadir}/apport/apport-gtk.glade
184
185%files qt
186%defattr(644,root,root,755)
187%attr(755,root,root) %{_datadir}/apport/apport-qt
188%{_datadir}/apport/*.ui
189
190%files retrace
191%defattr(644,root,root,755)
192%{_mandir}/man1/apport-retrace.1*
193%attr(755,root,root) %{_datadir}/apport/apport-retrace
194%attr(755,root,root) %{_datadir}/apport/apport-chroot
195%attr(755,root,root) %{_datadir}/apport/dupdb-admin
This page took 0.103093 seconds and 4 git commands to generate.