]> git.pld-linux.org Git - packages/apache1-mod_snake.git/blob - apache1-mod_snake.spec
- initial pld release (nfy; need port to v6)
[packages/apache1-mod_snake.git] / apache1-mod_snake.spec
1 %define         mod_name        snake
2 Summary:        An Apache module to allow for Python plugins and control
3 Summary(pl):    Modu³ do Apache pozwalaj±cy na kontrolê i wtyczki Pythona
4 Name:           apache-mod_%{mod_name}
5 Version:        0.5.0
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        fhttp://prdownloads.sourceforge.net/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
12 URL:            http://modsnake.sourceforge.net/
13 BuildRequires:  /usr/sbin/apxs
14 BuildRequires:  apache-devel >= 1.3.15
15 BuildRequires:  python-devel >= 1.5
16 Prereq:         /usr/sbin/apxs
17 Requires:       apache
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
21
22 %description
23 mod_snake is an Apache module which allows for execution of Python
24 code directly within the Apache server process. By including an
25 interpreter in the Apache process, Python CGIs are accelerated, Python
26 can be embedded within HTML and Python written modules can control the
27 internals of the webserver.
28
29 %description -l pl
30 mod_snake to modu³ Apache pozwalaj±cy na wykonywanie kodu Pythona
31 bezpo¶rednio w procesie serwera Apache. W³±czaj±c interpreter do
32 procesu Apache skrypty CGI w Pythonie s± znacznie przyspieszone.
33 Python mo¿e byæ umieszczany w HTMLu oraz modu³y Pythona mog±
34 kontrolowaæ wewnêtrzne sprawy serwera www.
35
36 %prep 
37 %setup -q -n mod_%{mod_name}-%{version}
38
39 %build
40 %configure2_13 \
41         --with-apxs=%{_sbindir}/apxs \
42         --enable-dso
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_pkglibdir}
48
49 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63         if [ -f /var/lock/subsys/httpd ]; then
64                 /etc/rc.d/init.d/httpd restart 1>&2
65         fi
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.91016 seconds and 3 git commands to generate.