]> git.pld-linux.org Git - packages/apache1-mod_snake.git/blob - apache1-mod_snake.spec
- use apache1(EAPI) for runtime dep
[packages/apache1-mod_snake.git] / apache1-mod_snake.spec
1 # NOTE
2 # - This project is RIP since Thu May 9 19:00:01 PDT 2002
3 # - and doesn't compile anyway
4 %define         mod_name        snake
5 %define         apxs            /usr/sbin/apxs1
6 Summary:        An Apache module to allow for Python plugins and control
7 Summary(pl.UTF-8):      Moduł do Apache pozwalający na kontrolę i wtyczki Pythona
8 Name:           apache1-mod_%{mod_name}
9 Version:        0.5.0
10 Release:        1.3
11 License:        GPL
12 Group:          Networking/Daemons
13 Source0:        http://dl.sourceforge.net/mod%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  7c043871a66a8579c6fec561c5d6cb84
15 Patch0:         %{name}-dumb_acam.patch
16 URL:            http://modsnake.sourceforge.net/
17 BuildRequires:  apache1-devel >= 1.3.39
18 BuildRequires:  python-devel >= 1.5
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires:       apache1(EAPI)
21 Obsoletes:      apache-mod_snake <= 0.5.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26
27 %description
28 mod_snake is an Apache module which allows for execution of Python
29 code directly within the Apache server process. By including an
30 interpreter in the Apache process, Python CGIs are accelerated, Python
31 can be embedded within HTML and Python written modules can control the
32 internals of the webserver.
33
34 %description -l pl.UTF-8
35 mod_snake to moduł Apache pozwalający na wykonywanie kodu Pythona
36 bezpośrednio w procesie serwera Apache. Włączając interpreter do
37 procesu Apache skrypty CGI w Pythonie są znacznie przyspieszone.
38 Python może być umieszczany w HTML-u oraz moduły Pythona mogą
39 kontrolować wewnętrzne sprawy serwera WWW.
40
41 %prep
42 %setup -q -n mod_%{mod_name}-%{version}
43 %patch0 -p0
44
45 %build
46 %configure2_13 \
47         --with-apxs=%{apxs} \
48         --enable-dso
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
54
55 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56
57 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
58         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 %service -q apache restart
65
66 %postun
67 if [ "$1" = "0" ]; then
68         %service -q apache restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
74 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.077261 seconds and 4 git commands to generate.