]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blame - apache1-mod_mp3.spec
- initial PLD spec
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
CommitLineData
f2fb9b0b
GS
1%define arname mod_mp3
2%define mod_name mp3
3Summary: MP3 Apache module
4Name: apache-mod_mp3
5Version: 0.25
6Release: 1
7License: distributable
8Group: Networking/Daemons
9Group(de): Netzwerkwesen/Server
10Group(pl): Sieciowe/Serwery
11Source0: ftp://ftp.tangent.org/pub/apache/%{arname}-%{version}.tar.gz
12Source1: %{arname}.conf
13URL: http://media.tangent.org/
14Requires: apache >= 1.3.12
15Prereq: grep
16Provides: %{arname}
17BuildRequires: apache >= 1.3.12
18BuildRequires: apache-devel >= 1.3.12
19BuildRequires: expat-devel
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _pkglibdir %(%{_sbindir}/apxs -q LIBEXECDIR)
23%define _sysconfdir /etc/httpd
24
25%prep
26%setup -q -n %{arname}-%{version}
27
28%description
29This turns apache into your basic RIAA hating, but every college
30student loving mp3 streaming server. It can play from a list of files,
31either straight through or randomly. It can also be used to cache
32mp3's into memory and have the server operate entirely from memory.
33Enjoy, groove, mp3s not included.
34
35%build
36%{__make}
37
38%install
39rm -rf $RPM_BUILD_ROOT
40install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
41
42install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
43install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
44
45gzip -9nf README ChangeLog LICENSE
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%post
51%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52if [ -f %{_sysconfdir}/httpd.conf ] && \
53 ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
54 echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
55fi
56if [ -f /var/lock/subsys/httpd ]; then
57 /etc/rc.d/init.d/httpd restart 1>&2
58fi
59
60%preun
61if [ "$1" = "0" ]; then
62 %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63 grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
64 %{_sysconfdir}/httpd.conf.tmp
65 mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
66 if [ -f /var/lock/subsys/httpd ]; then
67 /etc/rc.d/init.d/httpd restart 1>&2
68 fi
69fi
70
71%files
72%defattr(644,root,root,755)
73%config(noreplace) %{_sysconfdir}/mod_mp3.conf
74%attr(755,root,root) %{_pkglibdir}/mod_mp3.so
75%doc *.gz faq.html
This page took 0.108807 seconds and 4 git commands to generate.